"Minimal BASH like line editing is supported..." after kernel update

I am getting this infamous grub error screen. I already tried this solution https://askubuntu.com/questions/929833/how-do-i-boot-my-pc-from-grub/931327#931327 , but I can't find an initrd.img. When I try to boot it says "No video mode detected. Booting in blind mode" and then nothing happens

The problem is that I can't even boot a live disk, because I get the same grub screen there. Usually that is my way of choice to reinstall grub, but this time I really need help with this.

As i understand, no correlation between grub and live cd. Can you check that in your bios you have disabled "security boot" option and also make sure that as first priority you selected your usb/dvd with live cd.

Use this for Manjaro

I guess it is too late for that guide, since I already reinstalled a new GRUB, which boots, but doesn't find my Manjaro installation.

The Live CD problem was due to LiLi USB Creator. I have now made a live cd with another linux pc and am experiencing different problems.

I am stuck at https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader#Note

When I try to install efibootmgr I get a couldn't resolve host error. I can not install packages inside the chroot environment. Update-grub also doesn't work btw

1 Like

So I made it to install grub. Problem for installing packages was an empty /etc/resolv.conf . I added nameserver and I could install packages. Now I can't still run update-grub. I tried grub-mkconfig -o /boot/grub/grub.cfg, but since I have an NVMe SSD my /dev/sda1 is called /dev/nvme0n1p1 and grub-probe wants to install on /dev/sda1

Grub is so easy to reinstall, that doing so is usually the most efficient way to solve bootloader issues.

Obviously not if you have and NVMe SSD and your drive is not called /dev/sda

Try setting $esp (/boot/efi) to a nvme partition.
And do manual partitioning/installation.
Oh.. do not format that $esp partition in nvme if that is same for windows.

This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by