More help with MTP device connection

I'm struggling to find an approach to connecting devices via mtp which consistently works. I've been following https://wiki.archlinux.org/index.php/Media_Transfer_Protocol. I've asked about methods before but didn't really get anywhere. This time I'm looking for some help understanding what the problem actually is, maybe then I can find some solution myself.

Firstly, no matter what the device ( I have two Xperia Android Phones and two Creative Zen mp3 players), Dolphin recognises them and opens then without any trouble at all, so does KDE Connect work perfectly (on the Android devices). The trouble is I want to transfer playlists, and no media player works with these devices. I thought I could mount them manually and do something creative with rsync, but no mounting method works either.

  1. First on the list Android File Transfer - A very simple failure, no matter what I plug in . It just says "No Android device detected"

  2. Of the others, only mtpfs seems to be supported by the official repo, so I skipped to that. I edited the fuse.conf as instructed and carried out mtpfs -o allow_other ~/mnt. I get error returned by libusb_claim_interface() = -6LIBMTP PANIC: Unable to initialize device Unable to open raw device 0

Skipped the other FUSE options as they're not in the official repos

  1. Libmtp - I run lsusb as requested ( made sure I'm in the uucp user group) and get the results like it shows. I run mtp-detect and get exactly the same error as above libusb_claim_interface() = -6LIBMTP PANIC: Unable to initialize device

  2. Tried gio mount - using gio mount mtp://[usb:001,007]/ (where 001 and 007 were replaced by my listing from lsusb). It says gio: mtp://[usb:001,004]/: volume doesn’t implement mount

I've checked the udev rules and all devices are listed properly (I listed them last time I tried this)

None of the problems I'm having are listed in the troubleshooting section.

Can anyone help? Does anyone know what "libusb_claim_interface() = -6LIBMTP PANIC: Unable to initialize device" means?

This is a shot in the dark.

Mtp is not for file transfers - as in the sense of non media files.

When you connect your device you will often have a choice on the device of selecting which protocol to use - select file transfer to enable transfer of non media files.

Yep, I should have mentioned that. Those device which have that option are set to MTP (but setting them to mass storage doesn't make any difference). Of course, not all devices have this option (the Creative Zens for example).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by