Most browsers crash after the latest stable update (also vlc)

Specs:
OS: Manjaro Linux x86_64
Host: HP EliteBook 8540p
Kernel: 5.4.35-1-MANJARO
Packages: 1583 (pacman), 4 (flatpak)
Shell: zsh 5.8
Resolution: 1600x900, 1920x1080
DE: Plasma
WM: KWin
CPU: Intel i5 M 540 (4) @ 2.534GHz
GPU: AMD ATI Radeon HD 8870M / R9 M270X/M370X
Memory: 7818MiB

Before the latest update everything worked fine (I am on the stable branch)

Running various browsers from the terminal:
Chromium: v81.0.4044.122-1


Firefox: v75.0-1

The both crash before drawing a window

However;
Vivaldi: [AUR] v3.0.1874.33-1


and
Brave: betav1.8.83-1 and v1.7.98-1

Both vivaldi and brave work fine-ish, until you try to download anything (or for example save an image)
when the both crash, and neither manages to save a crash log as far as I could tell
here is an example video with vivaldi: https://gfycat.com/miserlyembarrassedboubou

for some reason vlc also does this: v3.0.9.2-1

I'd appreciate any help fixing this, as I have no idea what could cause this
I have read on another post on this forum that glibc might be responsible, and downgrading it (to 2.30) would fix it: It didn't

also, the rest of the system seems fine, with all kde stuff working as if nothing is wrong
so far only the browsers and vlc seem to be affected

also, Falkon seems to be unaffected, with it being able to download things as well,
electron apps (Discord and Caprine) also seem to be unaffected

I have tried:
Rebooting
Reinstalling them
Clearing their directories in ~/.cache/

What can cause something like this?

Have you tried different kernels? My google-fu seems to indicate this error may originate in kernel space. And you've re-booted, right?

Yes I have rebooted,
and now I have updated from 5.4.35-1[LTS] to 5.6.7-1, and It has not fixed the issue unfortunately

Create a new user and try them there

did that: https://pastebin.com/s9qx5Siw

firefox still doesn't work, however chromium starts (in the new "guest" user session) and does the same as the other two chromuim based browsers, crashing when downloading anything.

(pulling another one from my butt). Driver/Systemd issues?

@Ask philm?

1 Like

from my butt systemctl --failed

1 Like

well
it says

0 loaded units listed.

which doesn't sound helpful, to me at least

yeah it just says that your services are ok

firefox complains about appmenu-gtk-module
which I do not have installed and firefox does not say anything

While we are at getting things out of our butt, I would would say concentrate not on the apps themselves but it is probably something(s) common to these apps that is broken in the system, not the apps directly.
Maybe list all dependencies for these crashing apps and list all the dependencies shared between these apps?

edit: and as mentioned above, this appmenu-gtk-module, did you try to remove it? Reinstall it??

okay it seems after reinstalling the appmenu-gtk-module, the warning for it went away, but nothing else changed, all of them still do the exact same thing

here is the list of dependencies they all (vlc, vivaldi, brave, chromium, firefox) share: https://pastebin.com/w4cHUT0e

It is quite lengthy with 134 entries

So what is logged when it crashes now?

$ firefox
ExceptionHandler::GenerateDump cloned child 156152
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...

Basically the same, except without that warning

after some more digging around I have found that more apps crash than I first noticed
These: vlc firefox chromium vivaldi brave gimp audacity all crash the same way: segmentation fault

Here are all their common dependencies (now alphabetically)


It's now only 113

What is that the all share that can just crash them like that?

Could a graphics card setting have changed? I don't know much about Radeon but maybe worth checking out (I realize audacity is audio oriented but odd things happen sometimes :wink:).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by