Mount points are being switched/reversed between two SSD.

I have two SSD that I use for spare storage. They are setup with the following mount point - label.

/kingston - Kingston
/ubuntu - Ubuntu

(aside: the ubuntu was my old drive before switching to Manjaro, thinking I might switch back but, I love Manjaro now so much that I'm not going back and it's just storage at this point.)

Sometimes, the two mount points get switched and this after turning on the computer, restarting or coming up from hibernate (I'm not sure if it's happening with all or just a certain one at this point.)

When this happen, my Dolphin bookmarks stop working and if I go to each drive they are mounted in reverse and therefore open the other drive instead (as expected for being backwards, but unwanted.)

I'm able to fix the issue using KDE Partition Manager, where I just rename the mount point back to the correct location, then everything works again, for awhile.

I looked at /etc/mtab and they are indeed backwards and then are fine again after I fix it with KDE Partition Manager.

Note: as I write this, using Gparted, I ran the check on both drive without issue and I've tried changing the UUID to a new random one as well but, not sure if that will have any affect.

Also, there has been a few times where it boots in to maintenance mode and it says it couldn't mount the Kingston drive. I then sign in as root and just systemctl reboot, at which point things boot normally (although the drives were backwards again) but, that doesn't happen every time so, it's kind of random and can switch at times without booting into maintenance mode.

Any thoughts on what might be causing this issue?

Appreciate it!

The following is after fixing things with KDE Partition Manager:

➜  ~ blkid

/dev/sda1: UUID="C09B-E19D" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="a1089f21-4f67-4788-be7c-eeade603bc28"
/dev/sda2: UUID="381a1e65-4053-4115-b8c8-85d927d6baf5" TYPE="swap" PARTUUID="f24d432d-8217-4a49-a864-218c90da7bd5"
/dev/sda3: LABEL="Root" UUID="a62e6124-e6b3-44ba-a577-922d6ceac703" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="28653c65-a47a-4186-bac5-e5e5b0fdaaf9"
/dev/sda4: LABEL="Home" UUID="84a9ac75-a680-404c-ab7b-b39a24d0cbba" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="a7bd090b-e39b-4777-92f6-3e0e70e1f964"
/dev/sdb1: LABEL="Ubuntu" UUID="ba2a21e5-9d73-4d7a-a41c-896f3f9da509" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="Ubuntu" PARTUUID="74b982c4-adde-42e0-8f2f-1689fb1dac68"
/dev/sdc1: LABEL="Kingston" UUID="668b1543-5308-477d-a040-712d05b26db6" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="Kingston" PARTUUID="58f3f075-7d4a-4221-8ec9-9143255373c2"
➜  ~ subl /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=C09B-E19D	/boot/efi	vfat	umask=0077	0	2	
UUID=381a1e65-4053-4115-b8c8-85d927d6baf5	swap	swap	defaults,noatime,discard	0	2	
UUID=a62e6124-e6b3-44ba-a577-922d6ceac703	/	ext4	defaults,noatime,discard	0	1	
UUID=84a9ac75-a680-404c-ab7b-b39a24d0cbba	/home	ext4	defaults,noatime,discard	0	2	
/dev/sdc1	/kingston	ext4	defaults	0	0	
/dev/sdb1	/ubuntu	ext4	defaults	0	0	
➜  ~ subl /etc/mtab

proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
sys /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
dev /dev devtmpfs rw,nosuid,relatime,size=4039128k,nr_inodes=1009782,mode=755 0 0
run /run tmpfs rw,nosuid,nodev,relatime,mode=755 0 0
efivarfs /sys/firmware/efi/efivars efivarfs rw,nosuid,nodev,noexec,relatime 0 0
/dev/sda3 / ext4 rw,noatime,discard 0 0
securityfs /sys/kernel/security securityfs rw,nosuid,nodev,noexec,relatime 0 0
tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
tmpfs /sys/fs/cgroup tmpfs ro,nosuid,nodev,noexec,mode=755 0 0
cgroup2 /sys/fs/cgroup/unified cgroup2 rw,nosuid,nodev,noexec,relatime,nsdelegate 0 0
cgroup /sys/fs/cgroup/systemd cgroup rw,nosuid,nodev,noexec,relatime,xattr,name=systemd 0 0
pstore /sys/fs/pstore pstore rw,nosuid,nodev,noexec,relatime 0 0
none /sys/fs/bpf bpf rw,nosuid,nodev,noexec,relatime,mode=700 0 0
cgroup /sys/fs/cgroup/net_cls,net_prio cgroup rw,nosuid,nodev,noexec,relatime,net_cls,net_prio 0 0
cgroup /sys/fs/cgroup/cpu,cpuacct cgroup rw,nosuid,nodev,noexec,relatime,cpu,cpuacct 0 0
cgroup /sys/fs/cgroup/freezer cgroup rw,nosuid,nodev,noexec,relatime,freezer 0 0
cgroup /sys/fs/cgroup/devices cgroup rw,nosuid,nodev,noexec,relatime,devices 0 0
cgroup /sys/fs/cgroup/pids cgroup rw,nosuid,nodev,noexec,relatime,pids 0 0
cgroup /sys/fs/cgroup/perf_event cgroup rw,nosuid,nodev,noexec,relatime,perf_event 0 0
cgroup /sys/fs/cgroup/cpuset cgroup rw,nosuid,nodev,noexec,relatime,cpuset 0 0
cgroup /sys/fs/cgroup/blkio cgroup rw,nosuid,nodev,noexec,relatime,blkio 0 0
cgroup /sys/fs/cgroup/hugetlb cgroup rw,nosuid,nodev,noexec,relatime,hugetlb 0 0
cgroup /sys/fs/cgroup/rdma cgroup rw,nosuid,nodev,noexec,relatime,rdma 0 0
cgroup /sys/fs/cgroup/memory cgroup rw,nosuid,nodev,noexec,relatime,memory 0 0
mqueue /dev/mqueue mqueue rw,nosuid,nodev,noexec,relatime 0 0
systemd-1 /proc/sys/fs/binfmt_misc autofs rw,relatime,fd=37,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=958 0 0
hugetlbfs /dev/hugepages hugetlbfs rw,relatime,pagesize=2M 0 0
debugfs /sys/kernel/debug debugfs rw,nosuid,nodev,noexec,relatime 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,nosuid,nodev,noexec,relatime 0 0
configfs /sys/kernel/config configfs rw,nosuid,nodev,noexec,relatime 0 0
tmpfs /tmp tmpfs rw,nosuid,nodev 0 0
/dev/sda4 /home ext4 rw,noatime,discard 0 0
/dev/sda1 /boot/efi vfat rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0
tmpfs /run/user/1000 tmpfs rw,nosuid,nodev,relatime,size=809756k,mode=700,uid=1000,gid=1001 0 0
fusectl /sys/fs/fuse/connections fusectl rw,nosuid,nodev,noexec,relatime 0 0
/dev/fuse /run/user/1000/appimagelauncherfs fuse rw,nosuid,nodev,relatime,user_id=1000,group_id=1001 0 0
gvfsd-fuse /run/user/1000/gvfs fuse.gvfsd-fuse rw,nosuid,nodev,relatime,user_id=1000,group_id=1001 0 0
/dev/fuse /run/user/1000/doc fuse rw,nosuid,nodev,relatime,user_id=1000,group_id=1001 0 0
/dev/sdb1 /ubuntu ext4 rw,relatime 0 0
/dev/sdc1 /kingston ext4 rw,relatime 0 0

Use the UUID not /dev/sdN then all will be good :smiley:

3 Likes

Ha! Thanks, I was wondering about that.

Can I just edit /etc/fstab as root and call it a day?

1 Like

Yes, reboot to see the effect.

1 Like

Great, thanks again!

1 Like

Glad it worked.

Well, it was a random occurrence but, it makes more sense to use UUID either way so, I think it will probably address the issue. I'll update if it doesn't.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by