Mouse macro buttons work while wired, but not when wireless (G700)

So, I finally made the jump and left windows behind.
Installed Manjaro XFCE and managed to get everything working fine so far.
One thing that's making me go crazy is why I can't get my Logitech G700 to use the saved button macros.
The thing is, it works perfectly IF I have it connected using the USB cable. As soon as I unplug it and use in wireless mode, he looses all the configs.
I've installed Solaar and it recognizes the mouse and the battery when using the nano receiver in wireless mode as you can see bellow.
It has all the saved macros in the internal memory because when I first tried after the install it it had all the macros saved, I didn't have to program anything again.
I've also tried installing Piper to configure it and it recognized all the saved macros, but as soon as I unplug from the USB cable, none works.
I have no idea what's happening and was wondering if you could help me out.
Thanks a lot!

System:    Host: jpdesktop Kernel: 5.7.9-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: Xfce 4.14.2 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: Z170 PRO GAMING v: Rev X.0x serial: <root required> UEFI: American Megatrends 
           v: 3805 date: 05/16/2018 
Battery:   Device-1: hidpp_battery_2 model: Logitech G700 charge: 70% (should be ignored) status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i5-6600K bits: 64 type: MCP arch: Skylake-S rev: 3 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28009 
           Speed: 4100 MHz min/max: 800/4300 MHz Core speeds (MHz): 1: 4100 2: 4100 3: 4100 4: 4100 
Graphics:  Device-1: NVIDIA GK104 [GeForce GTX 670] vendor: ASUSTeK driver: nvidia v: 440.100 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.8 driver: nvidia resolution: 1920x1080~60Hz, 1680x1050~60Hz 
           OpenGL: renderer: GeForce GTX 670/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 
           Device-2: NVIDIA GK104 HDMI Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Device-3: JMTek LLC. USB PnP Audio Device(EEPROM) type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-3:2 
           Sound Server: ALSA v: k5.7.9-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6 
           IF: enp0s31f6 state: down mac: f8:32:e4:c0:25:c3 
           Device-2: Qualcomm Atheros AR9271 802.11n type: USB driver: ath9k_htc bus ID: 3-1:2 
           IF: wlp3s0u1 state: up mac: 64:70:02:1e:44:22 
Drives:    Local Storage: total: 2.19 TiB used: 1.23 TiB (56.0%) 
           ID-1: /dev/sda vendor: Western Digital model: WD1600AVJS-63WNA0 size: 149.05 GiB 
           ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
           ID-3: /dev/sdc type: USB vendor: Seagate model: ST320005 42AS size: 1.82 TiB 
Partition: ID-1: / size: 227.94 GiB used: 21.14 GiB (9.3%) fs: ext4 dev: /dev/sdb2 
Sensors:   System Temperatures: cpu: 70.0 C mobo: 27.8 C gpu: nvidia temp: 56 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 14% 
Info:      Processes: 199 Uptime: 1h 22m Memory: 15.58 GiB used: 4.59 GiB (29.5%) Init: systemd Compilers: gcc: 10.1.0 
           Shell: bash v: 5.0.18 inxi: 3.0.37 

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by