[MSI GS63VR 6RF] Manjaro doesn't boot after install

I have just installed Manjaro 17.1 on my MSI laptop ( GS63VR 6RF Stealth pro). Manjaro works fine, but I must have done something wrong with the bootloader, and I am able to boot it only using the live cd.
So, after installing Manjaro, I have followed the instruction on this guide

including the UEFI extra commands. My boot/efi partition seems to be on
/dev/nvme0n1 partion 1, hence I have modified the second command of the "UEFI - additional commands" section accordingly ( -d /dev/nvme0n1 -p1).
Still, this didn't fix my issue: when I reboot my computer, windows starts straight away. However something has changed: if I now boot from the live cd and then press c to access grub prompt, the instruction

search.file /etc/manjaro-release  root

doesn't work anymore, because there isn't any /etc directory (???). Anyway, if from the live cd menu I select "Detect EFI bootlader" the first two options are:

(hd2,gpt1) /efi/Boot/bootx64.efi
(hd2,gpt1) /efi/Manjaro/grubx64.efi

and then there are other entries that are microsoft or msi -related. Selecting the Manjaro.grubx64.efi I can successfully load my Manjaro system. I'm also aware of the specific bios settings mentioned in the previous guide for MSI laptops, and I think I've set them correctly.
Do you have any suggestion? Thanks a lot for your help guys, I really appreciate it a lot! :slight_smile:
This is the output of the command mentioned in the guide I've linked before:

efibootmgr -v
BootCurrent: 0004
Timeout: 2 seconds
BootOrder: 0004,0000,0003
Boot0000* Windows Boot Manager	HD(1,GPT,f4bc48cd-b863-4008-b747-db90337907bb,0x800,0x96000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
Boot0003* manjaro	HD(1,GPT,f4bc48cd-b863-4008-b747-db90337907bb,0x800,0x96000)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0004* UEFI: USB Hard Drive, Partition 2	PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/HD(2,MBR,0x5da30169,0x37c93c,0x2000)..BO
sudo parted -l 
Model: ATA ST2000LM007-1R81 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  1559GB  1559GB  ntfs         Basic data partition  msftdata
 3      1559GB  1982GB  423GB   ext4
 2      1982GB  2000GB  18.1GB  ntfs         Basic data partition  hidden, diag

Model:   (scsi)
Disk /dev/sdb: 7812MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      32.8kB  1872MB  1872MB  primary               boot
 2      1872MB  1876MB  4194kB  primary               esp

Model: Unknown (unknown)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name                          Flags
 1      1049kB  316MB  315MB  fat32        EFI system partition          boot, esp
 2      316MB   450MB  134MB               Microsoft reserved partition  msftres
 3      450MB   254GB  254GB  ntfs         Basic data partition          msftdata
 4      254GB   255GB  824MB  ntfs                                       hidden, diag
 5      255GB   256GB  944MB  ntfs         Basic data partition          hidden, diag
sudo blkid

/dev/nvme0n1: PTUUID="b0aa9fe3-c83b-4b34-ac09-5e3b7a7c7256" PTTYPE="gpt"
/dev/nvme0n1p1: LABEL="SYSTEM" UUID="7C6B-18B5" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="f4bc48cd-b863-4008-b747-db90337907bb"
/dev/nvme0n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="9e4638ac-96ee-441f-a4de-ea210d16c3d4"
/dev/nvme0n1p3: LABEL="OS_Install" UUID="50206C7E206C6D42" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="3d6b9596-1eb6-4f4d-907a-2936b8c7e9cf"
/dev/nvme0n1p4: UUID="F05228F15228BE6A" TYPE="ntfs" PARTUUID="ffd0fa44-f8d2-440e-8bfe-a4588339ce18"
/dev/nvme0n1p5: LABEL="WinRE tools" UUID="38346DA9346D6AB8" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="99cb3d02-e43c-402a-8000-8f4824a9c83d"
/dev/sda1: LABEL="Data" UUID="26C073C3C07397AF" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="e7af6060-2741-48e3-b17d-87ba6eac076f"
/dev/sda2: LABEL="BIOS_RVY" UUID="B61276141275D9B7" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="a7ece6d4-750b-4ace-97be-431e610683e7"
/dev/sda3: UUID="6900761d-66c7-4ac7-b1bf-baed54287e8a" TYPE="ext4" PARTUUID="8886f1df-e233-40eb-b800-812693305d0e"
/dev/sdb1: UUID="2018-07-01-08-28-47-00" LABEL="MJR17111" TYPE="iso9660" PARTUUID="5da30169-01"
/dev/sdb2: SEC_TYPE="msdos" LABEL="MISO_EFI" UUID="F4CA-AD32" TYPE="vfat" PARTUUID="5da30169-02"
findmnt -s

TARGET    SOURCE                                    FSTYPE OPTIONS
/boot/efi UUID=7C6B-18B5                            vfat   defaults,noatime
/         UUID=6900761d-66c7-4ac7-b1bf-baed54287e8a ext4   defaults,noatime

findmnt /boot/efi
/boot/efi /dev/nvme0n1p1 vfat   rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro

Edit: Finally fixed the super-annoying format.

Please read this tutorial and fix it, it is unreadable.

For the boot order try this first

and if it won't work, try this

First try this.

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -o 0003,0004,0000

Then check at bios-setup (F2) if you had set TPM to 2.0 with 1.x compatibility

Thanks a lot guys for your help!
I've first tried what gohlip was suggesting, but it didn't work, while the first suggestion of petsam worked:

Thanks a lot again!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by