MT7630e weird problem.


I have Asus X555lf with Manjaro KDE installed and my problem is im getting like higher speeds on other wifi networks but not on mine,my wifi network is stuck at 0.50mbps but when i speedtest my wifi from other pcs,phones it goes much higher than that.Tried older karnels,headers everything.Seems like my wifi does not like manjaro *jk.But its weird why im getting high internet speeds on other networks but not on mine.

If you get good speeds with the same laptop on other networks while running manaro KDE then the compatibility problem is between your router and the adaptor, not the operating system

1 Like

Try disabling IPv6 in your router and network manager. You can search the forum for more info on how to do that.

If there is no big improvement then you will need to provide your system info. Please post the output from:

inxi -Fxxxz

In the "network" section of that terminal output will be your adapter model and your driver. Search both your adapter and driver on the forum for common issues and fixes.

Please read this thread on how to post required information properly:

Good luck.

1 Like

Well the router is flirtz box and did some research changed it from wpa/wpa2 mixed to just wpa2 and disabled auto channel select and that kinda fixed it but now the speed is not constant like it will go to normal speeds and then it wil drop to 5kbs.

No system info no help. Bye bye.

Did you search your adapter and module for fixes as I suggested.


Was replying from phone did not had time to send outputs,but here you go:
System: Host: andrejmanjaro Kernel: 5.2.21-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.16.5
tk: Qt 5.13.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Machine: Type: Laptop System: ASUSTeK product: X555LF v: 1.0 serial:
Mobo: ASUSTeK model: X555LF v: 1.0 serial: UEFI: American Megatrends v: X555LF.603 date: 04/16/2019
Battery: ID-1: BAT0 charge: 4.0 Wh condition: 14.1/37.3 Wh (38%) volts: 7.6/7.6 model: ASUSTeK ASUS Battery type: Li-ion
serial: status: Discharging cycles: 233
CPU: Topology: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell rev: 4 L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17582
Speed: 799 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 799 2: 799 3: 799 4: 799
Graphics: Device-1: Intel HD Graphics 5500 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:1616
Device-2: NVIDIA GM108M [GeForce 930M] driver: N/A bus ID: 04:00.0 chip ID: 10de:1346
Display: x11 server: X.Org 1.20.5 driver: intel compositor: kwin_x11 resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) v: 4.5 Mesa 19.2.1 compat-v: 3.0
direct render: Yes
Audio: Device-1: Intel Broadwell-U Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:03.0
chip ID: 8086:160c
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus ID: 00:1b.0 chip ID: 8086:9ca0
Sound Server: ALSA v: k5.2.21-1-MANJARO
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8168 v: 8.047.04-NAPI
port: 4000 bus ID: 02:00.0 chip ID: 10ec:8168
IF: enp2s0 state: down mac:
Device-2: MEDIATEK MT7630e 802.11bgn Wireless Network Adapter vendor: Foxconn driver: mt7630e v: 2.3.8 port: 4000
bus ID: 03:00.0 chip ID: 14c3:7630
IF: wlp3s0f0 state: up mac:
Drives: Local Storage: total: 1.14 TiB used: 14.14 GiB (1.2%)
ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB speed: 6.0 Gb/s serial: rev: 3B6Q
scheme: GPT
ID-2: /dev/sdb vendor: HGST (Hitachi) model: HTS541010A9E680 size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm
serial: rev: A560 scheme: GPT
Partition: ID-1: / size: 191.70 GiB used: 14.14 GiB (7.4%) fs: ext4 dev: /dev/sda1
Sensors: System Temperatures: cpu: 36.0 C mobo: N/A
Fan Speeds (RPM): cpu: 2300
Info: Processes: 188 Uptime: 9m Memory: 7.23 GiB used: 1.50 GiB (20.7%) Init: systemd v: 242 Compilers: gcc: 9.2.0
Shell: bash v: 5.0.11 running in: konsole inxi: 3.0.36
(yes rip battery).
Yes i searched for my adapter and modules for fixes as you suggested.

Have you rebooted your router, and reset your router to the factory default yet.

Router setup and troubleshooting tips:

Yes i did.

Also, upgrade to kernel 5.3, but also test an older lts kernel as well.

I did a quick search and I think you may have a bios update available. You would want to double check on that.

Tried older karnels (4.14, 4.19) will try 5.3,bios already updated.

UEFI: American Megatrends v: X555LF.603 date: 04/16/2019

Alright tried this still same.

Perhaps look for a router firmware update if available. Otherwise try locking your BSSID to your preferred access point in your connections properties in NM. Also try setting a static IP through your router via mac address association.

If you cannot find anything to fix your problems I have written a service that might help with your issue. Worth a try I guess.

Not a fix, but it usually brings my connection back up in 5-6 seconds on my system.

Just this router is absolute garbage ffs.All other devices get high speeds on this router but not me,tho when i connect to another network i get expected speeds.So idk if its my PC or this crap router.

This sounds like a combination of your router and driver not working well together, but it can also be some strange component your ISP uses that your laptop isn't liking.

You need to go through every suggestion in my router guide and test everything I recommended.

Yeah thanks for your help,but seems like manjaro aint causing this,just this cancer router.

1 Like

Okay,problem fixed,bought new router.Thanks for your help :*


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by