Multiple EFI partitions after dual booting


This is my first try dual booting and it wasn't exactly stress free but I followed the dual boot guide by linux-aarhus and I have a few qualms left over:

  • Should I have two EFI partitions now according to this guide? Because I do and when booted into windows, the partition is visible as a mounted FAT32 drive, but not flagged as EFI. When I boot up, I first have to ESC to what looks like the older BIOS type screen (even though msinfo32 shows the BIOS mode is UEFI) before choosing the Manjaro EFI manually which then takes me to a Manjaro screen which also gives me the choice of booting to windows or Linux. I assume this is a consequence of having two partitions for two separate EFIs?

  • I get some weird system hang on startup of Manjaro (XFCE) and when I try to shutdown. The screen remains on but black, and the fans continue spinning. It eventually starts up but I haven't yet reached a time when it shuts down on its own.

  • In addition, after logging in I get large streaks or screen tears across the screen

From what I've seen the last two could be driver issues? I use a laptop (HP envy 13t) with dual Intel and nvidia graphics so I suppose I need to do something extra about this?
And the first discussed issue is not so much a problem for me. I suppose this will allow me to completely remove Linux easily as it has not edited the windows bootloader?

I'm very sorry for all the questions and I appreciate that perhaps they should be separate posts but I figured that they might all be simple fixes. Being a complete novice with Linux I'm afraid I don't know what detail to give you specifically but direct me to the right place and I can do my best!

Many thanks.

Unmount it from Windows and remove the drive letter attributed to it.
The reason why is safe to have two EFI partitions is that when you update your Windows it will not break Manjaro boot. Do not manually edit those two partitions, unless you have to and know what you are doing.

For all other issues there might be some fixes, but we really need the output from terminal of:
inxi -Fxxxz
so we can rely on some real hardware/drivers information.

Have you used any of the acpi_osi=! acpi_osi="Windows 2009" variants of kernel boot parameter ?

2 Likes

Your first issue is firmware related - a setting informing the system which system to load.

I reckon you may have what is called compatibility mode enabled in firmware make the system aware of both MBR and EFI boot.

For the rest I cannot be of help - others are much better at those things.

System:    Host: JP-PC Kernel: 4.19.28-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN 
           tk: Gtk 3.24.3 info: xfce4-panel wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP ENVY Laptop 13-ah0xxx v: Type1ProductConfigId serial: <filter> Chassis: 
           type: 10 serial: <filter> 
           Mobo: HP model: 8482 v: 69.28 serial: <filter> UEFI: Insyde v: F.13 date: 06/07/2018 
Battery:   ID-1: BAT0 charge: 37.9 Wh condition: 52.0/52.0 Wh (100%) volts: 15.5/15.4 model: 333-2B-49-A KC04053XL 
           type: Li-ion serial: <filter> status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28808 
           Speed: 900 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
           Device-2: NVIDIA GP108M [GeForce MX150] vendor: Hewlett-Packard driver: nouveau v: kernel bus ID: 01:00.0 
           chip ID: 10de:1d12 
           Display: x11 server: X.Org 1.20.4 driver: intel,modesetting alternate: fbdev,vesa resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 18.3.4 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:9d71 
           Sound Server: ALSA v: k4.19.28-1-MANJARO 
Network:   Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: 3000 bus ID: 04:00.0 chip ID: 8086:095a 
           IF: wlo1 state: up mac: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 6.08 GiB (2.5%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB256HAHQ-000H1 size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: EXD70H1Q scheme: GPT 
Partition: ID-1: / size: 43.43 GiB used: 6.08 GiB (14.0%) fs: ext4 dev: /dev/nvme0n1p8 
           ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p7 
Sensors:   System Temperatures: cpu: 50.0 C mobo: 44.0 C gpu: nouveau temp: 511 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 222 Uptime: 2m Memory: 7.54 GiB used: 1.09 GiB (14.5%) Init: systemd v: 241 Compilers: gcc: 8.2.1 
           Shell: bash v: 5.0.0 running in: xfce4-terminal inxi: 3.0.32

It took a few attempts to get this as the system rapidly slows down while in use to the point where it eventually froze completely the first time. To give some context it took 2 minutes to boot and over 10 minutes (i didnt wait) to shut down. I havent tried any boot paramaters though.

Ah, I wil try disabling this. Out of interest, does having two efi files enable me - should i ever want to - completely wipe the manjaro related partitions with no adverse effect on the windows partitions? I read about linux changing the windows bootloader but i assume this method avoids it? Many thanks for your guide by the way.

It should be doable - you will need to revert the firmware boot entry to Windows bootloader if you decide so. This was not my thought behind recommending it in the first place but you can call it a positive side effect of having two EFI partitions.

It is unfortunate that Windows shows the partition but you can - as @bogdancovaciu says - use the disk manager in Windows to remove the assigned driveletter and thereby remove it from the Windows File Explorer.

Only one $esp (EFI) partition can be active a any time. This is what the entry in the firmware does - setting the active partition (at least that is how I understand it).

TIP: When posting terminal output please format the text

  • select the pasted text
  • click the </> icon in the post toolbar
1 Like

It seems you are not using any driver for the second GPU, so is "using" the nouveau, but the iGPU is in fact used with the i915 driver.
Please have a look at the options for Optimus Laptops and chose one of the variants, but please read carefully so you can make a wise and informed decision

But would this cause the significant slowdown and freezing? I guess the only thing i can do is try and see - except it’s difficult to get anything done before it becomes unresponsive enough to be effectively unusable.

The unmounting worked just fine, and thanks for the tip. Couldnt find the the proper ‘ on my tablet keyboard but forgot about the ui options :sweat_smile:

You have a few issues in this one post. I won't (because I'm no good in it) address your graphics issue.
For a quick start, just let me say it is okay to have multiple $esp's.
And it is very okay (no, much much better) to have windows separate from the manjaro $esp.
And it is okay not to have a boot flag in Manjaro $esp because linux don't need a boot flag.
But remember windows $esp needs and must have a boot flag.
You can have multiple boot flags, or all flagged in all $esp's.
But really it is of no concern to linux. But if you want to, a command to set boot flag on sdb3 is as follows.

sudo parted /dev/sdb set 3 boot on

3 Likes

Wonderful thank you, I didn’t know if I had done something wrong there so I’m relieved at least in that respect.

1 Like

Re: the slowdown to unresponsiveness I don't know what to do :frowning: The memory usage isn't maxed so it doesn't seem to be thrashing. It couldn't be CPU frequency scaling because it seems to just get worse and worse instead of starting from bad. Not particular sure where I can start especially as I get about 4 minutes of usable time every reboot.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by