Multiple entries in bios

I just installed Manjaro next to Windows 10 according to this guide here:, when I restarted and entered the bios I noticed that there is an extra entry in the bios, one is Windows, another is manjaro and a third one that says HDD1: ST200, I tried booting form both this one and manjaro both are the same so I don't know what the difference is. Moreover when I run "efibootmgr -v" I noticed that everything is doubled, there are 2 Windows boot managers, 2 manjaros and 2 HDD1s, I tried to remove duplicated using the -b {xxxx} -B command but they're still there. Can somebody help?

Are there two seperate EFI partitions?
Maybe paste the output of: lsblk -o fstype,name,mountpoint


if that would be of benefit also


There are 2 windows entries but only 1 manjaro entry and 1 HDD entry. You said there are 2 of each? Explain.

Best to leave it alone. No other issues,right?

Yes you're right sorry. But you don't have an explanation as to why there two boot entries for Manjaro in the bios? Also another thing, I installed grub and it starts just fine but the thing is there is no Windows option, you don't happen to have a solution for that do you?

First, try "sudo update-grub"
Is there an entry for windows now?

If not, you have formatted out the efi partition ($esp), then .........
Can you boot windows after you installed manjaro? (any way you do it is fine)
You did not say. But let's check on it.
At Manjaro terminal, what is output for

ls /boot/efi/efi
ls /boot/efi/efi/Microsoft/
ls /boot/efi/efi/Microsoft/boot/

If you not have /efi/EFI/Microsoft/Boot/bootmgfw.efi, then you cannot boot windows. You have erased $esp when you installed windows. You need to reinstall back windows boot loader (I cannot advise how) and then reinstall back manjaro bootloader (We can advise how). In the installation wiki, you are told not to format the $esp.

That's because you've generated the entries twice. You can erase the older one or you can leave that alone. No harm.

Okay so no windows entry. First command outputs the Manjaro bootloader but there is no Microsoft folder. However windows boots just fine when I boot from it from the bios.

Can you answer this first before I assume things that may not be true?

You are able to boot windows now?
From the bios? What did you choose?
A windows entry like "Windows Boot Manager"
or a Hard drive entry
Hitachi P547y6vgfddb
WD kjjhuybv7667868678
HDD1 ;,lklokj

Yeah Windows boot loader or something like that definitely not a hard drive entry. To make it easier for you here are the commands outputs after a fresh Manjaro install (I'm running on an Acer Predator if that means anything)

*efibootmgr : bootmgr

*lsblk -o fstype,name,mountpoint: tree

*ls /boot/efi/efi
ls /boot/efi/efi/Microsoft/
ls /boot/efi/efi/Microsoft/boot/: efi

I haven't yet done anything from your grub post.

Just one more output. PRINT please not screen shot.

efibootmgr -v

Guacamole is right.
You have 2 disks and Windows $esp is in the other disk.
Your output is not complete with the other disk not provided.

Incomplete, omitted output. Bad.
Like journalists 'reporting' from the Middle East...or anywhere.


Dude why are you mad at me I didn't mean to offend you or withhold info I do appreciate your help. Yes I completely blanked about that I do apologize that's why I'm in the Newbie corner. Would you please continue to offer your help? The output for efibootmgr -v is :
BootOrder: 0001,2001,0002,0000,2002,2003
Boot0000* HDD1: ST2000LX001-1RG174 PciRoot(0x0)/Pci(0x17,0x0)/Sata(16,32768,0)/HD(2,GPT,91a03fa0-931e-4a66-a670-58a5c2b6dedd,0xc3608028,0x1007d8)RC
Boot0001* Manjaro HD(2,GPT,91a03fa0-931e-4a66-a670-58a5c2b6dedd,0xc3608028,0x1007d8)/File(\EFI\Manjaro\grubx64.efi)
Boot0002* Windows Boot Manager HD(1,GPT,1c4d9a3d-f1b9-403b-aea2-09cf1bfa3493,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
Boot0003* HDD1: ST2000LX001-1RG174 PciRoot(0x0)/Pci(0x17,0x0)/Sata(16,32768,0)/HD(2,GPT,91a03fa0-931e-4a66-a670-58a5c2b6dedd,0xc3608028,0x1007d8)RC
Boot0004* USB HDD: SanDisk PciRoot(0x0)/Pci(0x14,0x0)/USB(16,0)/HD(1,MBR,0x0,0x45a7dc,0x2000)RC
Boot2001* EFI USB Device RC
Boot2003* EFI Network RC

Alright, perhaps you did not understand what Guacamole was asking.

Go to your bios and change SATA drives to AHCI from RAID.
You may need to change your windows to use ACHI.
I've not needed to do anything about this, so I cannot help further.
Search this forum and see if any helps.
Maybe search external websites relating to your computer.

If you need further help here, suggest you start a new topic with 'achi' and' raid' so others can help you further.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by