My computer won't load Manjaro boot loader

Dear all,

I hope I will explain my problem as precise as possible, here we go:

I received a brand new HP Envy 13 laptop with Windows pre-installed. I had some experience with Linux in the past, so tried to give Manjaro a try (along side Windows: dual boot). Install went fine, except the Manjaro boot loader won't show up.

In my HP boot section the Manjaro boot loader does not appear (I know where to look). I tried some tips and commands I found via Google, but I do not really know what I am doing. Before I do more bad then good I decided to ask for help.

When I boot the USB Manjaro live version I can select the Manjaro UEFI file, so thats a start. I can boot in the Manjaro installation.

I believe this is some handy output:

Model: (onbekend) (unknown)
Schijf /dev/nvme0n1: 512GB
Sectorgrootte (logisch/fysiek): 512B/512B
Partitietabel: gpt

Nummer Begin Einde Grootte Bestandssysteem Naam Vlaggen
1 1049kB 274MB 273MB fat32 EFI system partition opstart, esp
2 274MB 290MB 16,8MB Microsoft reserved partition msftres
3 290MB 186GB 186GB ntfs Basic data partition msftdata
6 186GB 497GB 310GB ext4
4 497GB 498GB 1028MB ntfs Basic data partition verborgen, diag
5 498GB 512GB 14,3GB ntfs Basic data partition verborgen, msftdata

[wybren@envy ~]$ sudo blkid
/dev/nvme0n1: PTUUID="2fdc694f-b197-4a68-8d7c-8a139e5e7742" PTTYPE="gpt"
/dev/nvme0n1p1: UUID="BEDD-F080" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="4b4c5c39-d8b2-4236-bdf8-da5e98261340"
/dev/nvme0n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="89a22768-8f81-4f16-b27e-e5809c9ce34d"
/dev/nvme0n1p3: LABEL="WINDOWS" UUID="16B8D198B8D17729" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="77c0f4ec-61dd-42c4-9e4c-cb11dd2fd802"
/dev/nvme0n1p4: LABEL="Windows RE tools" UUID="5E16601E165FF58D" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="3d3d6d3e-fd4e-41ce-9ee1-5e9adad10923"
/dev/nvme0n1p5: LABEL="RECOVERY" UUID="40ACFF17ACFF0666" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="d89c8743-1ccb-425a-8367-c13338322a6b"
/dev/nvme0n1p6: UUID="93987146-7426-489c-bd3a-2bb00cd8a8cd" TYPE="ext4" PARTUUID="ecfe8bcd-6639-44d1-9a37-0ce7ca3875c4"
[wybren@envy ~]$ findmnt -s
/boot/efi UUID=BEDD-F080 vfat defaults,noatime
/ UUID=93987146-7426-489c-bd3a-2bb00cd8a8cd ext4 defaults,noatime
[wybren@envy ~]$ efibootmgr -v
Timeout: 0 seconds
BootOrder: 0001,2001,0003,0002,2002,2004
Boot0000* USB Hard Drive (UEFI) - SanDisk (SanDisk) PciRoot(0x0)/Pci(0x14,0x0)/USB(12,0)/HD(2,MBR,0xdd7c2bfe,0x37c93c,0x2000)RC
Boot0001* Windows Boot Manager HD(1,GPT,4b4c5c39-d8b2-4236-bdf8-da5e98261340,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}
Boot0002* USB Hard Drive - SanDisk BBS(7,USB Hard Drive - SanDisk,0x500)
Boot0003* Notebook Hard Drive - KXG50ZNV512G TOSHIBA BBS(HD,Notebook Hard Drive - KXG50ZNV512G TOSHIBA,0x500)................+..P....#..P?..P..................................g.o.......A...............................(.J...
Boot2001* EFI USB Device RC

Many thanks ins advance!

Boot into manjaro using this way or using 'Detect EFI bootloaders' of the install media.
As long as you boot into Manjaro in UEFI, any way is fine.

At step 6, do the [Additional UEFI commands] specifically...

sudo grub-install 
sudo update-grub
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/nvme0n1 -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

You may still (hopefully not) face problems and if you do, see the HP links in the "Some difficult UEFI setups" section.

Whenever you reboot (when there's a problem), please check with command efibootmgr and let us know if 'manjaro' bootentry is still there.

Good luck.

ps: It's late here and will respond tomorrow.
If @AgentS replies while I'm asleep, please follow his instructions.
Good luck.

1 Like

Works like a charm! Many thanks! Love the support.

1 Like

For the following please always set to solved if everything works.
I'll do that for you today :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by