My first impressions with Manjaro

Hello,
I am opening this topic to share my experience with Manjaro after 2-3 weeks of use. I would like to mention that I am not an expert linux user. I started with Ubuntu a decade ago, I used it for a couple of years as my main OS, than switched back to Win, in the last 4 years I used Linux Mint as my main OS. I am still using dual boot with W10, only for Adobe suite, rarely I need to do some home working. Apart Mint and Ubuntu I tested other distros, most of them based on Debian /Ubuntu. I also tried different DE but in the end I always get back to XFCE

But let's get back to Manjaro, I've read some articles and some comments about Manjaro, so I got curious, but at the same time a little worried since it is not based on Debian or derivates. I choose the XFCE edition which I have to say it's nice integrated in Manjaro. There was no need to install additional themes, the stock theme is similar to what I've got personalised on Mint XFCE.

The installation was easy, I asked a question on these forums and I was told to use UEFI, which I admit boots faster even on Win10.

Drivers: almost everything installed without problems. I tried to install the fingerprint-gui from AUR, but that package is not building. I always used fingerprint-gui on Mint/Ubuntu without problems. On Manjaro forums (or the wiki?!? ) I found I can use fprint which works fine, and IMHO is more accurate than fingerprint-gui. So not missing fingerprint-gui.

I was not able to start Blender, I was getting an error, something like my card is too old to use OpenGL. That was strange since I used the same version of Blender on Mint. In the end I found the solution here on forums, there was an nvidia package installed which should be removed. I am sure that I did not installed that package since I don't have a Nvidia card.

Packages and updates: Fantastic! Not missing apt, ppa ... A few days ago I got 1,4 GB of updates, I did a full backup and started the update. Everything went fine.

Stability, daily use: never had crashes. The system boots quickly and is very responsive.

Documentation and support: the documentation is complete and accurate. The forum is friendly and responsive. I read some good topics here and found many answers of my doubts on forums, so no need to post on forums :wink:

Overall my first impressions are positive, there is nothing I miss from Xubuntu/Mint XFCE, I like it! Congrats!

Sorry for the long post and my english.

My hardware:

[radu@ThinkPad-T450 ~]$ hwinfo --short
cpu:                                                            
                       Intel(R) Core(TM) i5-5300U CPU @ 2.30GHz, 2483 MHz
                       Intel(R) Core(TM) i5-5300U CPU @ 2.30GHz, 2180 MHz
                       Intel(R) Core(TM) i5-5300U CPU @ 2.30GHz, 2260 MHz
                       Intel(R) Core(TM) i5-5300U CPU @ 2.30GHz, 2607 MHz
keyboard:
                       Logitech Unifying Receiver
  /dev/input/event3    AT Translated Set 2 keyboard
mouse:
                       Logitech Unifying Receiver
  /dev/input/mice      SynPS/2 Synaptics TouchPad
  /dev/input/mice      TPPS/2 IBM TrackPoint
monitor:
                       AUO LCD Monitor
                       SAMSUNG SMFX2490HD
graphics card:
                       Intel HD Graphics 5500
sound:
                       Intel Wildcat Point-LP High Definition Audio Controller
                       Intel Broadwell-U Audio Controller
storage:
                       Intel Wildcat Point-LP SATA Controller [AHCI Mode]
network:
  wlp3s0               Intel Dual Band Wireless-N 7265
  enp0s25              Intel Ethernet Connection (3) I218-LM
  wwp0s20u4            Sierra Wireless EM7345 4G LTE
network interface:
  wwp0s20u4            Ethernet network interface
  enp0s25              Ethernet network interface
  lo                   Loopback network interface
  wlp3s0               Ethernet network interface
disk:
  /dev/sda             CT1000MX500SSD1
partition:
  /dev/sda1            Partition
  /dev/sda2            Partition
  /dev/sda3            Partition
  /dev/sda4            Partition
  /dev/sda5            Partition
  /dev/sda6            Partition
  /dev/sda7            Partition
  /dev/sda8            Partition
usb controller:
                       Intel Wildcat Point-LP USB EHCI Controller
                       Intel Wildcat Point-LP USB xHCI Controller
bios:
                       BIOS
bridge:
                       Intel Wildcat Point-LP PCI Express Root Port #6
                       Intel Wildcat Point-LP LPC Controller
                       Intel Broadwell-U Host Bridge -OPI
                       Intel Wildcat Point-LP PCI Express Root Port #3
hub:
                       Linux Foundation 3.0 root hub
                       Linux Foundation 2.0 root hub
                       Intel Hub
                       Linux Foundation 2.0 root hub
memory:
                       Main Memory
unknown:
                       FPU
                       DMA controller
                       PIC
                       Keyboard controller
                       Realtek RTS5227 PCI Express Card Reader
                       Intel Wildcat Point-LP MEI Controller #1
                       Intel Wildcat Point-LP SMBus Controller
                       Intel Wildcat Point-LP Thermal Management Controller
  /dev/input/event19   Chicony Electronics Integrated Camera
                       Validity Sensors VFS 5011 fingerprint sensor
                       Logitech Unifying Receiver
[radu@ThinkPad-T450 ~]$ inxi -Fxz
System:
  Host: ThinkPad-T450 Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.1.0 Desktop: Xfce 4.14.2 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 20BUS05W0A v: ThinkPad T450 
  serial: <filter> 
  Mobo: LENOVO model: 20BUS05W0A v: SDK0E50510 WIN serial: <filter> 
  UEFI: LENOVO v: JBET54WW (1.19 ) date: 11/06/2015 
Battery:
  ID-1: BAT0 charge: 18.3 Wh condition: 18.3/23.2 Wh (79%) 
  model: SANYO 45N1773 status: Unknown 
  ID-2: BAT1 charge: 20.4 Wh condition: 20.4/23.5 Wh (87%) 
  model: LGC 45N1127 status: Unknown 
  Device-1: hidpp_battery_0 
  model: Logitech M720 Triathlon Multi-Device Mouse 
  charge: 10% (should be ignored) status: Discharging 
CPU:
  Topology: Dual Core model: Intel Core i5-5300U bits: 64 type: MT MCP 
  arch: Broadwell rev: 4 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 18367 
  Speed: 798 MHz min/max: 500/2900 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting 
  resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 20.0.7 
  direct render: Yes 
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:03.0 
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.6.15-1-MANJARO 
Network:
  Device-1: Intel Ethernet I218-LM vendor: Lenovo driver: e1000e v: 3.2.6-k 
  port: 3080 bus ID: 00:19.0 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: efa0 
  bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
  IF-ID-1: wwp0s20u4 state: down mac: <filter> 
Drives:
  Local Storage: total: 931.51 GiB used: 56.63 GiB (6.1%) 
  ID-1: /dev/sda vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB 
Partition:
  ID-1: / size: 239.31 GiB used: 26.51 GiB (11.1%) fs: ext4 dev: /dev/sda7 
  ID-2: /home size: 461.65 GiB used: 30.13 GiB (6.5%) fs: ext4 
  dev: /dev/sda8 
  ID-3: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
Sensors:
  System Temperatures: cpu: 51.0 C mobo: 0.0 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 187 Uptime: 5h 49m Memory: 15.52 GiB used: 2.77 GiB (17.8%) 
  Init: systemd Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17 inxi: 3.0.37 

22 Likes

What a refreshing post. I must admit I usually find most of these threads closer to a rant than a review.

Nicely done, and welcome to the forum.

10 Likes

Hello,

You gave a splendid post, It's refreshing to read something positive. :grin: :grin: :+1: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap:

4 Likes

"PPA hell" is exactly why I will never use Ubuntu again. I know there is some risk involved with the AUR, but OMG is it ever convenient. :partying_face:

2 Likes

I hope you will enjoy here in Manjaro family. If you are facing issues please raise them if required.
Is your Blender issue solved?

Regards,
Sree

Welcome to the forum!

Usually people who are happy stay silent, and those who have problems complain loudly. It's nice to see someone posting something positive, which is more detailed than: "OMG I LOVE MANJARO" :smiley:

1 Like

Your English is fine :wink:
If your username is not an anagram, and is romanian Radu then i'm even more happy to see you around. First user story that had some cowbell in a long time :smiley: Nice read!
Cheers and welcome to Manjaro!

3 Likes

Thank you all for your kind words.

Yes, thank you. The issue is solved, I found the solution on this forum :wink: There was an Nvidia package that should be uninstalled.

I know this feeling very well, I own and manage a couple of automotive forums and I see this behaviour every day.

Thank you, that is correct, my name is Radu, I am born in Romania and I live in Italy since 2000. A few weeks ago I ended up in one topic where you exposed some of your work you made, I've seen your website, you did some nice caricatures, congrats!

3 Likes

Another thing that I did not mentioned in the first post is the battery life on my laptop, on Mint 19 without any tweak was horrible, but became pretty good if installed and congured TLP and Powertop. On Manjaro I didn't do anything, not even checked if TLP or Powertop were installed, battery life on my Thinkpad is good, similar to Win10 or Mint19 with some tweaks.

Tlp is installed by default in xfce, but you can still tweak it.


...and do not forget to look out for a new revision, things change from time to time on a rolling release.
Cheers

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by