My journey with Manjaro ARM on a Raspbery Pi 4

I decided to try and make a Raspberry Pi 4 as my daily computer.
(I guess I am a bit bored here in Covid lockdown.)

FYI, I am not much of a programmer.

I bought a Raspberry Pi 4, 8GB, a Argon Neo case for passive cooling, and the various other things one needs to use a Pi.

I like two linux distros, Manjaro and MX Linux.
Since MX has no ARM support, it seems obvious to try and put Manjaro on my Pi.

I tried KDE Plasma first, but there was a runnaway process, that ate so much CPU cycles, that the machine was unusable.
(There was a baloo process that was eating up 25-35% of CPU, and I could not figure out how to fix it.)

Then I tried the XFCE version.
So far no issues with it.

I have had some struggles though.

I have extensively customized Thunderbird email.
In the past when I have a new computer, I just copy the thunderbird folder in home directory from my old computer to the new one.
Did not work this time.
It seems the previous computer was running thunderbird 68.11.0 and Manjaro Arm uses 68.10.0
So, I can either wait till it gets updated to 68.11.0 or spend a long time reconstructing things in a fresh thunderbird. Ouch!

The other big software problem I am having is with Wildvine.
As I use my daily computer to watch videos, including Netflix and Hulu, I need the Wildvine software to do that, and according to my limited understanding, there is still no official 64 bit ARM version of Wildvine.
I found some posts on this forum aimed at Pinebook users, that promised a workaround to create a Chromium that somehow uses a 32 bit version of arm wildvine, but tricks the system so it works, Chromium-Armv7.
I could not get this to work.
(I believe I mentioned above that I am not much of a programmer.)
Perhaps this is for the best. I have been watching FAR to much Netflix and Hulu during lockdown.

Hardware issues are heat and speed.

I REALLY like passive cooling, so a fan case was not an option for me.
I choose the Argon Neo case because the metal plate that goes over the cpu/gpu/etc has only a few milimeters clearance, so i could place a bunch of thermal pads on chips not directly cooled by other passive cases.

Still, to play video effectively in a browser, with the current situation that Pi has with youtube playback, really needs over clocking.

But with high overclocking and passive cooling of the case, AND how hot it is in my home in August, means the computer gets too hot if I watch for more than a half an hour.

With moderate overclocking, it gets hot, but does not throttle.
1800 GHz for the CPU, 600 GHz for the GPU (fyi, it ships with 1500 and 500 respectively)

At this setting I can watch youtube videos mostly fine, key word being mostly.
The computer is only JUST strong enough.
(Or youtube video playing code is not efficient enough.)

I have ordered a 2 1/2 inch by 1 1/2 inch heat sink which I will stick on the top of the case. This should improve cooling considerably, which may mean I can over clock higher.

Also, I am waiting on a M.2 usb enclosure I ordered. When I get that, I can pop in a m.2 drive that I already have, and use it as the boot drive. Reports online suggest that switching from micro SD card booting to fast usb booting greatly improves performance.

While I have had some problems, over all, I am pleased.
Manjaro's ARM implementation, at least the XFCE version, is amazing.
This tiny under powered computer is working out. I really believe I can use it for my daily tasks. Video playback is the only thing I do regularly that makes the Pi seem a bit weak, and software improvements will keep coming to improve that.

I want to thank all of you that have worked to make Manjaro ARM a reality.
I believe that the future of computer is RISC (ARM and RISC-V), and that you all are helping to make it happen.

1 Like

On KDE we have a menu.
Open it and type 'baloo'
Select the 'file indexer' option (there are two, you can try both)
Then click 'suspend', or otherwise modify the config.

Maybe too complicated?
baloo
:face_with_hand_over_mouth::face_with_raised_eyebrow:

While I did not try that exact thing, I did try killall in terminal, and killing via a system monitor i installed. It did not die.
Even when rebooting, it would hang the reboot up, it was so resistant to dying.

I tried uninstalling it, but that ■■■■■■■ the OS.

Anyway, I am happy with XFCE, so I am not motivated to go back to KDE Plasma and spend time fixing it.

EDIT:
How odd, it censored the word b r i c k e d.
Is that a swear word in some language I am not aware of?

br1cked himself in English means the same as Shat himself... maybe that's it :wink: :rofl:

Ha! I did not know that. In the USA, its used to refer to a non functional computer.

Slang sure is different between the two countries.....Pissed means angry in USA, but i believe it means drunk in England.

1 Like

@spikerguy created a package for this called chromium-docker, which basically creates a docker container with 32-bit chromium and widevine when you install it. So it should be as easy as running sudo pacman -S chromium-docker and it will create an icon in your menu for Chromium, which should have widevine support. @appelgriebsch also created something similar for his work on Sway, but without the docker stuff.

I'm glad to hear that you are glad for your Manjaro ARM install overall. :slight_smile:

2 Likes

I use USB boot it is much faster, SD card is slow like HDD
Youtube is ok only to 720p on my raspberry4 in Firefox
I found Plasma needs less tweaking then Manjaro XFCE4-compositor is laggy
I use Rpi4 daily as desktop computer.

This is what I tried, and it did not work.

I also tried
sudo pacman -U https://www.uex.dk/public/manjaro/arm-unstable/community/aarch64/chromium-docker-4.10.1610.6-1-aarch64.pkg.tar.xz
Which was suggested by another user.

I also tried
sudo usermod -aG docker $(whoami)
to fix potential docker permission issues.

What happens is Chommium Armv7 launches via the terminal, then quits a few seconds later.

Here are the error messages
$ /usr/local/bin/chromium-armhf
Enabling XHost Forwarding
non-network local connections being added to access control list
Searching for Docker image ...
Found and using 27e85e9e1f2f
/usr/bin/chromium-browser: line 133: lsb_release: command not found
/usr/bin/chromium-browser: line 134: lsb_release: command not found
[1:1:0806/174059.865463:ERROR:process_singleton_posix.cc(294)] The profile appears to be in use by another Chromium process (1) on another computer (dcb9edaa84da). Chromium has locked the profile so that it doesn't get corrupted. If you are sure no other processes are using this profile, you can unlock the profile and relaunch Chromium.
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:CRASHING:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:CRASHING:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:CRASHING:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:CRASHING:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:CRASHING:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:CRASHING:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:CRASHING:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:CRASHING:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:CRASHING:seccomp-bpf failure in syscall 0403
[1:23:0806/174110.316445:FATAL:gpu_data_manager_impl_private.cc(986)] The display compositor is frequently crashing. Goodbye.

Ah yes. That old bug. @spikerguy a change of an updated docker container?

1 Like

There are a lot of good workarounds for YouTube (web browsers are about the least efficient way to do anything). You might try FreeTube (I haven't tried it yet). One thing I do on slower machines is go to youtube, perform my search or whatever, then right click on the video (instead of clicking on it), copy the url, then open up VLC, ctrl-N to open a network stream, then paste in the youtube URL. Works like a charm, as long as youtube-dl is up-to-date.

Most of the videos I watch in the browser are not on youtube, but in 3rd party sites that are not usable by youtube apps.

It's ok tho, videos dont play great in the browser but they do play well enough.

Sometimes chromium plays better than firefox.

This is true, I think Chromium gets more optimization on ARM devices than Firefox. :confused:

Forum kindly sponsored by