My manjaro is 4 minutes late !

Hello !
I am puzzled since yesterday : my Manjaro Xfce install is 4 minutes late (compared to UTC or to my Xubuntu or my iPhone.

I never did any time or date setup apart the install timezone choice.

1 Like

Open Manjaro Settings Manager -> Time & Date and enable "Automatically set time and date".

1 Like

Done and back to real time :wink:

The only drawback is that I have an additional continuous query on the net :stuck_out_tongue:

Still a little puzzled : my xubuntu and my debian are on manual and are on time, how comes ?

Are they on the same machine?
If not, the BIOS clock may to 4 minutes apart on the 2(3) devices.

https://wiki.archlinux.org/index.php/Systemd-timesyncd

sudo systemctl enable --now systemd-timesyncd

Did it leave the house on time? Maybe there was traffic?

Does this "--now" not require a reboot? Sure?
How about "--start" or "--restart" ?

The service starts and a symlink is created.

No need to restart. (systemd >= 220)

https://wiki.archlinux.org/index.php/Systemd

Enable a unit to be started on bootup and Start immediately:

# systemctl enable --now *unit*
2 Likes

@Strit : different PCs (first time I notice such a gap though)

@linux-aarhus : it's the command line version of Strit's advice, isn't it ?

I am not sure - if I remember correct - the setting in Manjaro Settings Manager is based on ntp daemon which is not installed on the system.

Thanks for the explanation but ...

on bootup? Isn't that a restart?

I am just curios, why isn't this set by default?

I just checked my setting and it was not checked, and as soon as I turned it on, my clock changed by 2 minutes.

Yes - but the --now starts the service immediately - think of it as a condensed version of

sudo systemctl enable service && sudo systemctl start service

1 Like

Good question.
We set it in Manjaro ARM.

man systemctl:

enable UNIT..., enable PATH...
Enable one or more units or unit instances. This will create a set
of symlinks, as encoded in the "[Install]" sections of the
indicated unit files. After the symlinks have been created, the
system manager configuration is reloaded (in a way equivalent to
daemon-reload), in order to ensure the changes are taken into
account immediately. Note that this does not have the effect of
also starting any of the units being enabled. If this is desired, combine this command with the --now switch
, or invoke start with appropriate arguments later.

1 Like

Okay. That's not my experience though, maybe on older versions of systemd.
And timedatectl (part of systemctl) requires a restart.
So to be safe, I'd just reboot.
But good to hear if you are right.
That's one of the things people complain about systemd (needing a reboot) when it was introduced.

Thanks for elaborating.
I'm as OCD as you. :rofl:

Thanks @Marte
just saw your post. Good one.

I have no problems if it is not default set.
As long one or two regular OS has ntp enabled.
Oh... sorry I have lots of distro's.
Sorry for the noise.
I disable ntp on many of them.
Cheers.

I remember well - it is only lately I have come around the --now and it is really easier than typing two almost identical commands.

It is set on Openbox, LXDE and LXQt - and has for some time now.

I added it due to a topic on the forum - long time ago - complaining about time sync not enabled by default and the MSM enable didn't work at that time and as the Arch Wiki notes - this is a time client - I knew it from Raspberry Pi - though it had another name then and was not a predefined service.

But searching the forum it seems to be a recurring topic - wonder why so many ask before searching the forum.

As I remember it was this topic which made me add the systemd-timesyncd to the list of services enabled in the Openbox, LXDE and LXQt ISO profiles.

And another time related topic - dual-booting Manjaro/Windows

2 Likes

Now match your system time with the most accurate atomic clock time.

You really need to sync to a public stratum-1 timeserver for accuracy.

I use the WWV subset from NIST.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by