My wifi connection keeps dropping (yet another topic about this)

Hi! My connection keeps falling periodically. It can go stable for an entire day, but it can be as bad as falling every five minutes. The network manager applet icon stays the same as if I was still connected, but I'm not able to load any page. I'm using manjaro for a year, but this behavior only started maybe a week or two ago. It happens both at work and at home.

Relevant lshw output:

description: Wireless interface
                product: QCA6174 802.11ac Wireless Network Adapter
                vendor: Qualcomm Atheros
                physical id: 0
                bus info: pci@0000:03:00.0
                logical name: wlp3s0
                version: 32
                serial: 0c:96:e6:eb:d1:3f
                width: 64 bits
                clock: 33MHz
                capabilities: bus_master cap_list ethernet physical wireless
                configuration: broadcast=yes driver=ath10k_pci driverversion=4.19.98-1-MANJARO firmware=WLAN.RM.4.4.1-00140-QCARMSWPZ-1 ip=10.1.0.44 latency=0 link=yes multicast=yes wireless=IEEE 802.11
                resources: irq:129 memory:df200000-df3fffff

lspci -k:

03:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
	Subsystem: Dell QCA6174 802.11ac Wireless Network Adapter
	Kernel driver in use: ath10k_pci
	Kernel modules: ath10k_pci

I think it has something to do with this dmesg output. If I keep watching it, the connection drops precisely when this happens:

[10653.936352] wlp3s0: disconnect from AP 0c:80:63:06:fc:e9 for new auth to b0:be:76:43:fb:29
[10653.943816] wlp3s0: authenticate with b0:be:76:43:fb:29
[10653.994547] wlp3s0: send auth to b0:be:76:43:fb:29 (try 1/3)
[10653.995386] wlp3s0: authenticated
[10654.014758] wlp3s0: associate with b0:be:76:43:fb:29 (try 1/3)
[10654.028214] wlp3s0: RX ReassocResp from b0:be:76:43:fb:29 (capab=0x411 status=0 aid=3)
[10654.031485] wlp3s0: associated

It general, the two relevant addresses are the same, wlp3s0 for some reason keeps switching between the two every now and then.

I already tried setting random mac address as no. Didn't any help. Here's my /etc/NetworkManager/NetworkManager.conf

# Configuration file for NetworkManager.
# See "man 5 NetworkManager.conf" for details.
[device]
wifi.scan-rand-mac-address=no

Any help is appreciated!

First thing I'd try is to "disable MAC Address randomization". If you search those terms on the forum you should easily be able to find instructions on how to do that.

The next thing to try is to try adding this kernel boot parameter:

pcie_aspm=off

Most every fix for the qca6174 is given on this thread:

Did you fix it? Have the same problem with Manjaro KDE, but Manjaro Gnome works fine for me. I think it has to do something with the power saving thing? But don't know for sure.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by