Need advice on resolving No Signal while gaming on AMD RX 580

Hi All,

For about the past four (4) months, I have been trouble gaming because my monitor will display the following message while playing some, but not all, games.

No signal Entering the power saving mode shortly

When this happens, I have to force reboot the machine.

This message occurs predictably with Doom (2016) and Metro Redux/Lastlight, but not with Rise of the Tomb Raider or Company of Heroes 2.

I have searched the Internet, including these forums, for solutions and none have worked. Things I have tried but not worked are the following:

Performance Mode

sudo cpupower frequency-set -g performance

Setting Kernel Parameters

idle=nomwait rcu_nocbs=0-15 processor.max_cstate=1 iommu=off

Disabling power management of the display

The system is stable with normal desktop use. After months of internet searches, I believe the issue is AMD graphics driver because same issue seems to affect some, but not all, Windows users who have AMD polaris and navi graphics.

I am very frustrated. Although I prefer AMD over Nvidia, if I cannot resolve this issue, I am going to ditch AMD and move to an Nvidia card. I researched the possibility of upgrading to a Vega 56 or RX 5600XT; however, the stability issues seem to plague these gpu's too. I want stability when I game.

Any new ideas on preventing the monitor from going to sleep while gaming will be appreciated.

Cheers!

System:
CPU: AMD Ryzen 2700x
RAM: 16Gb DD4 3200
GPU: AMD 580 8Gb
OS: Manjaro-XFCE
Kernel: 5.5.13-1
Mesa: 19.3.5
Proton: 5.0-5, 4.2-9, 3.16-9

Hi there .. these might be helpful:

inxi -Fxxxza --no-host
mhwd -li

Thank you for the quick reply.

Output of the inxi -Fxxxza --no-host

System: Kernel: 5.5.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0
parameters: BOOT_IMAGE=/vmlinuz-5.5-x86_64 root=UUID=a5b82288-cfcb-4586-9e2c-274744c3ac65 rw quiet
udev.log_priority=3
Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine: Type: Desktop Mobo: ASRock model: B450M Pro4 serial: UEFI [Legacy]: American Megatrends v: P3.60
date: 07/31/2019
CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 8 stepping: 2
microcode: 800820D L2 cache: 4096 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 118202
Speed: 2493 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz): 1: 2493 2: 2168 3: 2135 4: 2162 5: 2191
6: 2205 7: 2191 8: 2193 9: 2158 10: 2193 11: 2189 12: 2203 13: 2194 14: 2188 15: 2427 16: 2158
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Micro-Star MSI driver: amdgpu v: kernel bus ID: 06:00.0 chip ID: 1002:67df
Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa tty: N/A
OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.36.0 5.5.13-1-MANJARO LLVM 9.0.1) v: 4.5 Mesa 19.3.5
direct render: Yes
Audio: Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Micro-Star MSI driver: snd_hda_intel
v: kernel bus ID: 06:00.1 chip ID: 1002:aaf0
Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASRock driver: snd_hda_intel v: kernel
bus ID: 08:00.3 chip ID: 1022:1457
Sound Server: ALSA v: k5.5.13-1-MANJARO
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8168 v: 8.048.00-NAPI
port: f000 bus ID: 04:00.0 chip ID: 10ec:8168
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac:
Drives: Local Storage: total: 1.03 TiB used: 688.70 GiB (65.5%)
ID-1: /dev/sda vendor: Toshiba model: TR150 size: 111.79 GiB block size: physical: 512 B logical: 512 B
speed: 6.0 Gb/s serial: rev: 12.3 scheme: MBR
ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-00WN4A0 size: 931.51 GiB block size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: rev: 1A01 scheme: GPT
ID-3: /dev/sdg type: USB vendor: SanDisk model: Cruzer Pop size: 7.45 GiB block size: physical: 512 B
logical: 512 B serial: rev: 1.26 scheme: MBR
Partition: ID-1: / raw size: 111.29 GiB size: 109.04 GiB (97.98%) used: 48.78 GiB (44.7%) fs: ext4 dev: /dev/sda2
ID-2: /boot raw size: 512.0 MiB size: 487.9 MiB (95.30%) used: 145.3 MiB (29.8%) fs: ext4 dev: /dev/sda1
ID-3: /home raw size: 931.51 GiB size: 916.77 GiB (98.42%) used: 639.78 GiB (69.8%) fs: ext4 dev: /dev/sdb1
Sensors: System Temperatures: cpu: 39.5 C mobo: 30.0 C gpu: amdgpu temp: 30 C
Fan Speeds (RPM): fan-1: 1222 fan-2: 1867 fan-3: 1208 fan-4: 0 fan-5: 0 gpu: amdgpu fan: 1151
Voltages: 12v: N/A 5v: N/A 3.3v: 3.38 vbat: 3.30
Info: Processes: 351 Uptime: 34m Memory: 15.57 GiB used: 1.95 GiB (12.5%) Init: systemd v: 244 Compilers: gcc: 9.3.0
Shell: zsh v: 5.8 running in: guake inxi: 3.0.37

Output of mhwd -li

Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

     network-r8168            2016.04.20                true            PCI
       video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

Progress Update.

Yesterday, when playing Doom (2016) at the very end of the game where after defeating the last baddie, the screen goes white and the message on the monitor says 'No signal Entering the power saving mode shortly' message and I had to force reboot, thus unable to complete the game. It happened every time and seemingly no known cause why this occurs.

As stated above, the issue where the monitor looses connectivity to the computer and displays a 'No signal Entering the power saving mode shortly' message has been happening for the past four months while gaming with some, but not all, games. Very annoying indeed.

This morning, I got past the white screen after defeating the final 'baddie' after I did the following:

LG Monitor Setting

  • Disabled FreeSync
  • Disabled Displayport 1.2

Note: I have a single (1) monitor (an LG 34" UltraWide 2560x1080 60/75Hz)

XFCE Settings

  • Power - Disabled blanking of display
  • Display - 2560x1080 @ 60 Hz

In-Game(Doom) Options

  • OpenGL 4.5
  • Disabled Motion Blur

Note: The following parameters were also set

  • BIOS settings were at default
  • CPU scheduler is set to 'schedutil'
  • Kernel parameters were at default
  • Display power management (dpm) in
  • /sys/class/drm/card0/device/power_dpm_force_performance_level is set to low instead of auto

System Settings:

  • Kernel: 5.5.13-1
  • Mesa: 19.3.5

Game Specific Settings:

  • Set Launch Options in Steam

-NoLauncher -NoStartupMovies +com_skipIntroVideo 1

  • Proton: 5.0-5

Just to repeat, after applying the above, I was able to get past the white screen at the end of the game, and complete it. I don't know whether the fix was due to a single change or multiple settings that I happen to discover.

Because I have been having the same issue (i.e., monitor losing connection to the PC and displaying 'No signal Entering the power saving mode shortly') with other first person shooter games (e.g., Metro 2033 and Lastlight), I will be playing these games with these setting and see if the issue is resolved as well.

I hope this post helps others who game on Manjaro and experience the same monitor issue; however, I prefer this issue does not occur for Linux users/gamers.

I determined that my issue was with the graphics card, an MSI RX 580 8GB Armor OC, was overheating. I installed from the AUR the Radeon Profile utility and used it to monitor the graphics card temperature when playing games.

After installing, I launched the utility in a terminal and entered the command.

sudo /usr/bin/radeon-profile

The utility conveniently displays the temperature on the main screen, and updates the temp every 1 second.

Note: I manually monitored the temp by alt+tabbing between the game and the Radeon Profile program.

After about a week of monitoring, I concluded that the monitor goes blank and displays the 'No signal' message when the temperature of the graphic card reached approximately 75oC.

Because others who have this GPU report it should be stable running at temperatures between 70 and 85oC, I suspected that my graphic card needed maintenance, which I never have done to a graphics card previously.

Thankfully, MSI made it easy to remove the backplate of the graphics card, as well as the four screws that secure the heatpipe/heatsink/fans onto the GPU/pcb (printed circuit board). Disconnecting the power connector to the fans from the graphics card pcb was also easy.

I wiped away the thermal paste from the surface of the GPU, as well as, from the heat pipe. The thermal paste was not hardened; however, there were areas of the GPU not covered.

After cleaning these two surfaces (no solvent was used), I applied fresh thermal paste onto the GPU and spread it around with my finger making sure all areas was covered. I also added a bit onto the part of the heat pipe that comes in contact with the GPU.

I re-attached the heatpipe/heatsink/fan assembly by aligning the four screws to the four holes on the GPU side of the pcb and securing it with the appropriate screws, as well, as the reconnected the power to the graphics card fans.

Although the backplate that came with the MSI graphics card looks nice, I noticed that the inside of it was plastic, which is a material that I expect will not be a good thermal conductor. So, I did not re-attach the backplate and left it off.

I re-tested the system with the most demanding game that I have, which is Project Cars 2, a Windows game that requires Proton). For the first time, I was able to complete the California course using a GT car without getting the 'No signal' message on the monitor, which was great!

When playing Project Cars 2 with Proton, the graphics card temperature went up as high as 82oC without a hiccup in stability.

To see if I could prevent the graphics card temperatures a bit more, I added passive cooling onto the backside of the graphics card by placing a 2"x2" and a 3"x2" heatsink (one is copper and the other aluminum) I had in my computer parts drawer. Both of these heatsinks have smooth bottoms that I could place a thermal pad between the heatsink and the hottest areas of the pcb.

This time, the radeon-profile reported the graphics card temperature did not exceed 65oC when playing the same California circuit in Project Cars 2 with Proton.

I did a bit more testing in two other Linux native games that I could not play previously due to the monitor 'No signal' blanking issue, which were Metro 2033 Redux and F1 2017. This time, the graphic card temperatures were below 65oC and I had no issues with monitor blanking or stability.

So, it seems the cause of my issue was due to the thermal paste in my ageing graphics card was no longer effective, and replacing it seems to fix it.

I am not used to doing maintenance on a graphics card; however, it seems that some GPU chips can run hot and the thermal paste may need replacing after several years of use.

For now, I will mark this past as [SOLVED], but will update it if things change.

Cheers!

1 Like

Nice one. :+1:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by