Need help with Lutris and D9VK

Yep i need help installing D9VK.
Here's the tutorial video on youtube( https://www.youtube.com/watch?v=q2zEQ5Jm28A) ,but when i try to extract it cant found the ''Lutris .local'' folder ..

Any help wiil be hightly appreciated :stuck_out_tongue:

I'm sure is not mentioned in the video, because is /home/YourUser/.local/lutris/
And of course if you have lutris installed trough
pacman -S lutris
.local is a hidden folder in your home directory. Press Ctrl+h to show it in your file manager.
:wink:

1 Like

Yea i tryed that way /home/YourUser/.local/lutris/ ,but it does not exist on my system.And yes i have installed lutris. :slight_smile:

Fire lutris up for the first time and it will create the folders and files.

I have done it,but still no exist ...
I played an game called Tera before 1 month.
But now Lutris needs to have installed DXVK.
Here's screenshot :

Imgur

If you didn't install Lutris optional dependencies for vulkan you can try running this which will install them for you:

pamac install vulkan-icd-loader lib32-vulkan-icd-loader

And you should have DXVK support for your games(D9VK merged into DXVK which now support DirectX versions 9,10 and 11)
Hopefully this help but if not you can try to do it manually as instructed here under how-to section: https://github.com/doitsujin/dxvk
If you have any additional questions feel free to ask :slight_smile:

I installed with your command,but now got this message ::

When i click on ''istallation guide'' and enter.
Here's the link :

Cant do this :

Arch / Manjaro / Other Arch derivatives:

First, enable multilib.

To enable multilib repository, uncomment the [multilib] section in /etc/pacman.conf

/etc/pacman.conf -------------------------------------------------------------------------------------- [multilib] Include = /etc/pacman.d/mirrorlist

Then upgrade the system sudo pacman -Syu

What mean this ''uncomment'' and how to do it ?

That message says that you have nvidia driver 340.xx

which are quite old and no longer present in Manjaro repository

https://lmddgtfy.net/?q=how%20to%20uncomment

:vampire:

I already searched,but nowhere is explaned how to do exactly in this case.
Also i got checked that's the latest driver for my video card at Ndivia site.
Dont know whats wrong,but i played an game Tera before 1 month,without install any DXVK and other sh**s. :smiley:

Make sure your system is updated first and update all the needed packages by running:

sudo pacman -Syu

Now I don't know much about nvidia drivers since I'm running on amd but a quick look in manjaros wiki page suggested running :

sudo mhwd -a pci nonfree 0300

which should install the optimal drivers for your nvidia card so you should reboot and test if it's working now if not I found someone with the same driver problem as you on Manjaros forum updating nvidia drivers and they were able to resolve it with :

Also multilib was enabled by default for me on my installation and it's probably enabled for you too since you were able to install "lib32-vulkan-icd-loader" which is as much as I know a multilib package. But if you want to make sure that it's enabled you can run:

sudo nano /etc/pacman.conf

that will open the pacman configuration file in which you can search for the line that says "[multilib]". It looks like this if the multilib is working:

[multilib]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

If not just remove the # sings in front of the lines and it should be working now. Uncommenting means removing the # signs in front of the lines.
It's usually recommended to post the output of:

inxi -Fxxxza --no-host

when you're having an issue so that the people helping can see what drivers you're running, kernel etc. for easier diagnosis of the problem as suggested in here

Any idea on how to unistall the nvidia driver.
When i try with this command :

sudo mhwd -r pci video-nvidia

Got this error :

Error: config 'video-nvidia' is not installed!

What may be wrong ?

Graphics:
Device-1: NVIDIA G96C [GeForce 9500 GT] driver: nvidia v: 340.108
Display: x11 server: X.Org 1.20.8 driver: nvidia
resolution: 1280x1024~60Hz
OpenGL: renderer: GeForce 9500 GT/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108

System:
Kernel: 5.4.28-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64
root=UUID=a36df0e5-a6dd-40b0-aa0f-f3babc88d6a8 rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4
dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine:
Type: Desktop Mobo: Gigabyte model: GA-MA770T-UD3 serial:
BIOS: Award v: F10 date: 03/22/2011
CPU:
Topology: Quad Core model: AMD Athlon II X4 645 bits: 64 type: MCP
arch: K10 family: 10 (16) model-id: 5 stepping: 3 microcode: 10000C8
L2 cache: 2048 KiB
flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 24921
Speed: 800 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 800 2: 800
3: 800 4: 800
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass status: Not affected
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, STIBP: disabled, RSB filling
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA G96C [GeForce 9500 GT] driver: nvidia v: 340.108
bus ID: 01:00.0 chip ID: 10de:0640
Display: x11 server: X.Org 1.20.8 driver: nvidia
resolution: 1280x1024~60Hz
OpenGL: renderer: GeForce 9500 GT/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108
direct render: Yes
Audio:
Device-1: AMD SBx00 Azalia vendor: Gigabyte driver: snd_hda_intel
v: kernel bus ID: 00:14.2 chip ID: 1002:4383
Sound Server: ALSA v: k5.4.28-1-MANJARO
Network:
Device-1: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
driver: 8139too v: 0.9.28 port: de00 bus ID: 02:07.0 chip ID: 10ec:8139
IF: enp2s7 state: unknown speed: 100 Mbps duplex: full mac:
Drives:
Local Storage: total: 931.51 GiB used: 215.93 GiB (23.2%)
ID-1: /dev/sda vendor: Toshiba model: HDWD110 size: 931.51 GiB block size:
physical: 4096 B logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm
serial: rev: A8J0 scheme: MBR
Partition:
ID-1: / raw size: 931.51 GiB size: 915.89 GiB (98.32%)
used: 215.93 GiB (23.6%) fs: ext4 dev: /dev/sda1
Sensors:
System Temperatures: cpu: 26.0 C mobo: N/A gpu: nvidia temp: 42 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 40%
Info:
Processes: 218 Uptime: 2h 14m Memory: 3.84 GiB used: 3.14 GiB (81.8%)
Init: systemd v: 244 Compilers: gcc: 9.3.0 clang: 9.0.1 Shell: bash
v: 5.0.16 running in: xfce4-terminal inxi: 3.0.37

After looking at your inxi output I see you're using a GeForce 9500 GT which belongs to the GeForce 9 series and therefore isn't supported by the new nvidia drivers (check the supported devices section). On the nvidia driver lookup page using manual search I found out that the newest driver for your gpu is version: 340.1080 which you already have.
So in case you accidently deleted your drivers just run this:

sudo mhwd -a pci nonfree 0300

which will install the latest version.
Also as suggested on Lutris you should run:

sudo pacman -S nvidia nvidia-utils lib32-nvidia-utils nvidia-settings vulkan-icd-loader lib32-vulkan-icd-loader

Which should install all the neccesary components to run your games. If your game still doesn't work you can try force installing the newest drivers though this is not recommended since your gpu isn't supported. This can be done with:

Dont know what may be wrong.
Lutris tells me that i have outdated driver that may not support Vulkan or DXVK.
In Nvidia site shows me that i have the latest driver.
When do everything from the tutorial with your help,just got the same driver. (Even when unistall the driver and use this commands) :
sudo mhwd -a pci nonfree 0300
sudo pacman -S nvidia nvidia-utils lib32-nvidia-utils nvidia-settings vulkan-icd-loader lib32-vulkan-icd-loader

Well that means that you're probably stuck with what you have because it is the newest one for your gpu. Did you try starting your game (what happens when you click play) ? Did you restart after installing the drivers ?
You can probably just skip the warning about the old drivers.

I dont know,but somehow i fixed it :smiley:,after i update my system.

Glad to hear it. If you need any more help feel free to ask :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by