Netflix no longer plays in Manjaro

Since this problem occurs in Firefox (which only needs to activate DRM playback) and Chromium (which requires an AUR add-on) both, I am not sure why this was moved to the AUR thread.

Add/Remove programs shows widevine 1:1.4.9.1070-1 is installed. Uninstalling and reinstalling has no effect.

AUR shows widevine 1:1.4.9.1070-1 as the latest release and there are no notes there about my issue.

When I start Netflix in chromium, it goes to code M7702-1003 which says "Missing Component". When I go to chrome://components to look for updating the WidevineCdn component there is none listed.

Once again this happens on Firefox also which does not require an AUR add-on. On Firefox the movie just stalls immediately.

Edit: My HTPC Cinnamon with FF 57.0.4 plays Netflix, but my daily drive Xfce (and three others) also with FF 57.0.4 will not. The only difference I note is the HTPC has AMD video and the others Intel or nVidia.

You should try using a User Agent to fool Netflix into thinking you are running Windows and /or Internet Explorer. I don't currently subscribe to Netflix, so I can' t check for this at my end.

It's an issue with an AUR package. Widevine isn't in the repos.

And what AUR package is preventing Firefox from playing Netflix? I'm not sure widevine (AUR) has any part in this problem.

I continue to watch NF each night [including last night] just fine in Vivaldi-Snapshot* in Manjaro KDE.

*installed from herecura repo
https://wiki.archlinux.org/index.php/unofficial_user_repositories#herecura
https://repo.herecura.eu/herecura/x86_64/

Make sure that Chromium and chromium-widevine are both the same version, since they come from two different sources.

None, but that's not what you led with in your OP ("It says the Widevine Component on Chromium needs to be updated"), and you didn't mention whether it worked in Firefox previously ("On Firefox the movie just doesn’t play.").

Except for what you wrote in your OP:

I'm only going off what you wrote. You can disagree with my categorisation if you want but it's distracting from the core issue.

2 Likes

I'm sorry, I hoped the reference to Firefox would let you know @jonathon that Firefox was also acting up and not playing Netflix natively anymore. I will try to use more precise English next time.

Well, have you tried any of the solutions presented? Which ones, did they work etc...

I must confess I moved this from the "rants" section because the way you worded the OP I thought you actually wanted help.
If that is not the case we can move it back to rants.

Before trying other options like vivaldi and 'user agents', I would like to try to find out what happened to make Netflix not play in the two instances where it is supposed to play now. No AUR repair will make Netflix play on Firefox.

If all 5 of my current Manjaro installs are borked (all different hardware and WMs) and no one else is having the problem, then I must have a bad package from a repository. How do I find the corrupt package?

What suggestions do you feel I have ignored?

I would uninstall them all, FF & Chromium, etc., delete whatever residual settings regarding them under .config, reboot, reinstall ONE of them, check functionality, and go from there.

If the problem(s), persists, then I would go higher on up the food-chain and start looking at drivers, et al.

That's how I would do it. Yer free to do it any way ya choose. :wink:

regards

1 Like

You also ignored my "downgrade" suggestion, you would have to do some homework and find out what pakages were updated that related to your problem (Chromium suposedly) and then downgrade to the previous release.
This is on you to figure out and implement, I am not going to walk you through step by step.
Hint, the first step is to figure out what the downgrade app is and how to get and use it.

I want you to get help really I do. :grinning: But you gotta try something or ask more direct questions.

As soon as I get some assistance at locating the offending package, I will be more than happy to do so.

Having been using Manjaro for three years now, I am well aquainted with 'downgrade'.

We are talking five installs here, not just one. There must be a common thread that ties all of them together. What is it?

Who in the world would make all those changes? Try them on one machine, until you get it working. That they do not work on 5 machines indicates user-error.

My suggestion since you seem unwilling to move on any other solution is to.

  1. Open a new thread probably in newbie area about how to find the files from your last update.
  2. look those files over and see if you can find the offending updates, ask questions if needed with another thread.
  3. downgrade the offending updates.

Ha, I end up giving a complete walk through anyway. :grinning:
Good luck.

https://wiki.archlinux.org/index.php/Pacman/Tips_and_tricks#By_date

By date

To list the 20 last installed packages with expac, run:

$ expac --timefmt='%Y-%m-%d %T' '%l\t%n' | sort | tail -n 20
1 Like

If you normally use Chromium with the Widevine plugin, and it's now saying that the Widevine plugin needs updating, then it's probably the Widevine plugin.

1 Like

Wow, did you really just say that? What user change can I do to five machines to have identical problems? I'm better than I thought. Two of the machines are bare updated installs and they also do not work.

PEBKAC fer sure. But hey, we can help you if you want, but if you keep that 'tude yer going down. :smiley:

Come on, man, make it work as-intended once on one machine. Then duplicate what works rather than what fails. :smiley:

regards

Forum kindly sponsored by