Netflix no longer plays in Manjaro

My suggestion since you seem unwilling to move on any other solution is to.

  1. Open a new thread probably in newbie area about how to find the files from your last update.
  2. look those files over and see if you can find the offending updates, ask questions if needed with another thread.
  3. downgrade the offending updates.

Ha, I end up giving a complete walk through anyway. :grinning:
Good luck.

https://wiki.archlinux.org/index.php/Pacman/Tips_and_tricks#By_date

By date

To list the 20 last installed packages with expac, run:

$ expac --timefmt='%Y-%m-%d %T' '%l\t%n' | sort | tail -n 20
1 Like

If you normally use Chromium with the Widevine plugin, and it's now saying that the Widevine plugin needs updating, then it's probably the Widevine plugin.

1 Like

Wow, did you really just say that? What user change can I do to five machines to have identical problems? I'm better than I thought. Two of the machines are bare updated installs and they also do not work.

PEBKAC fer sure. But hey, we can help you if you want, but if you keep that 'tude yer going down. :smiley:

Come on, man, make it work as-intended once on one machine. Then duplicate what works rather than what fails. :smiley:

regards

As I mentioned @cooter, two are bare installs that I only update for test purposes. I have not had my 'hands' on them.

Just like @Kadee wrote above, it works in Vivaldi-snapshot.

But there is something which can (maybe) help ... I used to see Netflix in Vivald--stable (with the correct Widevine).
After the last Widevine update, there is no way for me to have it working in the stable build.... but it DOES work in the snapshot build, with the corresponding Widevine extension .
Could not understand why, but ... it works.

1 Like

Have you looked at the AUR site for Widevine??? As I suggested a loooong time ago? It is probably all there for you to discover, I think you have a AUR application plugin problem.
I am out. Good Luck.

Chromium version: 63.0.3239.132 (Developer Build) (64-bit)
chromium-widevine: 1:1.4.9.1070-1

Good info, thanks.
Please see his post for proper connotation, it involves Vivaldi but of course we all know its all chromium.

According to the commit log (https://aur.archlinux.org/cgit/aur.git/log/?h=chromium-widevine) version 1:1.4.9.1070-1 is for Chromium version 64. It likely won't work with Chromium 63.

Downgrade the AUR package or switch to the testing branch to get Chromium 64.

3 Likes

As was all said earlier in the thread and over again. :neutral_face: Check out AUR and all will be revealed to your hearts content. :smile:
I am just gonna mark this as me solved like 20 post ago, thanks.

That's not quite how this should work... when @Gene_J says it's fixed, then it can be marked as solved.

1 Like

Geez, The OP doesn't look like he even tried the simplest tip to fix his problem, such as the one I made about changing the User Agent to convince Netflix he is using Windows/EE. Jeez that one would have only taken 5 minutes to do, if that?

I have no idea if it still works, but we had to use that trick not that long ago.

1 Like

I'm not sure that would help in this case as it was working just before without it.

Even so, I would have tried it anyway just in case Netflix started acting funny about Linux users using their service. And besides it is really easy to do.

2 Likes

There's a Chromium update in the new stable update pack; give that a go.

You don't need plugins to play Netflix on Linux anymore. Firefox is able to do it for you. Else you might use Chrome. On Firefox you have to accept encryption transfer via the DRM. More about it here and here. Also some post about this topic in the Arch-Forum.

1 Like

I'm really glad of that. Anyone remember PipeLight? Back when I was using Mint and Xubuntu, I had to find a new PPA for that every time I upgrade to the new release if I wanted to avoid booting into Windows just to watch Netflix.

Im running xfce and I just went into package manager searched for Widevine Plugin, its there. I clicked on it, installed it, restarted Chromium and, it works. Now I can also watch Netflix in Chromium

1 Like

That's interesting. I've not tried to stream NF in Chromium for a very long time [as i said earlier, i happily use Vivaldi-Snapshot], so reading of your experience i thought i'd try it now.

  1. Initial Chromium attempt failed:
    20180130_002

  2. Checked its Widevine status & found as expected that this plugin was missing, so i installed it:
    20180130_001

  3. Restarted Chromium & retried; still failed -- oops! Also, note that the error code has subtly changed.
    20180130_003

  4. Cleared Chromium's cookies & cache, then retried; still failed, same error.

So it seems that OP might have a point; for some installations it's more tricky than for others.

EDIT: Conversely, just now i tested NF in Firefox 58. Instant success; i did not have to take any corrective steps.

EDIT-2: Conversely conversely, aka on the third hand, Pale Moon remains out of the loop [this message came as a real blast from the past for me]:

Help Center Netflix system requirements for HTML5 Player and Silverlight 

Netflix system requirements for HTML5 Player and Silverlight

You can use our HTML5 player or Silverlight to watch Netflix TV shows and movies on PCs running Windows XP or later, and Intel-based Macs running OS X Tiger (v10.4.11) or later. You'll find a complete list of requirements below for HTML5, Silverlight 4, and Silverlight 5.
HTML5
Silverlight 4
Silverlight 5

Supported Browsers:

Google Chrome version 37 or later on Windows 7 or later, Mac OS X 10.9 or later (Mavericks), Chrome OS, or Linux*

Internet Explorer 11 or later on Windows 8.1 or later

Microsoft Edge on Windows 10

Mozilla Firefox version 47 or later on Windows Vista or later, Mac OS X 10.7 or later, or Linux*

    Supported on stable, official release builds from Mozilla. Non-Mozilla builds are not supported.

Opera version 33 or later on Windows Vista Service Pack 2 or later and Mac OS X 10.9 or later

Safari on Mac OS X 10.10 or later (Yosemite)

    Supported on all 2012 or later models and select 2011 models

*Due to the many configurations of Linux available, customer support is unable to assist with troubleshooting issues on Linux devices.

Resolution:

Google Chrome

    Up to 720p on Windows, Mac, and Linux

    Up to 1080p on Chrome OS

Internet Explorer up to 1080p

Microsoft Edge up to 4K*

Mozilla Firefox up to 720p

Opera up to 720p

Safari up to 1080p on Mac OS X 10.10.3 or later

*Streaming in 4K requires an HDCP 2.2 compliant connection to a 4K capable display, Intel's 7th generation Core CPU, and the latest Windows updates. Check with the manufacturer of your system to verify specifications.

You may also be interested in:

Detailed instructions on how to install Silverlight on your Windows PC

Detailed instructions on how to install Silverlight on your Mac

Troubleshooting instructions for Netflix.com Player Error - System Compatibility

Back to Home
Have feedback on this article?

1 Like

Forum kindly sponsored by