Netflix no longer plays in Manjaro

As soon as I get some assistance at locating the offending package, I will be more than happy to do so.

Having been using Manjaro for three years now, I am well aquainted with 'downgrade'.

We are talking five installs here, not just one. There must be a common thread that ties all of them together. What is it?

Who in the world would make all those changes? Try them on one machine, until you get it working. That they do not work on 5 machines indicates user-error.

My suggestion since you seem unwilling to move on any other solution is to.

  1. Open a new thread probably in newbie area about how to find the files from your last update.
  2. look those files over and see if you can find the offending updates, ask questions if needed with another thread.
  3. downgrade the offending updates.

Ha, I end up giving a complete walk through anyway. :grinning:
Good luck.

https://wiki.archlinux.org/index.php/Pacman/Tips_and_tricks#By_date

By date

To list the 20 last installed packages with expac, run:

$ expac --timefmt='%Y-%m-%d %T' '%l\t%n' | sort | tail -n 20
1 Like

If you normally use Chromium with the Widevine plugin, and it's now saying that the Widevine plugin needs updating, then it's probably the Widevine plugin.

1 Like

Wow, did you really just say that? What user change can I do to five machines to have identical problems? I'm better than I thought. Two of the machines are bare updated installs and they also do not work.

PEBKAC fer sure. But hey, we can help you if you want, but if you keep that 'tude yer going down. :smiley:

Come on, man, make it work as-intended once on one machine. Then duplicate what works rather than what fails. :smiley:

regards

As I mentioned @cooter, two are bare installs that I only update for test purposes. I have not had my 'hands' on them.

Just like @Kadee wrote above, it works in Vivaldi-snapshot.

But there is something which can (maybe) help ... I used to see Netflix in Vivald--stable (with the correct Widevine).
After the last Widevine update, there is no way for me to have it working in the stable build.... but it DOES work in the snapshot build, with the corresponding Widevine extension .
Could not understand why, but ... it works.

1 Like

Have you looked at the AUR site for Widevine??? As I suggested a loooong time ago? It is probably all there for you to discover, I think you have a AUR application plugin problem.
I am out. Good Luck.

Chromium version: 63.0.3239.132 (Developer Build) (64-bit)
chromium-widevine: 1:1.4.9.1070-1

Good info, thanks.
Please see his post for proper connotation, it involves Vivaldi but of course we all know its all chromium.

According to the commit log (https://aur.archlinux.org/cgit/aur.git/log/?h=chromium-widevine) version 1:1.4.9.1070-1 is for Chromium version 64. It likely won't work with Chromium 63.

Downgrade the AUR package or switch to the testing branch to get Chromium 64.

3 Likes

As was all said earlier in the thread and over again. :neutral_face: Check out AUR and all will be revealed to your hearts content. :smile:
I am just gonna mark this as me solved like 20 post ago, thanks.

That's not quite how this should work... when @Gene_J says it's fixed, then it can be marked as solved.

1 Like

Geez, The OP doesn't look like he even tried the simplest tip to fix his problem, such as the one I made about changing the User Agent to convince Netflix he is using Windows/EE. Jeez that one would have only taken 5 minutes to do, if that?

I have no idea if it still works, but we had to use that trick not that long ago.

1 Like

I'm not sure that would help in this case as it was working just before without it.

Even so, I would have tried it anyway just in case Netflix started acting funny about Linux users using their service. And besides it is really easy to do.

2 Likes

There's a Chromium update in the new stable update pack; give that a go.

You don't need plugins to play Netflix on Linux anymore. Firefox is able to do it for you. Else you might use Chrome. On Firefox you have to accept encryption transfer via the DRM. More about it here and here. Also some post about this topic in the Arch-Forum.

1 Like

Forum kindly sponsored by