Netflix no longer plays in Manjaro

I'm really glad of that. Anyone remember PipeLight? Back when I was using Mint and Xubuntu, I had to find a new PPA for that every time I upgrade to the new release if I wanted to avoid booting into Windows just to watch Netflix.

Im running xfce and I just went into package manager searched for Widevine Plugin, its there. I clicked on it, installed it, restarted Chromium and, it works. Now I can also watch Netflix in Chromium

1 Like

That's interesting. I've not tried to stream NF in Chromium for a very long time [as i said earlier, i happily use Vivaldi-Snapshot], so reading of your experience i thought i'd try it now.

  1. Initial Chromium attempt failed:
    20180130_002

  2. Checked its Widevine status & found as expected that this plugin was missing, so i installed it:
    20180130_001

  3. Restarted Chromium & retried; still failed -- oops! Also, note that the error code has subtly changed.
    20180130_003

  4. Cleared Chromium's cookies & cache, then retried; still failed, same error.

So it seems that OP might have a point; for some installations it's more tricky than for others.

EDIT: Conversely, just now i tested NF in Firefox 58. Instant success; i did not have to take any corrective steps.

EDIT-2: Conversely conversely, aka on the third hand, Pale Moon remains out of the loop [this message came as a real blast from the past for me]:

Help Center Netflix system requirements for HTML5 Player and Silverlight 

Netflix system requirements for HTML5 Player and Silverlight

You can use our HTML5 player or Silverlight to watch Netflix TV shows and movies on PCs running Windows XP or later, and Intel-based Macs running OS X Tiger (v10.4.11) or later. You'll find a complete list of requirements below for HTML5, Silverlight 4, and Silverlight 5.
HTML5
Silverlight 4
Silverlight 5

Supported Browsers:

Google Chrome version 37 or later on Windows 7 or later, Mac OS X 10.9 or later (Mavericks), Chrome OS, or Linux*

Internet Explorer 11 or later on Windows 8.1 or later

Microsoft Edge on Windows 10

Mozilla Firefox version 47 or later on Windows Vista or later, Mac OS X 10.7 or later, or Linux*

    Supported on stable, official release builds from Mozilla. Non-Mozilla builds are not supported.

Opera version 33 or later on Windows Vista Service Pack 2 or later and Mac OS X 10.9 or later

Safari on Mac OS X 10.10 or later (Yosemite)

    Supported on all 2012 or later models and select 2011 models

*Due to the many configurations of Linux available, customer support is unable to assist with troubleshooting issues on Linux devices.

Resolution:

Google Chrome

    Up to 720p on Windows, Mac, and Linux

    Up to 1080p on Chrome OS

Internet Explorer up to 1080p

Microsoft Edge up to 4K*

Mozilla Firefox up to 720p

Opera up to 720p

Safari up to 1080p on Mac OS X 10.10.3 or later

*Streaming in 4K requires an HDCP 2.2 compliant connection to a 4K capable display, Intel's 7th generation Core CPU, and the latest Windows updates. Check with the manufacturer of your system to verify specifications.

You may also be interested in:

Detailed instructions on how to install Silverlight on your Windows PC

Detailed instructions on how to install Silverlight on your Mac

Troubleshooting instructions for Netflix.com Player Error - System Compatibility

Back to Home
Have feedback on this article?

1 Like

I use firefox, and I see Netfilx perfectly.

Reading in Arch's wiki says:

To install it for Chromium, install the chromium-widevineAUR package. Make sure Allow sites to play protected content is checked in chrome://settings/content/protectedContent

My Chromium conforms to both those requirements, but as shown, does not stream NF. Really is interesting to ponder why different users get different outcomes.

Wow me too, silverlight who knew.

Oh Oh, and great job on the investigation and report. :grinning:

1 Like

What a difference a day makes...

Updates arrived here 4 hours ago. First three comps tested are now streaming NF (TM) fine, so I have to assume all I really had to do was sit on my hands for a couple of days and all would have worked out by itself. Thank you @Kadee for doing the screenshot work I didn't do. I was greeted at your point #3 on Sunday morning and have been puzzled why no one else ran into this issue ever since. With the new Firefox and Chromium that came with this up date, I pronounce this post 'solved'. Thanks for all your help, folks.

Since @jonathon was the first to mention the update, he gets the solved nod.

2 Likes

Glad you got it solved. Why it took 47 posts I have not a clue.

It is solely because Manjaro repos are not sync'd with Arch's. If Manjaro wants to do a better job, ensure that critical components--those that required proper plugins to work--are sync'd.

Three things are required to play DRM such as Netflix in Chromium:

  • Chromium (extra)
  • Pepper-flash (extra) (for sites still using Flash)
  • Chromium-widevine (AUR)

That's where they are in the Arch Stable and AUR repos, and they are all the correct version (and it all works as advertised).

Firefox plays DRM just fine OOTB, just enable DRM in it's settings. Same goes with Chrome.

No idea about Vivaldi.

Misunderstanding... I was not asking for "feedback on this article", those are not my words, they were at the bottom of the big text block i quoted from the Netflix error page. It was Netflix offering to go back Home, & Netflix soliciting feedback on their article, not me.

2 Likes

UPDATE: My earlier test was done before i had done the 2018-01-29 upgrade, when my Chromium was still v63. Last night i did the upgrade, & just now the following morning i retested Chromium [now v64] on NF... & it now streams happily.

So now that's Vivaldi [Snapshot and Stable], Chromium & FF that can be used for one's NF pleasures.

2 Likes

Article? Christ, I thought you'd posted a book. :wink:

"Too many quotes warps c00ter's wee brain."

sorry this comment is unrelated but i love the icon of nhk ni youkoso :smiley:

I updated Manjaro today and found Netflix not working in Firefox (widevine "crashed") then downloaded Chromium and found the same result. Saw a closed thread on here recommending to download and install some tar file. Well that wasn't necessary. (Maybe fix that old thread?) All I had to do was install "widevine" via yaourt and restart Chromium. Easy. I haven't tried Firefox yet... Anyway, widevine doesn't show up in chrome://components but somehow it still works beautifully.

I spoke too soon, chromium just went "blank" halfway through the movie, like window decorations only without anything inside, couldn't even reload the page. Restarting Chromium seems to work though. Hopefully it was just a glitch :smiley:

NF continues to stream nicely in Vivaldi-Snapshot, in both my PCs [both before & after the 2018-05-26 Stable Update]. So, an option for you?

Thanks for the recommendation. Is there any config required for that or does it just work?

  1. When will VIVALDI browser be available in the repos like Opera now is?
  2. https://wiki.archlinux.org/index.php/unofficial_user_repositories
  3. When will VIVALDI browser be available in the repos like Opera now is?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by