Network does not start with VPN enabled

Hi,

In the thread: VPN does not automatically start at boot my problems shifted from not being able to automatically start the VPN when starting the wired connection to the wired connection not starting automatically when booting when it should start the VPN as well.
When I change the setting for the wired connection so it does not start the VPN automatically, it does start at boot. When it should also start the VPN it does not start at boot.

Can somebody please help me with this problem? Either way I have to start something manually:
or the wired connection which then will start the VPN, or the VPN itself.

The only way i can explain it is (keep the VPN connection/configuration as it is)
Create a new Wired connection and in General tab select both the Automatically connect... and All users..., in the drop-down menu under automatically connect to this VPN, select the service/connection to VPN you already have.
On Wired tab select Restrict to device.
On top give it a name then click Save
Now, the fun part is that kdewallet will ask for password ... I never understood exactly how all this works, but:
In KDE Wallet must have enabled the Prompt when an application access the wallet in Access Control tab
and allow to this 2, so it doesn't ask for password every time. Also the password for the VPN connection must be saved for all users (encrypted or not)
image

So you will have somthing like this for the wired connection (that i called VPN for convenience):
image
and this for VPN actual connection
image

Thanks again you for your help, unfortunately it still doesn't work.

I did set the tickbox in the kwalletmanager and when starting the connection manually it did give me a window indicating the wallet needed a password. My password is empty cause I want as less disturbances as possible.
I answered by clicking the button Always since I don't want to have this window again.
Then when starting Chrome it appeared again and again I said Always so also Chrome will not ask again.

The settings for both the wired and the VPN connection are as you indicate. Still the wired connection does not start when booting the computer until I switch off the tickbox to connect to the VPN as well.

For Chrome i set to Always deny because i don't use Chrome for main browsing, and after that is not asking the password again (and i do have a password). But once i reboot the connection to VPN and VPN tunnel goes fine, with no intervention. Be assured that also kded5 is there and for the VPN service/tunnel, in General is also set to automatically connect
image
Note: i replaced VPN to Lan to my wired connection to see if there is a difference. There is none and connect right on with no intervention.

I wonder what is different in my setup that makes the LAN not start when it has to start the VPN as well. What is wrong here? I did build a new LAN several times already and it is always the same.
When I set the LAN to start the VPN and I reboot, neither of the two is started. When I then start the LAN manually the VPN also starts, so the connection between the two works.

After reboot, in the settings of the Lan, it keeps all 3 check-boxes in General configuration and points to the VPN you have?

Yes it does. The settings are saved.

Then the only thing that remains to question/solution is to check that it never asks for password for kdewallet whatever changes you make ...

I've got this in kwalletmanager:
Screenshot_20170909_131832
As said, the wallet's password is empty so I don't need to type it. Both kwalletmanager and Chrome start without bugging me, so I expect kded5 to do the same.

Could you have a look in the following 2 folders to see if you have any files (or folders) in there"
/etc/openvpn/client and /etc/openvpn/server
Mine are both empty.
I read here in post 5 to copy the ovpn file to it. Will give it a try.

No, did not work, so I removed the file again.

The folders exist but are empty. I don't think the issue is there.
Be sure the password and configuration for VPN is also automatically stored and accessed without your input. If it asks you for any password, that means it doesn't access it automatically.

It does not ask me for a password. As I wrote earlier, when I start the LAN manually with a marked checkbox to start the VPN as well, it does so. It just doesn't want to do it automatically at boot.

And the VPN is also set to connect automatically ... is for all users or only your user, did you changed that and insert your user in the list?
image
Then click on Advanced and you put your user there as i have mine
image
click ok then Apply on the network settings. Kwallet is asking for password for this change, but it activates it at boot (for me it works even if is clicked for all users)

Bogdan, I really appreciate all you are doing but I think I will backup my stuff and re-install, with 17.04, hoping it will be working then.
There must be something else wrong in my setup, other than the network, or kwallet, which prevents it from working the right way.
Thank you very much for your help and time.
Btw, I had it set to all users, but just tested it with only my username. Both don't work.

I feel you. I had a few problems myself that i couldn't get working and today i found out that my scanner doesn't work (it scans correctly but all the saved images are black) On Mac OS, on my main linux box, and now i have to move to another machine and see what is going on ...
Take care!

Which software do you use to scan? When you say it scans correctly, how do you know? Is the preview okay, but after saving the pictures are black?

I did a complete new install, erased my /home except for some scripts and things are still the same, nothing changed.
LAN starts at boot without having to start the VPN
LAN does not start at boot when having to start the VPN
Manually starting the LAN also starts the VPN
If I weren't already I would get crazy.

You went trough a new install and still the same deal ??? Oh wow, is this some sort of black Saturday ? :frowning:

On Mac i use the default HP application (is a HP G4010) and i used it only when scanning film negatives. Since Sierra came out i didn't bother much. On Manjaro i use Skanlite because i scan most of A4 files (some of my drawings and few documents), so most of the time is connected to my linux box, because i do all of my work on it. Today i got 4 films and booted Mac, and all the preview looks fine but all are saved black whatever i do. Connected back to linux, preview looks fine (but only flat bed scan - not film strip), it saves all black. Moved to another room, booted an old box with a winxp on it (since 2000 years ago) and works like a boss. Seems like the new HP software did something, because once i moved back from xp box to my Manjaro is all nice (still no film strip 35mm options to scan in linux) VueScan doesn't like my setting either. Anyway ...

What if you put a simple password to kwallet and the wallet in use ? An x or something, maybe without it doesn't write something where it should? I'm speculating right now while i take a break of thinking how to solve my scanner ... hahaha

It must be black September, black August, black Jul..... well you get it.
I'll try the wallet with a simple password.
Hope you get your scanner working again. Now I wish I could help you. You spent so much time on my problem.

Don't worry for the scanner. I connected it back to that XP and from 4 films i have one remaining to scan (i can load only 6 frames, so the films has to be cut). Soon will be done, and i deal with the rest later. I don't even remember when i last time booted that HDD, maybe 8-10 years ago ... After all it proves to be a keeper :smiley:
Hope to get your problem solved!!!

Forum kindly sponsored by