Network is lagging on new Manjaro install

I have problem with network.
The problem is: When I load any website or download packages from internet there is anoying lag of few seconds and then it gets to full speed. So it gets to speed my ISP has allowed me, but there is always huge lag of sometimes even few minutes load.

I have this on my laptop and my PC.
Tested on different networks.
Red all forum posts for similar things, but nothings work.


I am using dynamic IPv4

My whireless card:
Realtek RTL8192CE PCIe Wireless Network Adapter

Example of lag:

what network adaptor and module are you using? Are you using IPv4/IPv6, static or dynamic IP? Really you should post such technical information relating to the issue because otherwise everyone would just be guessing and offering up what could be wrong advice.

1 Like

but, as always
welcome-01-sgs :slight_smile:

Sry I updated it.

  • 8min Lesezeit (read time in forum?)

Maybe not enough.

please read this topic and try the solution, i know yours is not USB hosted but the power management issue may still apply:

1 Like

I tried suggested solution but updating the driver does nothing. I installed Ubuntu today and any website loads before i lift my finger of keyboard...

As I said, I have tried on multiple devices. So I'm not sure it has to do with drivers.

The 'vanilla' realtek device power management is not fine.

The solution is not to swap the driver (not why I highlighted that thread) but deploy the configuration changes regarding power management. Ubuntu has them in place by default rather than the vanilla realtek configuration every other distribution uses which is why it just works out of the box with your adaptor.

Anyhow, if you aren't comfortable editing configuration files then Ubuntu or one of it's flavours/derivatives is probably the better fit you right now anyway.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by