Network keeps dropping intermittently

Hi everyone,
I've been using the Manjaro + Awesome WM variant for a couple of days now and everything feels amazing, apart from one thing: I believe that my network cuts out every now and then (maybe every 5 minutes), then comes back after 20-30 seconds.

When I'm browsing websites it really frustrates me and I've been unsuccessful trying to resolve the issue with commands that I came up with before writing this post, such as appending net.ifnames=0 to /etc/default/grub or disabling IPV6. I've also tried sudo sysctl net.ipv4.tcp_ecn=0.

I use Ethernet, I have a fritz.box cable 6591 and everything works fine on my Windows10, MacOS and Android devices.

My /etc/resolv.conf contains:

search fritz.box
nameserver 192.168.178.1
nameserver fd00::2e91:abff:fe8c:265a

When I add other DNS addresses here they don't get persisted through reboot though, I have to find a way to do that, but that's not the root cause of the problem, I'm just thinking about the possibility that the error comes from the fact that my router's IPs are the only nameservers in this file.

Can you give me a hint? Some commands I can run to narrow down the issue? Maybe it is an external problem?

THANKS!

Have you tried substituting new cables (minimum cat6e) and a different router?

1 Like

Yes it stays the same...
So when I notice that it's cut off, I quickly try a ping or ip a and both of them get stuck until the network is back.
Is my machine maybe losing its IP lease or something? How would I monitor this to know what actually happens.. any kind of logs I could check? thanks

You can try this:

It is always a good idea to install timeshift and make a backup before you do any system configuration changes.



Here is some different methods for setting the DNS servers so they will not change:



Enable Network Manager's debugging mode with the following command:

echo -e "[logging]\nlevel=DEBUG" | sudo tee /etc/NetworkManager/conf.d/00-defaults.conf

This will give you a far more in depth logging.

The command below will output a live log detailing your network's current activities:

Open a live Network Manager debuggingl log session:

journalctl -fu NetworkManager 

Let the command run in the terminal, logging all current network activities:

Log at least 50-100 lines of output around times when your connection has failed/restarted.

Post any important looking excerpts from the log around failure events.



2 Likes

Also try:



I'm not sure if you have tlp installed, but if you do then let's test to see if tlp is causing this by disabling tlp temporarily.

To prevent tlp from starting it can be masked:

sudo systemctl mask tlp && sudo systemctl mask tlp-sleep.service

Reboot, then test if the problem persists.


If there is no improvement by preventing tlp from starting, then simply reverse the changes by unmasking tlp.

To re-enable tlp:

sudo systemctl unmask tlp && sudo systemctl unmask tlp-sleep.service

Then reboot.



Also please check if there is any output from:

systemctl --failed
1 Like

Forum kindly sponsored by