NetworkManager can't brings me to wireless network, but I can't install wicd. How can I solve this problem?

Hello, I’m sorry for disturbing. I have been tormented by this issue for a whole day.

Wi-Fi is disabled by hardware switch by default when using NetworkManager, but I can't turn on the wireless network switch because of the malfunction of my laptop keyboard. I used wicd instead of NetworkManager to connect to internet wirelessly when I use Xubuntu as my primary opreating system. As in the past, I tried to install wicd on my laptop, but a dependency of wicd doesn't exist in AUR.

[lulu@lulu-ncbt41x Desktop]$ yay -S wicd
:: There are 2 providers available for wicd:
:: Repository AUR
    1) wicd-git 2) wicd-patched 

Enter a number (default=1): 
==> Error: Could not find all required packages:
    python2-urwid (Wanted by: wicd-git)

However, I'm sure python2 and urwid is installed correctly on my laptop.

[lulu@lulu-ncbt41x Desktop]$ python2 -V
Python 2.7.17
[lulu@lulu-ncbt41x Desktop]$ pip2 list | grep urwid
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
urwid              2.1.0

So what exactly does "python2-urwid (Wanted by: wicd-git)" mean? And how can I use wireless network? Gentlemen, please don't be stingy with your knowledge. Teach me, please.

If Network Manager cannot connect then wicd cannot either - and if you don't have any network you cannot install any packages.

If you have been able to unblock your wifi using software - it is probably rfkill

sudo rfkill unblock all

And wicd is based on python2 which was EOL 2020-01-01 and most - if not all - python2 packages has either been reworked upstream to use python3 or they have been demoted to AUR.

If you think it would help - use connman and the GUI cmst.

Please read this guide

If you have an Android phone you can tether using your charger cable - tethering works OOB - just ensure your phone has internet connection.

Another option is a network cable to your router - much more reliable.

1 Like

You have not posted any hardware info.

Please post:

inxi -Fxxxz

lsmod | sort

rfkill list

To remove a hard block is sometimes not so easy. These are the first things I would recommend:

Test at least three or four alternate kernels.

Update your bios if it is out of date.

Power down your computer completely. Remove, or let all attached batteries fully discharge. Unplug from any AC power source. Let the computer sit without power for 5 minutes or so. Then restart, and reset the bios to the factory default.

If none of these have a positive effect perhaps the outputs you post will give a clue as to the cause of your issue.

Are you dual booting with Windoze?

1 Like

Thank you, linux-aarhus, but rfkill can't unblock the built-in wireless card.

[lulu@lulu-ncbt41x ~]$ sudo rfkill unblock all 
[lulu@lulu-ncbt41x ~]$ sudo rfkill
ID TYPE DEVICE      SOFT      HARD
 0 wlan phy0   unblocked   blocked
 1 wlan phy1   unblocked unblocked

As you see, I also have a USB wireless card. It seemed to work, but it did not take any effect when I used NetworkManager. As a matter of fact, I have one more USB wireless card plugged, nevertheless it disappeared under command "rfkill". I can’t even find it by command "iw dev", nevertheless I can find it in the GUI of NetworkManager below.
I’m sorry to show you the Chinese interface, but I cannot switch the system language in Localization Settings. Actually, after a shutdown with saving sessions, each startup restored sessions before that shutdown. I'm not sure whether it's related to being unable to switch languages. I have translated the keywords to ensure you understand the point.

截图_2020-04-30_00-26-47

In short, there are three wireless cards, two found, one unblocked, but none usable, just like when I used xubuntu 18.04.
However, all these wireless cards worked via wicd at that time, no matter if it was unblocked, no matter if it appeared under "rfkill". This is why I want to solve the problem by replacing Network Manager. And this method is indeed effective.

截图_2020-04-30_16-16-09

In connman, only one of my USB wireless cards can be found, fortunately, it works. One is better than none. Although the built-in wireless network card is not yet usable, I am very glad. Because I can put my laptop top on my lap now.
Thank you, linux-aarhus.

1 Like

Hello, tbg. I have used several Linux kernels. Nevertheless, the built-in wireless card was always usable, even in Windows 10. In my experience, using wicd can solve this problem. This method sounds illogical, but it does work. I don't understand why.

Your suggestion of upgrading BIOS is constructive. But I didn’t find the manufactory of this motherboard (ncbt41x), and furthermore I don’t know where I can download its BIOS in. I observed these outputs but didn’t figure out what went wrong with my laptop. Whatever, thank you for your suggestion.

inxi -Fxxxz

System:
  Host: lulu-ncbt41x Kernel: 5.6.7-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.3.0 Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: TSINGHUA TONGFANG product: NCBT41x v: 1.02S 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: TSINGHUA TONGFANG model: NCBT41x serial: <filter> 
  UEFI: American Megatrends v: 1.02S date: 06/09/2014 
CPU:
  Topology: Quad Core model: Intel Celeron N2930 bits: 64 type: MCP 
  arch: Silvermont rev: 8 L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 14673 
  Speed: 500 MHz min/max: 500/2166 MHz Core speeds (MHz): 1: 584 2: 529 
  3: 721 4: 577 
Graphics:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display 
  vendor: Tongfang Hongkong Limited driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:0f31 
  Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 20.0.5 
  compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio 
  vendor: Tongfang Hongkong Limited driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 chip ID: 8086:0f04 
  Sound Server: ALSA v: k5.6.7-1-MANJARO 
Network:
  Device-1: Realtek RTL8188EE Wireless Network Adapter vendor: AzureWave 
  driver: rtl8188ee v: kernel port: e000 bus ID: 01:00.0 chip ID: 10ec:8179 
  IF: wlp1s0 state: down mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Tongfang Hongkong Limited driver: r8168 v: 8.048.02-NAPI 
  port: d000 bus ID: 02:00.1 chip ID: 10ec:8168 
  IF: enp2s0f1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-3: Realtek RTL8191SU 802.11n WLAN Adapter type: USB driver: r8712u 
  bus ID: 1-1.2:6 chip ID: 0bda:8172 serial: <filter> 
  IF: wlan1 state: up mac: <filter> 
  Device-4: Ralink RT2870/RT3070 Wireless Adapter type: USB 
  driver: rt2800usb bus ID: 1-1.3:7 chip ID: 148f:3070 serial: <filter> 
  IF: wlan0 state: down mac: <filter> 
Drives:
  Local Storage: total: 59.63 GiB used: 9.15 GiB (15.3%) 
  ID-1: /dev/sda vendor: LITE-ON IT model: K3-L2064 size: 59.63 GiB 
  speed: 3.0 Gb/s serial: <filter> rev: SC1 scheme: GPT 
Partition:
  ID-1: / size: 18.21 GiB used: 6.72 GiB (36.9%) fs: ext4 dev: /dev/sda6 
  ID-2: /home size: 4.16 GiB used: 2.43 GiB (58.3%) fs: ext4 dev: /dev/sda5 
  ID-3: swap-1 size: 3.75 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda7 
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 169 Uptime: 7m Memory: 7.66 GiB used: 833.5 MiB (10.6%) 
  Init: systemd v: 244 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 
  running in: xfce4-terminal inxi: 3.0.37 

lsmod | sort

8021q                  40960  0
ac                     16384  0
agpgart                53248  2 intel_gtt,drm
asus_wmi               40960  0
atkbd                  36864  0
battery                24576  1 asus_wmi
bluetooth             679936  12 btrtl,btqca,btintel,hci_uart,btbcm,bnep
bnep                   28672  2
btbcm                  20480  1 hci_uart
btintel                32768  1 hci_uart
btqca                  20480  1 hci_uart
btrtl                  24576  1 hci_uart
cec                    69632  2 drm_kms_helper,i915
cfg80211              884736  3 rt2x00lib,rtlwifi,mac80211
cmdlinepart            16384  0
coretemp               20480  0
crc16                  16384  2 bluetooth,ext4
crc32c_generic         16384  0
crc32c_intel           24576  5
crc32_pclmul           16384  0
crct10dif_pclmul       16384  1
cryptd                 24576  1 ghash_clmulni_intel
crypto_user            16384  0
drm                   569344  8 drm_kms_helper,i915
drm_kms_helper        245760  1 i915
ecc                    36864  1 ecdh_generic
ecdh_generic           16384  1 bluetooth
evdev                  24576  19
ext4                  794624  2
fat                    86016  1 vfat
fb_sys_fops            16384  1 drm_kms_helper
fuse                  139264  3
garp                   16384  1 8021q
ghash_clmulni_intel    16384  0
hci_uart              151552  0
hid                   147456  3 i2c_hid,usbhid,hid_generic
hid_generic            16384  0
i2c_algo_bit           16384  1 i915
i2c_hid                32768  0
i2c_i801               36864  0
i8042                  32768  0
i915                 2502656  13
input_leds             16384  0
intel_cstate           16384  0
intel_gtt              24576  1 i915
intel_powerclamp       20480  0
intel_rapl_common      32768  1 intel_rapl_msr
intel_rapl_msr         20480  0
intel_soc_dts_iosf     20480  1 intel_soc_dts_thermal
intel_soc_dts_thermal    20480  0
intel_spi              24576  1 intel_spi_platform
intel_spi_platform     16384  0
iptable_filter         16384  0
iptable_mangle         16384  0
iptable_nat            16384  0
ip_tables              36864  3 iptable_filter,iptable_nat,iptable_mangle
irqbypass              16384  1 kvm
iTCO_vendor_support    16384  1 iTCO_wdt
iTCO_wdt               16384  0
jbd2                  139264  1 ext4
joydev                 28672  0
kvm                   827392  1 kvm_intel
kvm_intel             327680  0
ledtrig_audio          16384  2 snd_hda_codec_generic,snd_hda_codec_realtek
libarc4                16384  1 mac80211
libcrc32c              16384  2 nf_conntrack,nf_nat
libps2                 20480  2 atkbd,psmouse
llc                    16384  2 stp,garp
loop                   40960  0
lpc_ich                28672  0
mac80211             1036288  6 rtl_pci,rtl8188ee,rt2x00lib,rtlwifi,rt2x00usb,rt2800lib
mac_hid                16384  0
mbcache                16384  1 ext4
mei                   122880  3 mei_hdcp,mei_txe
mei_hdcp               24576  0
mei_txe                32768  1
mmc_core              188416  1 rtsx_pci_sdmmc
Module                  Size  Used by
mousedev               24576  0
mrp                    20480  1 8021q
mtd                    77824  6 spi_nor,cmdlinepart,intel_spi,ofpart
nf_conntrack          172032  1 nf_nat
nf_defrag_ipv4         16384  1 nf_conntrack
nf_defrag_ipv6         24576  1 nf_conntrack
nf_nat                 57344  1 iptable_nat
nls_cp437              20480  1
nls_iso8859_1          16384  1
ofpart                 20480  0
pcspkr                 16384  0
psmouse               180224  0
pwm_lpss               16384  1 pwm_lpss_platform
pwm_lpss_platform      16384  0
r8168                 565248  0
r8712u                200704  0
rc_core                61440  1 cec
rfkill                 28672  10 rfkill_gpio,asus_wmi,bluetooth,cfg80211
rfkill_gpio            16384  0
rt2800lib             143360  1 rt2800usb
rt2800usb              32768  0
rt2x00lib              90112  3 rt2800usb,rt2x00usb,rt2800lib
rt2x00usb              28672  1 rt2800usb
rtl8188ee             122880  0
rtl_pci                36864  1 rtl8188ee
rtlwifi               131072  2 rtl_pci,rtl8188ee
rtsx_pci               90112  1 rtsx_pci_sdmmc
rtsx_pci_sdmmc         32768  0
serio                  28672  9 serio_raw,atkbd,psmouse,i8042
serio_raw              20480  0
snd                   110592  14 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm
snd_hda_codec         163840  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_codec_generic    94208  1 snd_hda_codec_realtek
snd_hda_codec_hdmi     73728  1
snd_hda_codec_realtek   126976  1
snd_hda_core          106496  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hda_intel          57344  3
snd_hwdep              16384  1 snd_hda_codec
snd_intel_dspcfg       28672  1 snd_hda_intel
snd_pcm               143360  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer              40960  1 snd_pcm
soundcore              16384  1 snd
sparse_keymap          16384  1 asus_wmi
spi_nor                61440  1 intel_spi
squashfs               69632  0
stp                    16384  1 garp
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
uinput                 20480  0
usbhid                 65536  0
vfat                   24576  1
wmi                    36864  1 asus_wmi
xhci_hcd              290816  1 xhci_pci
xhci_pci               20480  0
x_tables               53248  3 iptable_filter,ip_tables,iptable_mangle

rfkill list

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
1: phy1: Wireless LAN
	Soft blocked: no
	Hard blocked: no

If your wifi is hard blocked you may have a faulty (or hidden wifi hardware switch).

The other cause of a hard block is a buggy kernel version, bad firmware, or incorrect driver version.

Another thing you can try is to reset your bios to the factory default.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by