NetworkManager getting DHCP error in WiFi

2 days ago the wifi in my house stopped working only for Manjaro, I have 1 Android, 1 my wife's iPhone and a Windows notebook, they are all connecting normally in WiFi (so I discarded errors in router).

Doing a journalctl -f -u NetworkManager I am seeing a:

dhcp (wlp2s0) internal error code 12 after dispatch

My wifi works in unprotected WiFi networks though (without password)

Does anyone know / already experienced this issue?

Try doing this:


Enable dhclient - Disable dhcpcd


Follow these directions to enable dhclient.

Change the DHCP client backend to dhclient:

Mask the dhcpcd.service.

sudo systemctl stop dhcpcd.service && sudo systemctl mask dhcpcd.service           

Ensure dhclient is installed:

sudo pacman -S dhclient --needed

Change the DHCP client backend to dhclient by creating a configuration file in /etc/NetworkManager/conf.d/.

Run the following command to auto-generate the required conf file:

echo -e "[main]\ndhcp=dhclient" | sudo tee /etc/NetworkManager/conf.d/dhcp-client.conf

Then reboot your computer and router.

Test your connection after making those changes.


The changes can be reversed with the following commands:

sudo rm etc/NetworkManager/conf.d/dhcp-client.conf && sudo systemctl unmask dhcpcd.service 

Reboot.

2 Likes

Hey @tbg it worked perfectly, thanks so much :sunglasses:

1 Like

You're very welcome. I'm so glad that solved your issue, and welcome to Manjaro.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by