NetworkManger inactive after resuming from suspend

Hi,
I'm using Manjaro stable: i3 + openrc
After the latest update I

NetworkManger service is showed inactivate after resuming from suspend. I'm cannot activate it using nm-applet, I tried to restart the service but the wifi still off.

  • if I'm connected using wifi and laptop gos sleep: NetworkManger ---> goes inactive after wake up. and I cannot use nm-applet (shows networking disabled) or nmtui to scan / connect wifi

  • if i'm coonected using ethernet and laptop goes sleep: nm-applet shows as "disconnected" and left click gives "Networking disabled" , but I still can connect using the browser and rc-status shows NetworkManager as active. When I disconnect I can not reconnect again using nm-applet (do not allow to reactivate network) and the rc-status shows NetworkManager as inactive. However, I can activated network using nmtuiand connect using ethernet (nm-applet still gives a wrong networking status: Networking disabled).

  • Quiting nmtui disconnect me, which is not the expected behaviour.

  • I get this message in dmesg: [ 147.634101] udevd[488]: RUN{builtin}: 'uaccess' unknown /usr/lib/udev/rules.d/73-seat-late.rules:15 when resuming from suspend... I deleted this file without result.

  • I tried to downgrade NetworkManager and nm-applet without result (nm-applet did launch)

For power management I'm using xfce power manager

Now, everytime I want to connect to wifi i have to reboot. For ethernet I can use nmtui but nor for wifi.
Any idea how to find the cause of this problem!

Well you're not the only one who has the issues...


I also facing the same problem tooo...
The workaround for now is to downgrade elogind

3 Likes

I think that should be downgrade elogind (and libelogind, to 227.2).

2 Likes

Oops! My mistake. Thanks for noticing it!

1 Like

Thanks @cimarronline and @thefallenrat
I'll try and reboot....

The other option when using elogind 229.3 is running one or both (as needed) of these commands to restore networking after suspend:

sudo rc-service NetworkManager restart
sudo nmcli dev set wlp3s0 managed yes

(with wlp3s0 replaced by your wireless interface)

3 Likes

Yes. I'm using elogind 229.3, so this solution is the best for me now.
Known bugs like that one should be noted on the update annoucement. I always read the annoucement before updating to prevent such problems. I waist much time. thns life savior.

2 Likes

I also downgraded to 227.2 and my system ran fine until the latest testing update. I am now booted in kernel 4.9 as I haven't been able to get an internet connection in 4.10 and & 4.11 after suspending. I NetworkManager widget did show there was no connection for a while but I had an Ethernet connection anyway. With this latest update there was no way to establish a connection until I booted into another kernel... @artoo are you there?

I just saw that there was a elogind update in unstable today and updated. I booted into kernel 4.11.3 and all was well, I suspended and came back and the NetworkManager widget shows it is disabled but I still have Internet connection...

This issue has been fixed with elogind-229.6-1.

5 Likes

Awesome! It's about time!

Hey, I know this is a stupid question, but when can this be expected to land on stable?

1 Like

Forum kindly sponsored by