New install - System Updates are stuck/frozen

I just installed the 18.02 KDE iso. And the very first I did (before installing anything tweaking settings, anything) was to update teh 129 packages that Manjaro had detected.

However, the process seems frozen. Its been stuck at the following steps for the past 27 minutes and couting

==> Image generation successful
( 3/19) Updating Grub-Bootmenu
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-4.19-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img

Does anyone have any idea what's going on and how to solve this?

I'm just sharing this in case if it matters; there are two additional HDs in the system, one which has an old version of Win 7 (but Manjaro is installed on its own drive with the bootloader installed on that drive as well)

Did you install on lvm?

No I don't believe I did. it was a generic install; heck I didn't even encrypt the HD

Looks like it is taking a long time to update grub. I would try being patient before giving up.

But surely not this long; we're about to hit the 45 minute mark.

This to me means something's wrong, rather than just let the system do its thing?

Well, yeah, it isn't supposed to take that long.

You have a few options I can think of.

  1. Try waiting and see if it finishes eventually.
  2. Find and kill the grub-mkconfig process and hope the rest of the post transaction hooks run. Then run update-grub before rebooting.
  3. Reboot.
  4. Wait for someone else to come along with a better idea.

#3 has a real chance of resulting in a system that doesn't boot. #2 is less risky than #3 but not ideal.

I honestly think its a HD issue (especially since we're stuck at grub). Its been an issue thats been affecting Manjaro since way back in May I think.

I hope its been resolved everytime, but no such luck.

My plan was to do a thorough system test with and without additional harddrives and see if the system was running fine. I guess that's what I'll do: reformat, and do the other tests I wanted to do and report back.

Hopefully someone can identify the bug; Manjaro has been unusuable for me for over 6 months now and I can't figure out why.


and will most likely remain so without more information. another thing you could try is disabling each drive from bios 1 at a time and see which is causing the problem. im assuming you have a manjaro usb handy? i ask because if your not able to get update-grub to finish successfully then your probably gonna be left with an unbootable manjaro. if thats the case you'll need to run manjaro-chroot -a
and update-grub from the live environment of the manjaro usb after disabling each drive. if after disabling one of them the trouble goes away then you know where/what to look for.

Right; that's probably what I'm going to do (but physically unplug the drives).

I have a list of complaints; but the combination of listing them here and on reddit, really hasn't gotten much traction.

My plan for tonight was to create a list of comprehensive issues that I've having with multiple harddrives (and I think this is symptomatic of it, after the grub can't be updated after over an hour) as well as what I feel is that solution (downgrade to an earlier kernel, 4.14).

But it is annoying regardless...and somewhat surprising that the issue isnt more widespread. I'd assume many people have multiple HDs, not just me.

As a point of reference, I have several machines with multiple hard drives and no issues with grub.

1 Like

maybe they are or they have in the past, dont know but i do know if your looking for a why then post much needed system information for those willing to help you. as of now you have mystery machine running on hamster wheels and magic dust.

Fair enough; but you're asking for information that I'm not ready to give yet. Heck I said it in frustration.

The issue at hand and for whome information I have provided (and am willing to provide more if someone is willing to ask for it) is regarding Manjaro's failure to complete system update on a brand new install.

we do have a rants and raves section for things like this.

did you get the impression is was only asking for fun? and i dont believe we have any psychic's available. if you make a help thread the least you could do is provide system info/logs and in your case drive layout.

i dont recall seeing this issue anywhere else on this forum and im here quite a bit. without info on your setup, nobody will be able to help you. that said, im sure forum members myself included would willing to help had i/they had the info needed to find a problem and resolve it. otherwise this thread can get moved to rants?

1 Like

FYI I've just had this occur on 2 existing installs.

Though it happened after a different issue where the computer failed to boot (some libidn missing during an update).

Using a live CD, then chroot, I get the same error above. This has occured on 2 machines which were already setup and have been in use for some months now, probably closer to a year for one.

The one worked by installing an older kernel from the cache - it still "stuck" at this point but just cancelling out was enough since in the message it had found all kernels etc.

Second machine is still having problems.

(For some reason backspace is having an issue so will update more details if rrrsssttt is still having issues).

Do you have any other Linux distros installed? If so make sure on those installations you have the package lsb-release installed on Manjaro AND in each other Linux installation. Without it, updating grub can take a long time to complete.

Nope, only install, only disk. One system has a second disk for timeshift only.

I've fixed mine for now by downgrading a kernel version - though still saw the error as above - just quit it out and everything was fine. Not really wanting to upgrade packages/kernels right at the moment though, for another day!

To chime in, I THINK the issue sort of goes away with kernel 4.14. If I switch to a newer LTS, that's where the problem begins.

A fresh install of Manjaro, now defaults to 4.17, which is also causing the issues.

that must be an older iso, all the recent ones are using 4.19 as default. remove 4.17 since its already past end of life and no longer supported/updated was when I tried it back in January. Maybe 4.19 fixes my problems...fingers crossed

both 4.14 and 4.19 are lts kernels, using either one is fine. 4.20 is another one you can also try.

Forum kindly sponsored by