New installation today, screen is pixelated.

Not yet, but will try that now

Ok so I booted again and Picked non-free drivers this time. After the installation was finished the problem with the screen tearing persisted. So I went to driver settings and installed “video-vesa”. After I rebooted it got stuck on a black screen.

Update: I made a clean install. This time I went with free drivers at boot because I have an AMD gpu. Still have pixelated screen.

A bit disappointed, Never had this problem with debian distros on this laptop.

Boot live iso, chroot in your system and install kernel > 5.2.
Use search function, it is all inside this forum.
Also post

inxi -Fxxxza --no-host

Solution was BIOS update:

Solution was kernel parameters:

1 Like

[prodeq12@acer-A515 ~]$ inxi -Fxxxza --no-host

  Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 
  root=UUID=64c52c4b-6e1d-4fb5-bee3-e23576c95629 rw quiet apparmor=1 
  security=apparmor resume=UUID=30578710-7235-4c37-a7f5-378082aecfcb 
  Desktop: Xfce 4.14.1 tk: Gtk 3.24.10 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Laptop System: Acer product: Aspire A515-43 v: V1.05 
  serial: <filter> 
  Mobo: PK model: Grumpy_PK v: V1.05 serial: <filter> UEFI: Insyde v: 1.05 
  date: 06/26/2019 
  ID-1: BAT1 charge: 42.3 Wh condition: 48.8/48.9 Wh (100%) volts: 16.2/15.2 
  model: LG 0x41,0x43,0x31,0x34,0x42,0x38,0x00BF type: Li-ion 
  serial: <filter> status: Discharging 
  Device-1: hidpp_battery_0 
  model: Logitech Marathon Mouse/Performance Plus M705 serial: <filter> 
  charge: 100% (should be ignored) rechargeable: yes status: Discharging 
  Topology: Dual Core model: AMD Ryzen 3 3200U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 18 (24) 
  stepping: 1 microcode: 8108102 L2 cache: 1024 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 20770 
  Speed: 1241 MHz min/max: 1400/2600 MHz boost: enabled Core speeds (MHz): 
  1: 1223 2: 1267 3: 1221 4: 1222 
  Vulnerabilities: Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Device-1: AMD Picasso vendor: Acer Incorporated ALI driver: amdgpu 
  v: kernel bus ID: 05:00.0 chip ID: 1002:15d8 
  Display: x11 server: X.Org 1.20.5 driver: amdgpu,ati unloaded: modesetting 
  alternate: fbdev,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD RAVEN (DRM 3.32.0 5.2.11-1-MANJARO LLVM 8.0.1) 
  v: 4.5 Mesa 19.1.5 direct render: Yes 
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 05:00.1 chip ID: 1002:15de 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Acer Incorporated ALI driver: N/A bus ID: 05:00.5 
  chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 05:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.2.11-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 2000 
  bus ID: 03:00.0 chip ID: 10ec:8168 
  IF: enp3s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Lite-On driver: ath10k_pci v: kernel port: 2000 bus ID: 04:00.0 
  chip ID: 168c:003e 
  IF: wlp4s0 state: up mac: <filter> 
  Local Storage: total: 119.24 GiB used: 6.26 GiB (5.2%) 
  ID-1: /dev/nvme0n1 vendor: Western Digital 
  model: PC SN520 SDAPNUW-128G-1014 size: 119.24 GiB block size: 
  physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 serial: <filter> 
  rev: 20110000 scheme: GPT 
  ID-1: / raw size: 110.15 GiB size: 107.92 GiB (97.98%) 
  used: 6.26 GiB (5.8%) fs: ext4 dev: /dev/nvme0n1p2 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap 
  swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/nvme0n1p3 
  System Temperatures: cpu: 43.5 C mobo: N/A gpu: amdgpu temp: 43 C 
  Fan Speeds (RPM): N/A 
  Processes: 193 Uptime: 3m Memory: 5.82 GiB used: 1.04 GiB (17.9%) 
  Init: systemd v: 242 Compilers: gcc: 9.1.0 Shell: bash v: 5.0.9 
  running in: xfce4-terminal inxi: 3.0.36 
[prodeq12@acer-A515 ~]$
1 Like

I dont know how to install a later kernel


Please :slight_smile:

Important knowledge

Please select the text in the terminal
Paste the text into the post
Select the newly pasted text in the post
Click the </> icon in the post toolbar

This creates nicely formatted text.

(Text was copied from @ linux-aarhus)

Need less place and will like very much by phone/tablet user :wink:

How to provide good information in your posts

Read post #12

sorry but I kindly need some assistance with this stressful issue. When a person is under stress they lack patience. If you would have some empathy you would understand that a person in my situation will not read any rules you wish us to follow. I am a noob here and I need help. My screen keeps tearing up all the words on screen making it difficult to read. Please (asking kindly) understand and help if you wish. Thanks

I updated my bios yesterday plus this laptop is 5 weeks old.

How you read this forum?
For bios update you need win, ubuntu, mint, redhat ....

For very new hardware it need some time for needed driver, sorry.
I have very old hardware and cant help changing kernel parameters.

Im readind this forum while the screen pixelates. very difficult!
let me go back a few days:
I was running linux mint everything was fine.
I bought and installed extra RAM.
I wanted to optimize performance
I checked for BIOS updates and found 1 new update.
I did update using windows.
I decided I wanted to go with manjaro because i hear its awesome with updates.
now my hardware is not old enough for manjaro.
solution roll back kernel
am I right?

Or Mint or Win, if older Manjaro kernel work fine with your hardware then use it, newer must not allways be better.
Hold always two kernel for security reason.

Its fixed.
Under Manjaro Settings Manager I went to Kernels then I installed kernel 5.1.21.
I uninstalled 5.2.11 which was active. I rebooted
Now is fixed!

Thanks for your help!

Actually when I was on mint I had to do the opposite. Mint puts you on an older kernel but certain thing where not working properly until I upgraded to kernel 5.0.

1 Like

Also possibly this thread?

uh... linux51 is EOL. In other words, dead. No more updates for it.
It's not a solution because it leaves you hanging in the wind.
The better solution would be to go back to linux419 or re-install linux52 and use the fix @cscs linked.

1 Like

Thanks. I went back to linux52 and tried your fix and it worked perfect.
But I have another issue, my screen brightness function does not work. screen is constantly bright and I cant adjust it.
This is happening on both kernels 51 and 52.

Those are key words for starting a new thread.

This one is solved, so a new thread is the accepted way forwards (i.e. keeping different issues in different threads).

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by