New Manjaro Xfce with no panel

Hi Experts, I'm a relative Noob on Linux, coming from Win10, so my terminology may be off as I describe the problem I'm seeing.

It's really pretty simple and I'm sure there is a simple solution. I was exploring a new Manjaro Xfce installation on my Raspberry Pi 4 (4G) and when I rebooted I found the panel at the bottom of the screen has disappeared. I can rt-click on the screen and get a menu but don't know how to restore the panel (dock?) at the bottom of the screen.

It seemed to happen after used sudo pacman -Syu in a terminal window then rebooted. I know that's not the likely cause but need help nonetheless.

Try

xfce4-panel -r

in a terminal and see if it get restarted.

No joy... I get an error message saying: The name org.xfce.Panel was not provided by any .service files.

Reinstall the panel:

sudo pacman -Syu xfce4-panel

Reboot (for good mesaure).

If what @Marte said doesn't work, you can create a new panel by

:point_right: Right click on the desktop -> Applications -> Settings -> Panel & use the exact same settings.

image

Appearance tab in the panel should be :point_down:

image

And in items add :point_down:
image

Add a seperator and tick the Expand box. That will push it to the right most side. You can play with separators to get the desired result. I added another separator and then moved it just next to the items in the right and expanded it to push the items to the right most side. But this looks to be a hack. Maybe someone else can elaborate on it better.

image

@bluewingedolive - hope this helps. Let me know if you have anymore questions.

1 Like

No joy again Marte. I did the reinstall as you indicated, as I did so it indicated that it was already installed. But I went ahead and had it download and update it anyway. And then I rebooted. No change.

TechnikHiLL: I tried your approach but when I try to open Panel (desktop->applications->settings->panel) it gives me an error. "Failed to show the preferences dialog. GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.xfce.Panel was not provided by any .service files.

Sorry @bluewingedolive, I am short of ideas now. I'll get back to you if I get some good ones in a strike of fortune :wink:

Have you tried it after a system reboot?

Edit: Came across this thread from Arch Linux forum. It says after some reboot it got fixed. Weird!
https://bbs.archlinux.org/viewtopic.php?id=251233

Looking at the arch topic, that IS the error I saw when I tried Marte's suggestion. I have rebooted once or twice, it hasn't fixed anything so far. I'll keep reading through arch and see what they found.

I've decided to go ahead and reload the micro-ssd. I didn't have a lot of changes invested in my instance. So I went ahead and reloaded. I can report that the panel is back, duh! And can add that a sudo pacman -Syuu did no hard to it.

4 Likes

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by