New to Manjaro and having some issues

Hello

I am new to Manjaro. Just bought a new laptop and installed Mint Cinnamon edition, had some issues which i couldn't resolve and am now trying Manjaro.
First issue is my laptop fan seems to be on way too much. It is coming on when the computer is idling or if i open one web page. Have checked the CPU usage on task manager and it is running at less than 5%. Checked the CPU temperature and it is around 29degrees.
The second issue is the colours on my screen look very washed out. Red seems to be almost pink. Every colour is very light, peoples faces look almost over exposed. I have tried changing the colour in colour profiles but it doesn't make a difference. I have adjusted screen brightness but it doesn't resolve it.
Very new to Linux having only used Peppermint before on a very old laptop, worked perfectly. So i am a bit lost trying to navigate a way to fix these issues
Thanks for any help.

Hello and welcome to Manjaro,
Is good to know a bit more information about the hardware you got there and what drivers, kernel boot parameter are used ... Here is how you can know what information is relevant to add to your topic:


Once we get that, is much easier to make suggestions.

1 Like

Thank you for the quick reply. Info below:

System:
  Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 82C7 v: Lenovo V15-ADA 
  serial: <filter> Chassis: type: 10 v: Lenovo V15-ADA serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: No DPK serial: <filter> UEFI: LENOVO 
  v: E8CN20WW date: 04/10/2020 
Battery:
  ID-1: BAT0 charge: 20.4 Wh condition: 35.5/35.0 Wh (101%) volts: 7.6/7.5 
  model: SMP L16M2PB2 type: Li-poly serial: <filter> status: Discharging 
  cycles: 2 
Memory:
  RAM: total: 5.75 GiB used: 1.89 GiB (32.9%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Topology: Dual Core model: AMD Ryzen 3 3250U with Radeon Graphics bits: 64 
  type: MT MCP arch: Zen+ rev: 1 L2 cache: 1024 KiB bogomips: 20770 
  Speed: 1227 MHz min/max: 1400/2600 MHz boost: enabled Core speeds (MHz): 
  1: 1368 2: 1465 3: 1244 4: 1220 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb 
  cpuid cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c 
  flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf 
  lahf_lm lbrv lm mca mce misalignsse mmx mmxext monitor movbe msr mtrr 
  mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat 
  pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb 
  pfthreshold pge pni popcnt pse pse36 rdrand rdseed rdtscp rep_good sep sev 
  sha_ni skinit smap smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 
  succor svm svm_lock syscall tce topoext tsc tsc_scale v_vmsave_vmload vgif 
  vmcb_clean vme vmmcall wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves 
Graphics:
  Device-1: AMD Picasso vendor: Lenovo driver: amdgpu v: kernel 
  bus ID: 03:00.0 chip ID: 1002:15d8 
  Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati unloaded: modesetting 
  alternate: fbdev,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD RAVEN2 (DRM 3.36.0 5.6.15-1-MANJARO LLVM 10.0.0) 
  v: 4.6 Mesa 20.0.7 direct render: Yes 
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 03:00.1 chip ID: 1002:15de 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Lenovo driver: N/A bus ID: 03:00.5 chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 03:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.6.15-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Lenovo driver: ath10k_pci v: kernel bus ID: 02:00.0 
  chip ID: 168c:003e 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1-6:3 
  chip ID: 0cf3:e300 
  WAN IP: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 7.28 GiB (3.1%) 
  ID-1: /dev/nvme0n1 vendor: Western Digital 
  model: PC SN520 SDAPMUW-256G-1101 size: 238.47 GiB speed: 15.8 Gb/s 
  lanes: 2 serial: <filter> rev: 20290001 scheme: GPT 
  Message: No Optical or Floppy data was found. 
RAID:
  Message: No RAID data was found. 
Partition:
  ID-1: / size: 224.77 GiB used: 7.28 GiB (3.2%) fs: ext4 
  dev: /dev/nvme0n1p2 label: N/A uuid: 4e9d19d4-3401-473a-a0b5-9ea9645e8792 
  ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat 
  dev: /dev/nvme0n1p1 label: N/A uuid: F269-70B3 
  ID-3: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p3 label: N/A uuid: 7839c3f2-7894-40e5-b998-d1ce6bcad7a8 
Unmounted:
  Message: No unmounted partitions found. 
USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 1-3:4 info: MosArt 2.4G Keyboard Mouse type: Keyboard,Mouse 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s 
  chip ID: 062a:5918 
  Device-2: 1-5:2 info: IMC Networks Integrated Camera type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 13d3:5a08 
  serial: <filter> 
  Device-3: 1-6:3 info: Qualcomm Atheros type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 0cf3:e300 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
Sensors:
  System Temperatures: cpu: 38.5 C mobo: N/A gpu: amdgpu temp: 38 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 197 Uptime: 53m Init: systemd v: 245 Compilers: gcc: 10.1.0 
  Shell: bash v: 5.0.17 running in: xfce4-terminal inxi: 3.0.37

Ok, it seems you are behind one update. make sure you do it before anything else. From terminal:
sudo pacman-mirrors -f && sudo pacman -Syyu
Reboot after that.

One thing you could try, is to install linux57
sudo mhwd-kernel -i linux57
and see if you boot from it things are better.

Also make sure you go trough this

Thanks for the reply. I've updated and installed linux57. I'll work my way through the AMD help and see how i get on. Hopefully can get it all working well as really enjoy Manjaro.

Hi. I have read through the suggested thread but don't see anything there that would help with the fan coming on constantly.
In the system information i posted above i notice this:
Sensors:
System Temperatures: cpu: 38.5 C mobo: N/A gpu: amdgpu temp: 38 C
Fan Speeds (RPM): N/A
Does the fact that the system can't recognise the Fan Speed pose a problem i.e. it doesn't know when it should be turning it on or off.zen processors.

I've only had the laptop a couple of days but am getting closer to putting it back in the box and sending it back. From what i can find on the web there seems to be a compatibility problem with the Ryzen processsors.

Thanks again

The system might not report the fan speed yet still work correctly, and in your case it doesn't do either of the two. My guess was that all starts with power management and some kernel boot parameters, or as stated there disable the C6 state.
Also i hoped that someone more experienced with AMD hardware will join. I still hope for your benefit that to happen.

Theres the TLP power management package that handles this sort of stuff maybe you could give it a try?

https://www.tecmint.com/tlp-increase-and-optimize-linux-battery-life/

Just tossing this here, maybe it'll help you (there seems to be a lot of people that recommend it on their top 20 to-do right after installing).

Thanks for that. TLP seems to be installed already. Interestingly i get the below when checking CPU temperature and fan speed using TLP. No CPU temp recorded and fan speed not available

$ sudo tlp-stat -t
--- TLP 1.3.1 --------------------------------------------

+++ Temperatures
Fan speed              = (not available)

I would look into your BIOS then, sometimes fans can be manually adjusted there. Since you have a Lenovo, press F1 when opening the laptop.

I do remember RoG and Gigabyte BIOSes having manual fan options at that level. Similarly, display color options may be present (but I wouldn't put too much faith there).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by