New user, Manjaro keeps force-shutting down HDD while poweroff

New user here, first time posting on forums, tell me if I'm doing something wrong:
I installed manjaro xfce on my MSI GL62M 7REX, default settings, overwriting my previous installation, onto my SSD. Everything is smooth, until when I shut down my system, and it powers off, but I hear a loud click.
My laptop makes the same noise when I try shutting it down by longpressing the power button, and I've tried describing the issue to my friends, who agreed it was the sound of my SSD being forced shut.
I've got everything else the way I want it, but this is not optimal for a healthy SSD. I can't find anything of this sort on the forums, so I don't know what to do. I tried digging on acpi, because Ubuntu did the same thing on my system, but it went away without me doing anything.

Why would you or your friends think it has something to do with SSD?

Do you and/or your friend(s) have a degree in electronic engineering?

1 Like

We are college students getting a degree, so maybe just not yet lol
But I found this, that described the same sound-issue and I'm just reading it now.

SSD's don't click. HDD's on the other hand can make click sounds. Maybe you get confused by the acronyms.

The over 10 year old bug report is about HDD's by the way.

1 Like

Yup, just reading it. My bad about SSDs, I don't know too much.
The report message #110 says that updating the kernel fixes it, and apparently I wasn't using a recommended LTS kernel. I'll change, and post back if that solves the clicky noise.

The click sound which may come from powering down a spinning storage device is usually due to the auto park of the device responsible for the transferring of magnetic impulses to the surface plate(s) of a spinning storage device.

I have never heard this should pose any problems.

But I do remember decades ago - some retailers claimed Linux wrecked their devices - I don't know if it was due to bad firmware or bad kernel code - but it was kind of funny.

Tried switching to kernel 4.19.84-1, still hear the clicking noise when I shut down. Not sure where to go from here, I'll try 4.14 too, and if that doesn't work I'm open to ideas

A little of topic

I don't now if you can still buy the green ones, they are now blue. But maybe it is the same firmware.

It has probably nothing to do with the click sound.

How about giving us some system info?

I haven't heard an HDD click since the old MFM/RLL drives went away ages ago.

Added bonus: I shutdown my HDD when it's not in use (only used as a backup target).

No clicks on powerdown OR powerup.

I don't know what to tell you, I tried changing kernels, no help. I'll keep looking for something, but I can't safely keep using Manjaro.

Some sound cards also produce a click on boot/shutdown.


Did you READ the link I gave you?

Oh well...:wave:

not related to your problem. but could you tell me how you got it to work? I got the same model laptop. I've cut secure boot and fast boot off non-free drivers and free-drivers. but all my laptop does is shutdown after about 30secs

I haven't gotten it to work, I'm trying ubuntu right now. I'll jump back in after my exams get over.
I tried installing Manjaro on my HDD, but now manjaro doesn't boot. I know that dual booting linuxes leads to some swap partition error, and I'm pretty sure that's why mine doesn't boot manjaro now.
Also , this time I installed Manjaro on my HDD, and it's completely silent now. I think when I installed Manjaro on SSD, it sent a stop request to my HDD on shutdown, and that request wasn't handled appropriately. This whole thing may have been a hardware issue. I'll post logs+details when I get manjaro working again.

Ok thanks human

Okay, update: I installed Manjaro 18.0 onto my HDD, no click sound on shutdown. I'll post logs later, but the only difference was this time I made the partitions manually, and made a 600 MB FAT32 /boot/efi partition with both boot and esp flags. Everything works, but Ubuntu had a few non-threatening messages before starting up that flashed by my screen. I'll look into those and say if something's up.

$  inxi -Fxxxza --no-host
System:    Kernel: 4.19.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN tk: Gtk 3.24.1 
           info: xfce4-panel wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Micro-Star product: GL62M 7REX v: REV:1.0 serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Micro-Star model: MS-16J9 v: REV:1.0 serial: <filter> UEFI: American Megatrends v: E16J9IMS.324 
           date: 03/23/2018 
Battery:   ID-1: BAT1 charge: 33.4 Wh condition: 37.1/42.4 Wh (88%) volts: 12.1/10.8 model: MSI BIF0_9 type: Li-ion 
           serial: N/A status: Charging 
CPU:       Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: 9 microcode: 8E L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44944 
           Speed: 800 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 799 2: 800 3: 800 4: 800 5: 800 6: 801 7: 801 8: 800 
           Vulnerabilities: Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Graphics:  Device-1: Intel vendor: Micro-Star MSI driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:591b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Micro-Star MSI driver: N/A bus ID: 01:00.0 
           chip ID: 10de:1c8c 
           Display: x11 server: X.Org 1.20.3 driver: intel unloaded: modesetting alternate: fbdev,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.5 Mesa 18.2.6 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a171 
           Sound Server: ALSA v: k4.19.12-1-MANJARO 
Network:   Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: e000 bus ID: 02:00.0 
           chip ID: 8086:24fb 
           IF: wlp2s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA8171 Gigabit Ethernet vendor: Micro-Star MSI driver: alx v: kernel port: d000 
           bus ID: 03:00.0 chip ID: 1969:10a1 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.03 TiB used: 5.97 GiB (0.6%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW128HEGR-00000 size: 119.24 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: CXB7401Q scheme: GPT 
           ID-2: /dev/sda vendor: Western Digital model: WD10SPZX-17Z10T0 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A01 scheme: GPT 
Partition: ID-1: / raw size: 254.60 GiB size: 249.61 GiB (98.04%) used: 5.96 GiB (2.4%) fs: ext4 dev: /dev/sda4 
           ID-2: swap-1 size: 980.0 MiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/dm-1 
           ID-3: swap-2 size: 16.95 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 62.0 C mobo: 27.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 224 Uptime: 5m Memory: 7.71 GiB used: 1.21 GiB (15.7%) Init: systemd v: 239 Compilers: gcc: 8.2.1 
           Shell: bash v: 4.4.23 running in: xfce4-terminal inxi: 3.0.28

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by