Newbie here. Computer won't boot after latest update

As the title says, I'm new to Manjaro, and I didn't realize I was expected to read the forum posts prior to applying the updates. So, a few days ago, after applying the updates, I leave my desk for about 30 minutes, and come back to a blank screen. I forced a reboot, and now the computer stalls at Started TLP system startup/shutdown. I posted on the Manjaro Linux subreddit, and they redirected me here.

So far I've tried adding nomodeset as a Kernel parameter for a one-time boot via grub. That seems to have helped it get a little further through the startup process, but not enough for me to actually log into my computer. I'm happy to provide any additional information, if needed.

And yes, from now on I will read the forum post before updating.

This may help:

Alright, I followed the directions there. The first step didn't work, but the second step (running startx) gave me some output and returned me to the command line. The only error (EE) line that I got reads:

Using system config directory "/usr/share/x11/xorg.conf.d" [missing bit of text] he log file at "/var/log/Xorg.0.log" for additional information. (EE) (EE) Server terminated with error (1). Closing log file.

I looked at the contents of var/log/Xorg.0.log and it looks like it's a problem with the NVIDIA kernel module. The very last error message says that no screens were found. There's another message that says to check the system's kernel log for more error messages, but I don't know how to get to that.

You might find How to provide good information in your posts helpful for accessing the journal, and otherwise. :smiley:

1 Like

Please make sure you refresh mirrors and update your system properly.

sudo pacman-mirrors -f8
sudo pacman -Syyu

Then reboot and only if it still has no GUI/Xorg running, provide more info.
Read the above posted tutorial to learn how to boot to TTY and post info from there.

inxi -SMGxxxz
mhwd -li
cat /etc/X11/xorg.conf.d/*.conf

I tried a few of those commands.

journalctl, regardless of what arguments I put after it, doesn't output anything to the console. Am I missing something?

dmesg outputs a lot to the console, but I'm posting on this forum from a separate computer, so I'm not sure how to copy and paste it from a computer that won't boot. Should I post pictures?

Apologies for the pictures, but I'm on a separate computer, so I can't really copy and paste.

I've already tried the first two commands you mentioned. The first one seems to work fine, but the second one outputs this:

and I still can't boot to the GUI.

Here's the output for inxi -SMGxxz and mhwd -li:

And the output for cat /etc/X11/xorg.conf.d/*.conf:

Database probably did get stuck due to the force reboot. Check if this file exists


If so you should be able to safely remove/rename it and try again with

pacman -Syyu

Generally speaking do so only if you are sure that Pacman isn't running or much worse problem could happens


Each proposed command has a purpose, not that you have to just run them whatever.. If you don't understand, follow the advice to the letter, or ask for more guidance.
It seems you haven't read the tutorial mentioned twice.
I am really disappointed.

sudo rm /var/lib/pacman/db.lck 
sudo pacman -Syyuu

That seems to have done the trick. Thank you very much!

1 Like

This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by