[newbie] issues with hotspot and gpu selection

I installed manjaro last night . loving it so far. i ran into two issues.
first: when i share my ethernet internet by creating hotspot i lose internet on the laptop and the device which connects to my hostpot doesnt get internet too
second: in linux mint nvidia drivers had a setting to choose between intel or nvidia gpu. but in manjaro there is no setting for that. i want to use intel gpu when i m not doing any heavy task.how can i do that?
output of inxi -Fxz

System:    Host: swastik-rogstrixg531gtg531gt Kernel: 5.4.23-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.1 
           Desktop: KDE Plasma 5.17.5 Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: ROG Strix G531GT_G531GT v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: G531GT v: 1.0 serial: <filter> UEFI: American Megatrends v: G531GT.305 
           date: 09/24/2019 
Battery:   ID-1: BAT0 charge: 27.4 Wh condition: 43.2/50.5 Wh (85%) model: ASUSTeK ASUS Battery 
           status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i5-9300H bits: 64 type: MCP arch: Kaby Lake rev: A 
           L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19204 
           Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK driver: nvidia v: 440.59 
           bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.7 driver: modesetting,nvidia unloaded: intel,nouveau 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.6 Mesa 19.3.4 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.4.23-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 
           v: kernel port: 3000 bus ID: 03:00.0 
           IF: eno2 state: down mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 296.21 GiB (62.1%) 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB 
Partition: ID-1: / size: 58.24 GiB used: 13.25 GiB (22.8%) fs: ext4 dev: /dev/nvme0n1p6 
Sensors:   System Temperatures: cpu: 43.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 3000 
Info:      Processes: 223 Uptime: 1h 04m Memory: 7.63 GiB used: 2.72 GiB (35.7%) Init: systemd Compilers: 
           gcc: 9.2.1 Shell: bash v: 5.0.16 inxi: 3.0.37

thanks in advance

Yes there is.
Open Settings > Hardware Configuration
Make sure you go over this too

2 Likes

A simple quick search of the forum would have given you the answer.

I personally use Optimus-Switch with the indicator I wrote for it.

@bogdancovaciu You must type faster than I do!

2 Likes

Off topic: I had, for very short time, that impression at one point till i saw a PRO typewriter doing her job, and she started laughing at the way i hold my hands on the keyboard :rofl:

1 Like

OT - @bogdancovaciu. Don't feel bad, I had the same thing happen to me. Typing is truly becoming a lost art.

1 Like

sir i tried that solution. i am getting the option to switch to nvidia but after selecting nvidia it logs me out and when i log back in it still shows intel in the panel.

I guess you went with optimus-switch or optimus-manager ... but i can't tell
What driver have you installed from that list? What option you followed from the first link provided by @linesma ?

mhwd -li

i followed this link Guide: Install and configure optimus-manager for hybrid GPU setups (Intel/NVIDIA)
and i installed optimus-manager
i went ahead and restored whatever settings i changed to not have any problems. thanks for helping me out.
output of mhwd -li

 Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI
           video-linux            2018.05.04                true            PCI


Warning: No installed USB configs!

Remove that and please take a look at the details when installing video-hybrid-intel-nvidia-440xx-primeon the link you provided ... there are a couple of things to make sure are the same. (just to make sure)

ok ill update u in a while

did everything still it wont change. should i revert everything i did ?

Did you made sure about this?

yeah i did . i guess my gpu is still not fully supported in arch. in linux mint there was a option within the nvidia-x server setting where i could choose which gpu to use. should i revert the things i did now?

The guide guides you exactly to have such option. Your responses are too vague, so it's hard to help you.
If you followed the guide, please, attempt to switch to nvidia two times and create the logs:

journalctl -b -p3 >journalctl.log.txt

journalctl -u optimus-manager.service >optimus-manager.log.txt

journalctl -u sddm.service >sddm.log.txt

Open them, go to the time when you were trying to switch, copy the output and paste here with proper formatting (code).

getting this error for 600 lines

-- Logs begin at Sat 2020-03-07 16:45:17 +0545, end at Mon 2020-03-09 12:21:42 +0545. --
Mar 09 12:10:12 swastik-rogstrixg531gtg531gt kernel: ACPI BIOS Error (bug): Failure creating named object [\_GPE._E4A], AE_ALREADY_EXISTS (20190816/dswload2-323)
Mar 09 12:10:12 swastik-rogstrixg531gtg531gt kernel: ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
Mar 09 12:10:14 swastik-rogstrixg531gtg531gt kernel: nouveau 0000:01:00.0: DRM: failed to create kernel channel, -22
Mar 09 12:10:54 swastik-rogstrixg531gtg531gt kernel: nouveau 0000:01:00.0: fifo: fault 09 [PHYS_WRITE] at 00000000ffef0000 engine c0 [BAR2] client 08 [HUB/HOST_CPU_NB] reason 0d [REGION_VIOLATION] on channel -1 [0000000000 unknown]
Mar 09 12:10:54 swastik-rogstrixg531gtg531gt kernel: nouveau 0000:01:00.0: fifo: fault 09 [PHYS_WRITE] at 00000000ffef0000 engine c0 [BAR2] client 08 [HUB/HOST_CPU_NB] reason 0d [REGION_VIOLATION] on channel -1 [0000000000 unknown]
Mar 09 12:10:54 swastik-rogstrixg531gtg531gt kernel: nouveau 0000:01:00.0: fifo: SCHED_ERROR 08 []
Mar 09 12:10:54 swastik-rogstrixg531gtg531gt kernel: nouveau 0000:01:00.0: fifo: fault 01 [VIRT_WRITE] at 000000000028b000 engine c0 [BAR2] client 08 [HUB/HOST_CPU_NB] reason 04 [UNBOUND_INST_BLOCK] on channel -1 [0000000000 unknown]
Mar 09 12:10:54 swastik-rogstrixg531gtg531gt kernel: nouveau 0000:01:00.0: fifo: SCHED_ERROR 08 []

you have the video-linux still installed i guess, and also i think you did not follow the process correctly ... Search for how to blacklist nouveau either trough kernel boot parameter or trough etc/modprobe.d/blacklist.conf

no video-linux is not installed and i m not able to find a way to blacklist noveau please help me out

is nouveau not noveau :slight_smile:



More trough forum search
https://archived.forum.manjaro.org/search?q=blacklist%20nouveau%20

can i just not remove nouveau..... i tried creating blacklist.conf with blacklist nouveau but it still doesnt work . it still runs on intel

What do you get if you run this command from terminal:
prime-run glxinfo | grep "server glx vendor string"

Forum kindly sponsored by