[newbie] issues with hotspot and gpu selection

A simple quick search of the forum would have given you the answer.

I personally use Optimus-Switch with the indicator I wrote for it.

@bogdancovaciu You must type faster than I do!

2 Likes

Off topic: I had, for very short time, that impression at one point till i saw a PRO typewriter doing her job, and she started laughing at the way i hold my hands on the keyboard :rofl:

1 Like

OT - @bogdancovaciu. Don't feel bad, I had the same thing happen to me. Typing is truly becoming a lost art.

1 Like

sir i tried that solution. i am getting the option to switch to nvidia but after selecting nvidia it logs me out and when i log back in it still shows intel in the panel.

I guess you went with optimus-switch or optimus-manager ... but i can't tell
What driver have you installed from that list? What option you followed from the first link provided by @linesma ?

mhwd -li

i followed this link Guide: Install and configure optimus-manager for hybrid GPU setups (Intel/NVIDIA)
and i installed optimus-manager
i went ahead and restored whatever settings i changed to not have any problems. thanks for helping me out.
output of mhwd -li

 Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI
           video-linux            2018.05.04                true            PCI


Warning: No installed USB configs!

Remove that and please take a look at the details when installing video-hybrid-intel-nvidia-440xx-primeon the link you provided ... there are a couple of things to make sure are the same. (just to make sure)

ok ill update u in a while

did everything still it wont change. should i revert everything i did ?

Did you made sure about this?

yeah i did . i guess my gpu is still not fully supported in arch. in linux mint there was a option within the nvidia-x server setting where i could choose which gpu to use. should i revert the things i did now?

The guide guides you exactly to have such option. Your responses are too vague, so it's hard to help you.
If you followed the guide, please, attempt to switch to nvidia two times and create the logs:

journalctl -b -p3 >journalctl.log.txt

journalctl -u optimus-manager.service >optimus-manager.log.txt

journalctl -u sddm.service >sddm.log.txt

Open them, go to the time when you were trying to switch, copy the output and paste here with proper formatting (code).

getting this error for 600 lines

-- Logs begin at Sat 2020-03-07 16:45:17 +0545, end at Mon 2020-03-09 12:21:42 +0545. --
Mar 09 12:10:12 swastik-rogstrixg531gtg531gt kernel: ACPI BIOS Error (bug): Failure creating named object [\_GPE._E4A], AE_ALREADY_EXISTS (20190816/dswload2-323)
Mar 09 12:10:12 swastik-rogstrixg531gtg531gt kernel: ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
Mar 09 12:10:14 swastik-rogstrixg531gtg531gt kernel: nouveau 0000:01:00.0: DRM: failed to create kernel channel, -22
Mar 09 12:10:54 swastik-rogstrixg531gtg531gt kernel: nouveau 0000:01:00.0: fifo: fault 09 [PHYS_WRITE] at 00000000ffef0000 engine c0 [BAR2] client 08 [HUB/HOST_CPU_NB] reason 0d [REGION_VIOLATION] on channel -1 [0000000000 unknown]
Mar 09 12:10:54 swastik-rogstrixg531gtg531gt kernel: nouveau 0000:01:00.0: fifo: fault 09 [PHYS_WRITE] at 00000000ffef0000 engine c0 [BAR2] client 08 [HUB/HOST_CPU_NB] reason 0d [REGION_VIOLATION] on channel -1 [0000000000 unknown]
Mar 09 12:10:54 swastik-rogstrixg531gtg531gt kernel: nouveau 0000:01:00.0: fifo: SCHED_ERROR 08 []
Mar 09 12:10:54 swastik-rogstrixg531gtg531gt kernel: nouveau 0000:01:00.0: fifo: fault 01 [VIRT_WRITE] at 000000000028b000 engine c0 [BAR2] client 08 [HUB/HOST_CPU_NB] reason 04 [UNBOUND_INST_BLOCK] on channel -1 [0000000000 unknown]
Mar 09 12:10:54 swastik-rogstrixg531gtg531gt kernel: nouveau 0000:01:00.0: fifo: SCHED_ERROR 08 []

you have the video-linux still installed i guess, and also i think you did not follow the process correctly ... Search for how to blacklist nouveau either trough kernel boot parameter or trough etc/modprobe.d/blacklist.conf

no video-linux is not installed and i m not able to find a way to blacklist noveau please help me out

is nouveau not noveau :slight_smile:



More trough forum search
https://archived.forum.manjaro.org/search?q=blacklist%20nouveau%20

can i just not remove nouveau..... i tried creating blacklist.conf with blacklist nouveau but it still doesnt work . it still runs on intel

What do you get if you run this command from terminal:
prime-run glxinfo | grep "server glx vendor string"

prime-run glxinfo | grep "server glx vendor string"
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  39
  Current serial number in output stream:  40

And one more time
mhwd -li

Forum kindly sponsored by