Nitrogen is not restoring wallpaper

hi guys,
after updating nitrogen is not restoring wallpaper.
look how it looks:

http://www.auplod.com/u/ualdop8bd48.png

any idea?

vlw fwi, Holmes :slight_smile:

I had this on Unstable/Testing I remember now, forgot to report. It should restore again after you define the default wallpaper with its GUI once. Run Nitrogen and select a wallpaper then relogin.

I had the same experience (unstable branch) - I was fiddling with fluxbox settings and when I reloaded there was no background. I thought it was something I did in editing fluxbox. I redefined the background and have been ok since.

i already did this and it does not restore!

vlw fwi, Holmes :slight_smile:

Have a look into your ~/.config/nitrogen folder, maybe the permissions are wrong, or some errors in the files. You can try renaming the folder to nitrogen.bak and run Nitrogen again.

nothing!

vlw fwi, Holmes :slight_smile:

I have the same issue here. Using openbox. Looks like command:nitrogen --restore doesn't work when invoked from script, eg. openbox autostart file.
Same command typed in terminal window works. Strange.

Try re-installing nitrogen ?

Issue on github https://github.com/l3ib/nitrogen/issues/86

1 Like

any idea if the problem can now be sorted without retyping nitrogen --restore every time I switch the machine on? Me with Manjaro, Openbox and no de (and kernel 4.9 since earlier today)

I use nitrogen-git compiled with --disable-xinerama for now without problems.
Here is package -> http://repo.maboxlinux.org/stable/x86_64/nitrogen-git-1%3Ar294.7747ef9-1-x86_64.pkg.tar.xz

1 Like

feh

 #/usr/bin/env sh
WALLPAPERS="/home/holmes/Imagens/Wallpapers"
desktop_bg=$(find "$WALLPAPERS" -type f | shuf | head -n 1) &&
exec feh --bg-scale "$desktop_bg"

vlw fwi, Holmes :slight_smile:

2 Likes

in my
~/.config/openbox/autostart

I moved the nitrogen command after conky and now nitrogen restore the bg,

you can also delay it by some seconds like so:

(sleep 2s && nitrogen --restore) &

hope this helps

1 Like

thanks nonino, tried this change but no luck, nitrogen still doesn't restore the photos...

hi Holmes, where should I insert these commands? And why does they mention few instead of nitrogen? You're meaning I should install and use feh instead of nitrogen? Thanks anywya :slight_smile:

This works for me too in my nitrogen OS (old i3).
On OS's with feh (Openbox from net-install) or on kde, I do not have this problem.
Just install feh (but should uninstall nitrogen first) and point to selected wallpaper.

https://wiki.archlinux.org/index.php/Feh

1 Like

thanks to everybody for the replies, and sorry as I didn't post any feedback but been too busy and had no time to sort this out... Ieaving for the Christmas holidays now... I'll have a look next year :smiley:
My best wishes to the community :christmas_tree:

Hey everybody, I had these problems too. All of them running Openbox. My solution was to uninstall nitrogen and install wallpaperd, which is not exactly a solution but more of a workaround. Wallpaperd is easy to configure but it doesn't have a browser, so you will need to use Viewnior or another image viewer when you want to change your background and get its name for the config.

One thing that is not mentioned in the instructions is that you will need to create a wallpaperd.desktop file in the /etc/xdg/openbox/autostart directory. Alternatively, you can also create a wallpaperd.desktop file in the ~/.config/autostart directory, which is useful if your computer hosts more than one user account. Wallpaperd works and has several configuration options.

Here are the contents of my wallpaperd.desktop file that I created:

[Desktop Entry]
Version=1.0
Name=wallpaperd
Comment=A small application that takes care of setting the background image
Exec=wallpaperd
Terminal=false
Type=Application

Two cents and one month later! :wink:

2 Likes

thanks for the info.
However I've decided that the easiest... workaround is just opening the terminal and writing nitrogen --restore every time I switch the pc on, sure it's just a newbie/lazy way :wink: and not what a proper geek would do but... it takes a very few seconds and I don't need to uninstall, install, learn to use another application... thanks anyway and I'll sure keep your hints in case nitrogen stops to work completely :smiley:

Hey @Finrod, the instructions for Wallpaperd are very clear and easy to follow, they are just a little incomplete, so I wrote what was missing in my post. An example wallpaperd.cfg is installed where all you have to do is enter your image directories and the image you want to use on your desktop. Believe me, you won't make any mistakes using it.

For your autostart directory, you could actually use my wallpaperd.desktop file - that I posted previously - and it would work on your machine. Nothing about it is system/desktop environment specific. Just follow the instructions in that post.

If you do decide to use Wallpaperd, and do have some trouble understanding it, let me know and I'll help you through it. :wink:

Forum kindly sponsored by