Nm-applet icon problem

Hello,

I have a problem with the nm-applet icon in Manjaro i3wm Community Edition.

Sometime even if I am connected to my wifi it shows the not-connected-icon. When I then click on it, I can't see any Wifinetworks. I can only click "Disconnect".

A workaround is to killall nm-applet and then nm-applet. But that is pretty annoying.

Can anybody help me?

Systeminfo:

           Desktop: i3 4.13-non-git Distro: Manjaro Linux
Machine:   Device: laptop System: LENOVO product: 20AV002YGE v: ThinkPad L540
           Mobo: LENOVO model: 20AV002YGE v: 0B98401 Pro
           UEFI: LENOVO v: J4ET81WW(1.81) date: 08/14/2015
Battery    BAT0: charge: 26.4 Wh 58.7% condition: 44.9/56.2 Wh (80%)
           model: LGC 45N1147 status: Charging
CPU:       Dual core Intel Core i5-4200M (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9980
           clock speeds: max: 3100 MHz 1: 2500 MHz 2: 2500 MHz 3: 2500 MHz
           4: 2500 MHz
Graphics:  Card: Intel 4th Gen Core Processor Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 driver: intel
           Resolution: 1920x1080@60.01hz, 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile
           GLX Version: 3.0 Mesa 13.0.1 Direct Rendering: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.4.33-1-MANJARO
Network:   Card-1: Intel Ethernet Connection I217-V
           driver: e1000e v: 3.2.6-k port: 5080 bus-ID: 00:19.0
           IF: enp0s25 state: down mac: 3c:97:0e:ef:57:1e
           Card-2: Intel Wireless 7260 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: 7c:7a:91:21:57:be
Drives:    HDD Total Size: 500.1GB (10.0% used)
           ID-1: /dev/sda model: Samsung_SSD_840 size: 500.1GB
Partition: ID-1: / size: 441G used: 31G (8%) fs: ext4 dev: /dev/dm-0
           ID-2: swap-1 size: 18.39GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
Sensors:   System Temperatures: cpu: 44.0C mobo: 40.0C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 165 Uptime: 1:56 Memory: 1066.1/15949.0MB
           Init: systemd Gcc sys: 6.2.1 Client: Shell (zsh 5.2) inxi: 2.3.4``` 

Thanks

The only 'fix' is downgrade right now ... or write a script for disable/enable on wake from suspend

1 Like

Thanks. I used the restart method and will wait for a fix :slight_smile:

Forum kindly sponsored by