No activity on HDMI output despite manjaro recognising connection

When I connect my laptop to HDMI, it recognizes that an o/p source is connected (see screenshot below) but the TV/monitor I'm connecting to stays blank (says something along the lines of "No input connected").

There are issues similar to mine on this forum and elsewhere, but most of them seem to reach the configuration solution (w.r.t. to the display drivers) that I currently already have.

[sorosrex@mjr_dsk ~]$ inxi -Fx
System:    Host: kaos Kernel: 5.4.35-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: KDE Plasma 5.18.4 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 15 7000 Gaming v: N/A serial: <root required> 
           Mobo: Dell model: 0MK77P v: A00 serial: <root required> UEFI: Dell v: 1.10.0 date: 05/17/2019 
Battery:   ID-1: BAT0 charge: 30.0 Wh condition: 53.5/74.0 Wh (72%) model: Samsung SDI DELL 0GFJ673 
           status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i5-7300HQ bits: 64 type: MCP arch: Kaby Lake rev: 9 
           L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20004 
           Speed: 1100 MHz min/max: 800/2500 MHz Core speeds (MHz): 1: 1100 2: 1097 3: 1100 4: 1100 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Dell driver: nvidia v: 440.82 
           bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.0.5 direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.4.35-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel 
           port: d000 bus ID: 02:00.0 
           IF: enp2s0 state: down mac: 64:00:6a:fd:d2:8e 
           Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel port: d000 bus ID: 03:00.0 
           IF: wlp3s0 state: up mac: 7c:67:a2:33:b2:ce 
Drives:    Local Storage: total: 1.17 TiB used: 22.35 GiB (1.9%) 
           ID-1: /dev/sda vendor: Toshiba model: THNSNK256GVN8 M.2 2280 256GB size: 238.47 GiB 
           ID-2: /dev/sdb vendor: Western Digital model: WD10JPVX-75JC3T0 size: 931.51 GiB 
           ID-3: /dev/sdc type: USB vendor: Generic model: SD MMC MS PRO size: 29.72 GiB 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 bus ID: 00:17.0 
Partition: ID-1: / size: 25.94 GiB used: 22.35 GiB (86.1%) fs: ext4 dev: /dev/sdc2 
           ID-2: swap-1 size: 2.94 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdc3 
Sensors:   System Temperatures: cpu: 51.0 C mobo: 43.0 C sodimm: 45.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 192 Uptime: 47m Memory: 7.65 GiB used: 1.75 GiB (22.8%) Init: systemd Compilers: gcc: 9.3.0 
           Shell: bash v: 5.0.16 inxi: 3.0.37

Screenshot_20200430_215103
Above is the screenshot of my display controller in the Settings window where you can see the installed drivers.

In the Nvidia settings window, you can see that the computer recognizes the HDMI output, in this case being SKK181 (for Philips 32PFL3738).

I don't know where the SKK181 comes from but it shows the same product if you google this code.

The same happens with my other TV, which is a Sony Bravia KLV-40W562D. In this case it shows "SONY-TV" instead of SKK181 (refer screenshot above).

In light of the recent situation, where work from home is being encouraged, I end up switching away from Manjaro if I have to use these external displays in my home. Please advise what I could do.

Cheers
sorosrex

  1. A TV is a bad monitor: depending whether or not it supports overscan or not, it might never work well.

  2. What happens if you run an application using

    prime-run szApplicationName
    

    Does the HDMI monitor turn on then?

    If yes, this is a "feature" of your Dell Inspiron: the HDMI port gets driven by the nvidia GPU only.

    If you want the HDMI port to be available at all times, you have to run in pure nVidia mode instead of hybrid mode or be content with running an application on the HDMI port using prime-run...

:innocent:

Thanks for your quick reply, and apologies for my late revert.

I tried your command unsuccessfully. I also tried some variations of it to ensure I got it correct. Here are all the commands I tried.

  1. prime-run szFirefox
  2. prime-run Firefox
  3. prime-run dolphin
  4. prime-run szdolphin
  5. prime-run szDolphin

None of these worked.

Regarding point 1 in your reply, I expected it to "just work" because these TVs have "just worked" with all other Linux based platforms (tried Ubuntu, Fedora, Kali) by simply plugging in the HDMI cable. I do not claim to have sufficient knowledge and am stating solely based on my observations here.

Based on other posts, I presume that running in nVidia only mode will result in decreased battery life (please correct me if I'm wrong here). I guess I can afford that, for the most part. It's not like I'm traveling anywhere with this laptop anyways.

If no solution is possible with this configuration, can you point me to posts/others where I can read on how to shift to nVidia only mode like you stated? Had high hopes from Manjaro to work right out the box.

Thanks!

To install the proprietary nVidia driver:

  • Log off

  • Switch to TTY2 by pressing Ctrl+Alt+F2

  • Log in there

  • Execute:

    mhwd --listinstalled
    sudo mhwd --remove pci szFirstLineThatCameOutOfCommandAbove 
    sudo mhwd --remove pci szSecondLine
    # Repeat until all lines are gone
    sudo mhwd --install pci video-nvidia-440xx 
    sudo reboot
    
  • Try again...

Is it okay to install it from the hardware configuration settings because I have this driver as an option there (refer to the image in my original post)?

PS. Solely asking for convenience purposes. Will go to TTY2 if you say so.

upload

Got this

Looks like you don't have an internet connection...
What does

nmcli networking connectivity 

give you?

and do you know the name of the WiFi network you connect to?

If yes, do a:

nmcli con up szNameOfSSID --ask

where obviously szNameOfSSID is the name of the WiFi networt.

If not: juts do the first command

I figured the same and connected my Ethernet cable. I was able to install the driver after that without having to configure the network like you stated.

Unfortunately, now Manjaro won't boot up. It is stuck in the screen shown below
IMG_20200506_214020

Sometimes, the boot process proceeds a little bit further than show in the pic - some processes are started - but it invariably ends up freezing somewhere on this screen only (I have waited upto 20 minutes).

Thanks again!

That looks like a hardware error unrelated to your original issue:

Remove the RAM from bank 6-9, clean the contacts with isopropyl-alcohol or vodka if you don't have any and re-seat it.

¯\_(ツ)_/¯

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by