No batteries detected on Manjaro

I was using Mint until i changed for Manjaro openbox; the problem was that i see there's no battery icon and after investigate it i discover that Manjaro don't detect the battery.

If i use sudo acpi -b doesn't return anything; sudo tlp stat says that No battery detected.

So i try to use a liveusb of Manjaro, the problem still here (i test on Manjaro openbox, kfce and awesome editions), then i tried with Arch linux and the problem was the same...
But when i use a liveusb of Mint there's no battery status problems.

Maybe i uninstall it wrong? It's possible that there's a kernel issue??
Don't know what to do... :frowning:

please post properly formatted system info.

inxi -Fxxxz

Sorry; here's the output:

  Host: carter Kernel: 4.19.23-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Openbox 3.6.1 info: tint2, polybar dm: LightDM 1.28.0 
  Distro: Manjaro Linux 

  Type: Laptop System: LENOVO product: 81FK v: Lenovo ideapad 330-15ICH 
  serial: <filter> Chassis: type: 10 v: Lenovo ideapad 330-15ICH 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0R32862 WIN serial: <filter> 
  UEFI: LENOVO v: 7ZCN29WW date: 10/24/2018 

  Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 9216 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 53004 
  Speed: 1910 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 1400 2: 1400 
  3: 1400 4: 1400 5: 1401 6: 1400 7: 1400 8: 1400 9: 1400 10: 1400 11: 1401 
  12: 1400 

  Device-1: Intel UHD Graphics 630 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Lenovo 
  driver: N/A bus ID: 01:00.0 chip ID: 10de:1c8d 
  Display: x11 server: X.Org 1.20.3 driver: intel compositor: compton 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) 
  v: 4.5 Mesa 18.3.3 compat-v: 3.0 direct render: Yes 

  Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k4.19.23-1-MANJARO 

  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel 
  port: 5000 bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlp0s20f3 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: N/A port: 3000 bus ID: 07:00.0 chip ID: 10ec:8168 

  Local Storage: total: 931.51 GiB used: 17.28 GiB (1.9%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-24Z10T0 
  size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: 1A01 scheme: GPT 

  ID-1: / size: 97.93 GiB used: 9.73 GiB (9.9%) fs: ext4 dev: /dev/sda6 
  ID-2: /home size: 98.60 GiB used: 7.55 GiB (7.7%) fs: ext4 dev: /dev/sda7 
  ID-3: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5 

  System Temperatures: cpu: 47.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 

  Processes: 281 Uptime: 25m Memory: 7.66 GiB used: 978.5 MiB (12.5%) 
  Init: systemd v: 241 Compilers: gcc: 8.2.1 Shell: zsh v: 5.7.1 
  running in: termite inxi: 3.0.30

its been a little while but i dont think openbox defaults to having a battery meter unless you enable it (i could be wrong).
please post:

ls -1 /sys/class/power_supply/
cat ~/.config/polybar/modules.conf
cat ~/.config/polybar/config
cat ~/.config/polybar/modules/battery.conf

Return to ls -1 /sys/class/power_supply/

Return to cat ~/.config/polybar/modules.conf

;     Modules

## Uncomment for alsa module
#include-file = $HOME/.config/polybar/modules/alsa.conf
## Uncomment for battery module
include-file = $HOME/.config/polybar/modules/battery.conf
## Uncomment for clock module
include-file = $HOME/.config/polybar/modules/clock.conf
## Uncomment for compton toggle module
#include-file = $HOME/.config/polybar/modules/compton_toggle.conf
## Uncomment for cpu use module
include-file = $HOME/.config/polybar/modules/coreuse.conf
## Uncomment for custom menu module
#include-file = $HOME/.config/polybar/modules/custom_menu.conf
## Uncomment for ethernet status module
#include-file = $HOME/.config/polybar/modules/ethernet.conf
## Uncomment for filesystem inf module
#include-file = $HOME/.config/polybar/modules/filesystem.conf
## Uncomment for keyboard module
#include-file = $HOME/.config/polybar/modules/keyboard.conf
## Uncomment for jgmenu module (Manjaro)
include-file = $HOME/.config/polybar/modules/manjaro.conf
## Uncomment for memory module
include-file = $HOME/.config/polybar/modules/memory.conf
## Uncomment for media player daemon module
#include-file = $HOME/.config/polybar/modules/mpd.conf
## Uncomment for network status module
include-file = $HOME/.config/polybar/modules/network.conf
## Uncomment for update status module
include-file = $HOME/.config/polybar/modules/pkg.conf
## Uncomment for pulse audio module
#include-file = $HOME/.config/polybar/modules/pulseaudio.conf
## Uncomment for redshift module
#include-file = $HOME/.config/polybar/modules/redshift.conf
## Uncomment for CPU temperature module
include-file = $HOME/.config/polybar/modules/temperature.conf
## Uncomment for window switcher module
include-file = $HOME/.config/polybar/modules/window_switch.conf
## Uncomment for wireless network module
#include-file = $HOME/.config/polybar/modules/wireless.conf
## Uncomment for workspaces module
include-file = $HOME/.config/polybar/modules/workspaces.conf

Return to cat ~/.config/polybar/config

;     Openbox Bars

inherit = bar/master

; Use $ xrandr -q | grep " connected" | cut -d ' ' -f1
monitor = eDP1
monitor-fallback = 

;tray-position = center
;tray-padding =
;tray-transparent = true
;tray-background = #0063ff

modules-left   = manjaro workspaces window_switch
modules-center = battery
modules-right  = coreuse pkg memory temperature clock

Return to cat ~/.config/polybar/modules/battery.conf

type = internal/battery
; Use $ ls -1 /sys/class/power_supply/
battery = BAT0
adapter = ADP0
full-at = 98
poll-interval = 5
time-format = %H:%M

format-charging    = <animation-charging> <label-charging>
format-discharging = <ramp-capacity> <label-discharging>
format-full        = <ramp-capacity> <label-full>

ramp-capacity-0 = 
ramp-capacity-1 = 
ramp-capacity-2 = 
ramp-capacity-3 = 
ramp-capacity-4 = 
ramp-capacity-0-foreground = ${colors.urgent}
ramp-capacity-1-foreground = #ffa900
ramp-capacity-foreground   = ${}

bar-capacity-width = 10
animation-charging-0 = " "
animation-charging-1 = " "
animation-charging-2 = " "
animation-charging-3 = " "
animation-charging-4 = " "
animation-charging-framerate = 750

have you try with kernel4.20 ?

i think its worth a try since your battery is not even detected, are you doing this while plugged into AC power? try the 4.20 kernel and check again and do it while on battery power

Okay, kernel changed, then i tried it again but there's no change in any instruction.

did you add any custom kernel parameters?
please post:
cat /etc/default/grub | grep CMDLINE

Yes, i add this two because on first time i think that was a problem of polybar.


you added these for the purpose of fixing your battery issue? or for some other reason?

can you post the actual output of:
cat /etc/default/grub | grep CMDLINE

its important how they are formatted acpi_osi="Linux" is not formatted properly and from what you posted is just sitting on its own line? it should be something like this:

~ >>> cat /etc/default/grub | grep CMDLINE                                      
GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=Linux  <other parameters>"

I added the lines because i post the problem in Newbie Corner (when i think that the problem was of the battery module of polybar), and someone tells me that if i change that maybe the problem was solved.

The output its exactly this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=08afdb48-8cae-445d-aa46-08727236c220 acpi_osi=Linux"

ok, lets try this, edit like this:

GRUB_CMDLINE_LINUX_DEFAULT=“acpi_osi=! acpi_osi=Linux resume=UUID=08afdb48-8cae-445d-aa46-08727236c220 ”

sudo update-grub
test again

There's no change... This is very frustrating xD

i just found something mentioned on github that kernels above 4.18 have acpi issues with your model and to use 4.14
sudo mhwd-kernel -i linux414

you can try using 4.14 both with and without those 2 kernel parameters


check each time with
ls -1 /sys/class/power_supply/
acpi -b


Im trying it, comment in few minutes.
Lot of thanks!

EDIT: It works fine!
I dont know how to thanks, thank you !!!!!!!!!!!:star_struck:

good to hear. after switching to 4.14 it worked? with or without the parameters?

After switch to 4.14, the unique problem was that the touchpad dont works, buuuut thats nothing (i solved that searching).
So thank you dglt!

1 Like

sometimes the acpi_osi=! parameter can break things like touchpad, either way you got it working so all is good. :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by