No boot menu

Just installed manjaro KDE. I wanted to dual boot with windows 10. i have selected mount point for efi as /boot/efi and installed manjaro. after install and reboot there is no grub boot menu. it just boots directly to windows 10IMG_20180811_202931 . when booting with USB and choose "detect boot" then i was able select manjaro and boot up the system. later upon some searching i have red that i need to install reFINed. i did that and still no use. after installing reFINed i now cant boot to manjaro even through "detect boot" option from USB. it kind of stops as shown in pic. please help.

Read this. First post, completely. And if problem again or don't understand, provide information as listed in the link.

ps: you may hae a graphic driver issue and after trying above, try booting to prompt and get info required.
To boot to prompt, add '3' in linux line of grub entry. If still don't understand, search forum for "booting to prompt"


IMG_20180811_231959 I am getting this after step 4. I.e. I choose Manjari from original manjaro grub menu. I get the error as shown in pic and the. Screen shows up like as in the pic I attached in the main topic thread.

Before installing reFINed I installed proprietary Nvidia drivers version 390. And I have used Rufus to create Bootable usb in "DD mode". Normal "ISO mode" gives and error grub unknown file system. I kind of forgot the exact terms. It's something like Unknown filesystem. I searched and found that I had to use "DD mode" and I used it.
Secure boot and fast boot are turned off.

"Press any key to continue..."

Did you press the 'any' key? It's in the keyboard somewhere.

?? I don't know what u mean. After 4th step with those 2 command lines. I get the above msg as shown in pic with first line as error stuff and last line with press any key. I did press "Enter" key and then Bunch of text shows up which is exactly like the pic in the 1st post.

Correct. I know what you mean.
At 2nd screen, you press 'any' key. Then you get 1st screen.
That's right.

Do you know what I mean above?

I think u to saying that the manjaro isn't booting up cos of graphic driver issue as in " fail to load kernel module".
Ok here's what I did
Now I followed the steps until step 4 and the instead of choosing manjaro I press " E ". Then remove "quiet" ONLY. Theres no word "Splash" ONLY word quiet was there. So I removed it and entered "3" and hit enter. Then I got 2 screen and then it asked for login and password. So now I am on completely command line interface I think. I did enter my username and password 15340132164236939425645783942667

Good. And correct. Now we need the information from the link...

efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi

Please take screen shots clearly...

Oh, if you still can,

mhwd -l
mhwd -li

See... you're doing well.
But it's late here and I need my sleep soon.
If others want to take over.., please do.
(I don't think so though) , maybe my partner might.

1 Like

IMG_20180812_095636 IMG_20180812_095557 IMG_20180812_095851 IMG_20180812_095803

I think it is showing debian and fedora in boot.. but I hadn't installed debian or fedora in this system. Although I have booted up live risk but didn't install either

What is your computer make and model?
Right. Boot up to prompt again. Do the following.

sudo pacman-mirrors -f 5
sudo pacman -Syyu
sudo mhwd -r pci video-nvidia-390xx
sudo mhwd -r pci video-linux
sudo pacman -Syu
sudo mhwd -a pci  nonfree 0300
sudo pacman -Syu
sudo grub-install
sudo update-grub
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 2 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

Is 'manjaro' entry now appearing in the last command and is it at the top of the bootorder?
BootOrder : xxxx,yyyy,zzzz.....
xxxx is 'manjaro'?

Reboot normally. If that still does not boot up to Manjaro, Boot up again (the hard way) and type in "efibootmgr" again. Is 'manjaro' missing again?

Let us know and we'll fix it.
Besides output of efibootmgr need contents of /boot/efi

ls /boot/efi/
ls /boot/efi/EFI/
(And the contents within), say
ls /boot/efi/EFI/manjaro/
ls /boot/efi/EFI/ubuntu/
ls /boot/efi/EFI/debian/

And reminder, let us know computer make and model.

[EDIT] - corrected 'mhwd -r' commands to include 'pci'

1 Like

What will happen if I just reinstall manjaro. Format the current partition and do a clean install. Will it fix it? . Will the 100MB efi partition contain extra boot data if I reinstall??
And y did I get this problem . I installed mint debian fedora and all but never faced this problem. I haven't tried out the solution yet cos power cut.15340787867942680588483185315745
I am getting this.

Should be

sudo mhwd -r pci video-nvidia-390xx
sudo mhwd -r pci video-linux

Doesn't matter what you installed, but the truth matters. All the time.
You need to answer first before I answer more questions from you.
You latter questions depends on the former.

1 Like

its a desktop. built it. core i7-4770, 16GB RAM, 1TB HDD SATA, GTX 760, 2GB graphic card,
intel DH87MC desktop board

Continue with my post in post 9. Note the correct commands for mhwd.
Continue regardless of error or blank output.

New reinstall other than graphics will not fix the problem. Don't worry about extra data (ubuntu, debian) in/boot/efi (except perhaps just (cmos) memory for your uefi firmware). We'll clean up after all is fixed.

IMG_20180812_214614 IMG_20180812_214806

After reboot i got grub boot menu and I chose manjaro and after that I still got this.153409097832115079209511754212

Correct. You are already booting to installed OS. Congratulations.
The problem now is your graphic drivers.

Fix it with the mhwd commands, but you must do it from prompt or from a tty.

5 posts were split to a new topic: Video tearing in KDE


Please stop posting multiple high-resolution photos which aren't necessary. Storage space on the server isn't free and you've already used 11MB of space just for this one thread. The forum isn't a media hosting site.

I'm going to mark this thread as solved and split out your other issue to a new thread.

Please post different issues to their own thread.

Forum kindly sponsored by