No bootloader option after installation

Hello guys,
I am new to this linux world and I have just installed Manjaro.
I have 2 ssd in my laptop: the first one (the main) running w10 and in the 2nd one I tried to install manjaro.
I followed many video guides, but coulnd't manage to solve my problem. So basically, the installation goes without any problem but when i restart there's no option for booting linux. It seems like the 2nd ssd it's not even bootable (it's not listed in boot manager). I tried many guides, thinking the problem was the Uefi bios, and created partitions manually, but it did not work. Maybe a problem with partitions type. How do I get it done?
If i use the usb live installation and go to "search for efi boot or something like that" I can boot the OS properly, but without it no luck.
WhatsApp Image 2020-01-30 at 13.28.02
Thanks for any help.

Have a look in your bios boot priorities and move Manjaro to the top. If there isn't an entry follow this guide to boot into your install from the grub prompt on the live USB (C at the menu in that picture) update grub, and add a uefi boot entry.

Thank you for the reply. I tried what's written in the guide but at this stage "sudo update-grub" I find an error:

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
grub-probe: error: cannot find a GRUB drive for /dev/sdc1. Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdc1. Check your device.map.
Found Windows Boot Manager on /dev/sda2@/efi/Microsoft/Boot/bootmgfw.efi
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

Reboot.

And in the link, there's a part [If further help needed] to print out the details required to be able to help you if you still need help.

[sauvage@sauvage ~]$ efibootmgr -v
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0001,2001,2002,2003
Boot0000* manjaro HD(1,GPT,8e2831d5-5e4d-42e6-82e9-47641752d35f,0x1000,0x96000)/File(\EFI\manjaro\grubx64.efi)
Boot0001* Windows Boot Manager HD(2,GPT,4a356ac7-12b0-4a9d-9f67-602475ae2ca3,0xfa000,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...a................
Boot0002* USB HDD: KingstonDataTraveler 2.0 PciRoot(0x0)/Pci(0x1d,0x0)/USB(0,0)/USB(0,0)/HD(1,MBR,0x0,0x4fb984,0x2000)RC
Boot0003* HDD2: CT250MX500SSD1 PciRoot(0x0)/Pci(0x1f,0x2)/Sata(1,0,0)/HD(1,GPT,8e2831d5-5e4d-42e6-82e9-47641752d35f,0x1000,0x96000)RC
Boot0004* CT250MX500SSD1 BBS(USB,CT250MX500SSD1 ,0x500)................-.■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■
Boot2001* EFI USB Device RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC
[sauvage@sauvage ~]$ sudo parted -l
[sudo] password for sauvage:
Sorry, try again.
[sudo] password for sauvage:
Model: ATA KINGSTON SA400S3 (scsi)
Disk /dev/sda: 480GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 524MB 523MB ntfs Basic data partition hidden, diag
2 524MB 629MB 105MB fat32 EFI system partition boot, esp
3 629MB 646MB 16,8MB Microsoft reserved partition msftres
4 646MB 480GB 479GB ntfs Basic data partition msftdata

Model: ATA CT250MX500SSD1 (scsi)
Disk /dev/sdb: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 2097kB 317MB 315MB fat32 boot, esp
2 317MB 250GB 250GB ext4

Model: Kingston DataTraveler 2.0 (scsi)
Disk /dev/sdc: 15,7GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
2 2675MB 2679MB 4194kB primary esp

[sauvage@sauvage ~]$ sudo blkid
/dev/sda1: LABEL="Recovery" UUID="321298051297CC6B" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="52eeb89b-a4b5-40ad-b7c8-ac1535279b9d"
/dev/sda2: UUID="5A9A-61B1" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="4a356ac7-12b0-4a9d-9f67-602475ae2ca3"
/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="30bc00ce-dd88-4d95-a8eb-e4304c97f5f6"
/dev/sda4: UUID="96689E0E689DED6D" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="faf6c1af-0cae-433e-bcc2-8c848baa452d"
/dev/sdb1: UUID="FB2C-A3A8" TYPE="vfat" PARTUUID="8e2831d5-5e4d-42e6-82e9-47641752d35f"
/dev/sdb2: UUID="fd3f06b4-712a-4f52-a5d5-f3cf71d36b4e" TYPE="ext4" PARTUUID="8f772863-2862-4c75-bb52-30b2ee1e6902"
/dev/sdc1: UUID="2019-12-29-08-02-01-00" LABEL="MJRO1815" TYPE="iso9660"
/dev/sdc2: SEC_TYPE="msdos" LABEL_FATBOOT="MISO_EFI" LABEL="MISO_EFI" UUID="D1C7-AC88" TYPE="vfat"
[sauvage@sauvage ~]$ findmnt -s
TARGET SOURCE FSTYPE OPTIONS
/boot/efi UUID=FB2C-A3A8 vfat umask=0077
/ UUID=fd3f06b4-712a-4f52-a5d5-f3cf71d36b4e
ext4 defaults,noatime,discard
/tmp tmpfs tmpfs defaults,noatime,mode=1777
[sauvage@sauvage ~]$ findmnt /boot/efi
TARGET SOURCE FSTYPE OPTIONS
/boot/efi /dev/sdb1 vfat rw,relatime,fmask=0077,dmask=0077,codepage=437,iochar

Acer E5-573G-58BH

In the same link there is in [Some difficult UEFI setups] section with another link to Acer also with an Acer E5. Try the OP solution there and see if that helps.
There is another Acer link there but I think the previous link should work out.

2 Likes

Thank you, finally worked :smiley:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by