No dbus user and group created in i3 install via manjaro architect

Background: I tried to install i3 openrc with auto-install of free vid drivers (nouveau-bumblebee hybrid) twice yesterday. Xorg fails on first reboot. An i3 systemd install immediately after on different partitions, same laptop works fine.

I guess this an OpenRC problem rather than a Manjaro Architect problem. :confused:

The interim solution:
login as user and

sudo groupadd -r -g 81 dbus >/dev/null
sudo useradd -r -u 81 -d / -g dbus -s /usr/bin/nologin dbus >/dev/null
sudo shutdown -r now

and I can login through the gui, launch Palemoon and browse the net etc.
More details:
rc-status told me that elogind and dbus were stopped. I checked rc-update and both were already added to default runlevels. Couldn't rc-service start them because there is no dbus UID or GID.

After googling I found the arch package for dbus-nosystemd, git cloned it on another pc and cut and pasted the above commands from the .install file .

Sounds like that issue is related to this:

Yes. I've set myself a reminder & I'll mark this as solved when it's fixed.


It was fixed by the latest update of the package filesystem. Will not happen on new manjaro-architect installs anymore.


Nope. Fixed today in dbus-elogind.


Pretty sure this is no longer supported, the new nouveau hybrid driver is now


Or if you want to use bumblebee then the only option is


I guessed wrong then. The filesystem fix was a temporary one then, wasn't it?

It was whatever was installed by the
[*] Auto install NonFree drivers
Now overwritten by the latest 17.02 manjaro architect installed version of i3 14 hours ago.

Thanks to all. I'll mark this solved and start a new topic about the pacman-mirrors problem I discovered last night.
Edit: couldn't recreate pacman-mirrors problem this morning. :grinning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by