No Display using DisplayLink


I'm currently on Manjaro XFCE 20.04 using a Displaylink hub for dual monitors and getting zero output or registration of the monitors via dmesg.

I followed the steps on the following arch guide here... and got the below output.

Error! echo
Your kernel headers for kernel 5.6.19-2-MANJARO cannot be found at
/usr/lib/modules/5.6.19-2-MANJARO/build or /usr/lib/modules/5.6.19-2-MANJARO/source.
You can use the --kernelsourcedir option to tell DKMS where it's located.
error: command failed to execute correctly
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Install DKMS modules
==> Unable to install module evdi/1.8.0 for kernel 5.6.19-2-MANJARO: Missing kernel headers.
==> Unable to install module evdi/1.8.0 for kernel 4.14.188-1-MANJARO: Missing kernel modules tree.

This is my dir in 5.6.19-2-MANJARO:

build          modules.alias.bin          modules.dep      modules.symbols
extramodules   modules.builtin            modules.dep.bin  modules.symbols.bin
kernel         modules.builtin.alias.bin  modules.devname  pkgbase
kernelbase     modules.builtin.bin        modules.order    vmlinuz
modules.alias  modules.builtin.modinfo    modules.softdep

Did you install the Kernel Headers for your currently installed Kernels? This is a very important step.

sudo pacman -Syu linux56-headers linux414-headers

kernel 5.6 is end of life, you should upgrade to the latest supported kernel or downgrade to an lts version. Then install the missing headers and try again.

Thank you.

This plus a bit of configuring got me running. I appreciate it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by