No GRUB after installing Manjaro next to Windows 10

I followed this walk-through to install Manjaro and I don't have GRUB but I can use the system if I choose "Detect EFI bootloader" in the installer's menu.
I have an Acer Aspire A515-51G-51JP (UEFI)
I disabled fast startup. I am 100% sure that I wrote "/boot/efi" to the correct partition (even repeated multiple times just be sure).
When I enter "findmnt /boot/efi" I can't see $esp.
I tried these steps but they didn't help.
I also tried pressing F10 and F12 but nothing happened.

I really wanted to use a linux based system but I am running out of ideas.

First, make sure you have /boot/efi in your /etc/fstab of your installed OS (not livecd). You may want to go to the file manager to double-check. If it is not there, make entry for it there and then mount $esp as /boot/efi.

If you mare booted to installed OS (not livecd) and 'findmnt boott/efi" is there, do 2 commands.

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L “manjaro” -l “\EFI\Manjaro\grubx64.efi”

Note the second command above is for $esp in sda1. Change if $esp is not sda1.
Read this topic to read more about it..

If still unsure, provide (when you booted up to installed OS, the following)

sudo parted -l
sudo blkid
efibootmgr -v
findmnt -s

Good luck.

Reminder: the second command is important.

Thank you for helping!

It still doesn't work but I think there is a pretty big change that I mess up something in the second command.
This is what it's look like: sudo efibootmgr -c -d /dev/nvme0n1p2 -p 2 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

[ftibi93@tibi-pc ~]$ sudo parted -l
[sudo] password for ftibi93: 
Model: ATA WDC WD10SPZX-21Z (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  1000GB  1000GB  ntfs         Basic data partition  msftdata

Model: Unknown (unknown) // Samsung 960 EVO
Disk /dev/nvme0n1: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  524MB  523MB   ntfs            Basic data partition          hidden, diag
 2      524MB   628MB  104MB   fat32           EFI system partition          boot, esp
 3      628MB   645MB  16,8MB                  Microsoft reserved partition  msftres
 4      645MB   448GB  447GB   ntfs            Basic data partition          msftdata
 5      448GB   498GB  50,3GB  ext4
 6      498GB   500GB  2097MB  linux-swap(v1)

[ftibi93@tibi-pc ~]$ sudo blkid
/dev/nvme0n1: PTUUID="4b69a7ff-79b7-41bb-bfb5-422b8bf1cc19" PTTYPE="gpt"
/dev/nvme0n1p1: LABEL="HelyreM-CM-!llM-CM--tM-CM-!s" UUID="9474A9E574A9C9F6" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="5f97fd43-6eed-4539-adde-6c1083149a8f"     
/dev/nvme0n1p2: UUID="82AB-6344" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="d2511025-d32e-4af9-ad09-a5da41c97324"                                                 
/dev/nvme0n1p3: PARTLABEL="Microsoft reserved partition" PARTUUID="06018bc5-5aaa-44dc-8323-481ee4c1cdce"                                                                      
/dev/nvme0n1p4: UUID="4CEE5FB1EE5F9256" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="33338b84-f768-4a63-bad1-957740df62f4"                                          
/dev/nvme0n1p5: UUID="7fd7f002-85ee-4fe1-9900-da70274374d8" TYPE="ext4" PARTUUID="e21c1604-770f-4876-8fd6-66f694340d03"                                                       
/dev/nvme0n1p6: UUID="21c9737c-d243-4a3f-a34e-bd3b91fb90b1" TYPE="swap" PARTUUID="e1e614dd-a4c8-4323-a160-e67f32fb6b96"                                                       
/dev/sda1: LABEL="1TB" UUID="2EC64220C641E923" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="d6f00181-060f-400a-9f3f-1a261b780953"                                   
/dev/sdb1: UUID="2018-04-15-11-39-13-00" LABEL="MJRO1718" TYPE="iso9660" PARTUUID="4a3f4813-01"                                                                               
/dev/sdb2: SEC_TYPE="msdos" LABEL="MISO_EFI" UUID="8340-DE05" TYPE="vfat" PARTUUID="4a3f4813-02"

[ftibi93@tibi-pc ~]$ efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 2002,2003,2001,0001
Boot0000* USB HDD: SanDisk      PciRoot(0x0)/Pci(0x14,0x0)/USB(12,0)/HD(2,MBR,0x4a3f4813,0x3d6688,0x2000)RC
Boot0001* Windows Boot Manager  HD(2,GPT,d2511025-d32e-4af9-ad09-a5da41c97324,0xfa000,0x31800)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...,................
Boot2001* EFI USB Device        RC
Boot2003* EFI Network   RC

[ftibi93@tibi-pc ~]$ findmnt -s
TARGET    SOURCE                                    FSTYPE OPTIONS
/boot/efi UUID=82AB-6344                            vfat   defaults,noatime
/         UUID=7fd7f002-85ee-4fe1-9900-da70274374d8 ext4   defaults,noatime
swap      UUID=21c9737c-d243-4a3f-a34e-bd3b91fb90b1 swap   defaults,noatime

Should be

sudo efibootmgr -c -d /dev/nvme0n1 -p 2 -L “manjaro” -l “\EFI\Manjaro\grubx64.efi”

Try again. Let's hope for the best.

ps: check also if grubx64.efi is there in

sudo ls /boot/efi/EFI/manjaro/

Thank you very much!

Finally I formatted the system, deleted the Manjaro entry from grub, reinstalled Manjaro and ran the command you suggested.

Could you explain what that command does and what did I do wrong?

As I understand, @gohlip is trying to make a case to convince Manjaro Devs to patch/modify manjaro-grub to fix this issue.
And it looks like your case is a very convincing one.
I think you did nothing wrong.
Until now, cases like yours had to be corrected after applying the Tutorial's advice about it, as the link given by @gohlip.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by