No grub menu, XFCE. Lenovo V130

Solution: Make sure the laptop is in UEFI mode, mine was somehow set to Legacy. I accessed the bios via F2. Good luck!

Can't get the GRUB menu to show up on this nightmare of a laptop. I followed this guide which then led me onto this guide. Problem is I don't have any /boot/grub/x86_64-efi/ folder. Which I guess means my system is running in legacy bios mode?

Not sure where to go from here, I've output some stuff below, any guidance is greatly appreciated!

$ efibootmgr -v
EFI variables are not supported on this system.

$ sudo parted -l

Model: ATA HFS25
6G39TNF-N3A (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  256GB  256GB  primary  ext4


Model: Kingston DataTraveler 3.0 (scsi)
Disk /dev/sdb: 15.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2874MB  2878MB  4194kB  primary               esp


$ sudo blkid

/dev/sda1: UUID="ef5040cf-cdda-42c8-8126-0c2c2f3c0573" TYPE="ext4" PARTUUID="6adee05a-01"
/dev/sdb1: UUID="2019-12-10-10-55-03-00" LABEL="MJRO1814" TYPE="iso9660" PARTUUID="69ebf76c-01"
/dev/sdb2: SEC_TYPE="msdos" LABEL_FATBOOT="MISO_EFI" LABEL="MISO_EFI" UUID="874E-3279" TYPE="vfat" PARTUUID="69ebf76c-02"

$ findmnt -s

TARGET SOURCE                                    FSTYPE OPTIONS
/      UUID=ef5040cf-cdda-42c8-8126-0c2c2f3c0573 ext4   defaults,noatime,discard
/tmp   tmpfs                                     tmpfs  defaults,noatime,mode=1777
f$ findmnt /boot/efi
No output

Looks like.

The following might help:
sudo nano /etc/default/grub
Navigate with arrow keys to this line:
GRUB_TIMEOUT_STYLE=hidden
change hidden to menu.
Press Ctrl-o followed by Enter and finally Ctrl-x to exit nano.
sudo update-grub
Reboot.

Unfortunately it's already set to menu :(.

Not sure then what is going on. Please wait for other community members to chime in.

Thanks anyway! For now I am reinstalling the entire thing under UEFI (no idea why it was disabled) to try that work around posted in my second link.

Welp.

Reinstalled it with UEFI enabled. Booted no problem. Well, i'll update the OP.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by