No grub, WIN starts right away without option of choosing Manjaro

Thx for the quick reply, I ran into an error right away:

detected systems:
0) ManjaroLinux
select system to mount [0-0]:
0

ERROR: You can't mount 0!

I'm trying to follow a yt-vid now and see if I get it to work. Thx for putting me in the right direction.

Btw, any ideas what happened? I did install WIN first, followed by Manjaro :man_shrugging:

I'd try live booting a Manjaro USB stick, and use it to edit your Grub file in the installed Manjaro. You can check there if Win is set as the default boot option, and change the timeout (it may be set to hidden) so you can have 5 secs or so to choose your OS. It usually defaults to the last booted OS, but recent updates made changes to the Grub loader IIRC, which may have caused it not to appear on boot?

I'm sure someone with a more knowledgable noggin will correct me if I'm wrong :slight_smile:

Thx for the idea... I'm on it...

This didn't work, nice try thou... have to go the restore way now...

ok, I've tried all different methods, but no luck...

I finally get stuck at "EFI variables are not supported on this system"

When trying to do modprobe efivarfs I get an error: modprobe: FATAL: Module efivarfs not found in directory /lib/modules/4.19.28-1-MANJARO

I can see the efi partition, so I'm pretty sure that it's an efi and not a bios legacy system

famous last words. :cold_sweat:

2 Likes

Argh. Every YouTube video mentioned on the forum gets something wrong.

Use this instead:

1 Like

:stuck_out_tongue: well, I ended up with your restore grub link, but no dice

this has the same problem:

when typing manajro-chroot -a

dont enter 0, just hit enter or enter 1 instead even though it's not listed. it's a bug that's been there for a while

1 Like

:see_no_evil:

1 did work :+1:

sudo update-grub gave me an error:

cannot find a GRUB drive.... check device.map

post

lsblk
sudo parted -l

use the </> button when pasting terminal output so it's formatted properly

lsblk

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0    7:0    0    77M  1 loop /run/miso/sfs/livefs
loop1    7:1    0 274,7M  1 loop /run/miso/sfs/mhwdfs
loop2    7:2    0   1,1G  1 loop /run/miso/sfs/desktopfs
loop3    7:3    0 475,5M  1 loop /run/miso/sfs/rootfs
sda      8:0    0   477G  0 disk 
├─sda1   8:1    0   529M  0 part 
├─sda2   8:2    0   100M  0 part /mnt/mnt/boot/efi
├─sda3   8:3    0    16M  0 part 
├─sda4   8:4    0 105,2G  0 part /run/media/manjaro/74AA1421AA13DE84
├─sda5   8:5    0  21,5G  0 part /mnt/mnt
├─sda6   8:6    0 346,7G  0 part /run/media/manjaro/7cf9337f-943f-450d-a216-4ebe
└─sda7   8:7    0     3G  0 part 
sdc      8:32   0 931,5G  0 disk 
└─sdc1   8:33   0 931,5G  0 part 
sdd      8:48   1  14,5G  0 disk 
├─sdd1   8:49   1     2G  0 part /run/miso/bootmnt
└─sdd2   8:50   1     4M  0 part 
sr0     11:0    1  1024M  0 rom  

sudo parted -l

Modell: ATA SAMSUNG MZNLN512 (scsi)
Festplatte  /dev/sda:  512GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: gpt
Disk-Flags: 

Nummer  Anfang  Ende   Größe   Dateisystem     Name                          Flags
 1      1049kB  556MB  555MB   ntfs            Basic data partition          versteckt, diag
 2      556MB   661MB  105MB   fat32           EFI system partition          boot, esp
 3      661MB   677MB  16,8MB                  Microsoft reserved partition  msftres
 4      677MB   114GB  113GB   ntfs            Basic data partition          msftdata
 5      114GB   137GB  23,1GB  ext4
 6      137GB   509GB  372GB   ext4
 7      509GB   512GB  3146MB  linux-swap(v1)


Modell: ATA WDC WD10EZEX-60W (scsi)
Festplatte  /dev/sdc:  1000GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: gpt
Disk-Flags: 

Nummer  Anfang  Ende    Größe   Dateisystem  Name  Flags
 1      1049kB  1000GB  1000GB  ext4


Modell: TOSHIBA USB FLASH DRIVE (scsi)
Festplatte  /dev/sdd:  15,5GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags: 

Nummer  Anfang  Ende    Größe   Typ      Dateisystem  Flags
 2      2120MB  2125MB  4194kB  primary               esp

from chroot, run these

sudo mount /dev/sda2 /boot/efi
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
sudo update-grub

then post output of efibootmgr

[manjaro@manjaro-cinnamon ~]$ sudo manjaro-chroot -a
==> Mounting (ManjaroLinux) [/dev/sda5]
 --> mount: [/mnt]
mount: /mnt: /dev/sda5 already mounted on /mnt.
 --> mount: [/mnt/boot/efi]
 --> mount: [/mnt/home]
mount: /mnt/dev: udev already mounted on /mnt/dev.
[manjaro-cinnamon /]# 1
bash: 1: command not found
[manjaro-cinnamon /]# sudo mount /dev/sda2 /boot/efi
mount: /boot/efi: /dev/sda2 already mounted on /mnt/boot.
[manjaro-cinnamon /]# sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
Installing for x86_64-efi platform.
Installation finished. No error reported.
[manjaro-cinnamon /]# sudo update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-4.19-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your device.map.
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

this is normal, it's referring to your usb drive and cant find a grub partition on it.

?

BootCurrent: 000A
Timeout: 0 seconds
BootOrder: 0000,000A,000B,0007,0009,0008
Boot0000* manjaro
Boot0004* CD/DVD Drive
Boot0005* Hard Drive
Boot0006* Hard Drive
Boot0007* Windows Boot Manager
Boot0008* CD/DVD Drive
Boot0009* Hard Drive
Boot000A* UEFI: TOSHIBA
Boot000B* UEFI: TOSHIBA
1 Like

exit chroot with exit, then reboot and manjaro's grub should start first

1 Like

Awesome! So, it actually did work.

I simply got put off with this error which actually wasn't one! I should have tried some time in between!
Thanks a lot! :smile:

1 Like

Forum kindly sponsored by