No internet after install

I have a Gigabyte mobo with the same model number 970 it has USB and NIC issues on Linux. It must be loaded with special kernel parameters to function properly in Linux. It' possible this board has the same issues.

You need to check for a BIOS update for your MOBO and install it in WINDOWS.

https://ask.fedoraproject.org/en/question/37104/can-you-please-include-usb-drivers-for-msi-970a-g46-in-fedora-20/

Have you ever had any version of Linux installed on this computer with you onboard network adapter functioning correctly.

Have you experienced USB errors in Linux with this MOBO. The NIC and USB can both be affected.

You can try this fix if you experience USB or NIC issues.

Fix USB and NIC problems for some MOBOs

Try this fix to see if it corrects your issue.

You could try the"amd_iommu=on iommu=pt" boot option.

Edit /etc/default/grub and add "amd_iommu=on iommu=pt" to the the end of the load line:

GRUB_CMDLINE_LINUX="amd_iommu=on iommu=pt"

Before manjaro I had Ubuntu 18. And Internet was working there. I deleted it just before manjaro installation.

I'll try this mobo

And I'm having these kernel files but no idea how to install it. If didn't found option like that in MSM. I'm trying to find a terminal command for that, but I didn't found nothing yet.

Have you had USB issues on this MOBO. If not, you are best not to mess with things.

Those are not commands, they are kernel parameters. You must edit your grub load line to change those parameters. I think it would be far better if you didn't change anything there. If you mess it up your computer will not boot.

Can you post these please:

lsmod | grep r816

uname -r 

dmesg | grep error

Oh, I just googled that mobo means motherboard. I didn't knew about that. I have latest version of bios. And I didn't thought about that before, but I don't have WiFi on USB NC, beacuse my router is on the other side of the house (I'm not using wifi, beacuse on windows Ethernet works, and on my phone I have mobile transfer). I just remembered that on my phone I can't use WiFi when I'm in the same room the computer is. I'll try iommu and those 3 commands now

Please don't.

I don't want you to render your computer unbootable.

They are not commands they are kernel parameters.

Please just post the outputs I asked for.

1 Like
[qbsoon@Qbsoon ~]$ lsmod | grep r816
r8169                  90112  0
libphy                 77824  2 r8169,realtek
[qbsoon@Qbsoon ~]$ uname -r
4.19.0-3-MANJARO
[qbsoon@Qbsoon ~]$ dmesg | grep error
[qbsoon@Qbsoon ~]$ 

You are using the right driver now without conflicts, but you are still on kernel 4.19. You do not have any errors in your dmesg logs, which is good.

Like I said, I don't know how to install these kernel files. I've downloaded them from gitlab.manjaro.org

I don't know the source to download them from manually. Can you use your phone to search for instructions on "phone tethering". You really need some kind of internet connection on your computer to make things go quickly.

I know how to do tethering on USB with phone connected to computer, but i don't have much transfer. How big is 4.14?

Kernels are generally small in size. I don't know exactly.

I'll try that tomorrow.

@tbg: Why not use the Live-CD and download the kernel 4.14 (that is not really small) to the proper machine itself? If I understood the OP correct, that is ... and if I did, why did it work in live mode and not after installation?

@Qbsoon: If Manjaro 18.0 worked with ethernet in live mode, you may post the lsmod output of the live session?

The live mode will show it is using the kernel driver (r8169), the installed version uses the proprietary r8168 driver. As the live worked with r8169 that is why I advised him to use it, and uninstall the r8168 driver.

The live version uses the kerrnel modules for this NIC and also many broadcom adapters, but on the installed version the proprietary drivers are often installed by default. This leads to much confusion when it is working on the live , but not on the installed version.

Sitting back after the fact reading a thread it is often easy to pick up something that is overlooked. When you're juggling a couple or three support threads at the same time it's easy to miss something when other stuff is happening all at once. So, ya good idea he could use the live disk.

1 Like

As you can see:
image

there is no blacklist r816* in /etc/modprobe.d/blacklist
then:

lsmod | grep r816
r8169                  90112  0
libphy                 77824  3 r8169,realtek,tg3

It works only if i edit the /etc/dhcpcd.conf and i replace duid with clientid, set my router as DHCP server, then on my Connections the IPv4 to automatic and required, IPv6 to Ignored, and in General to all users might connect to this network.

To fix the speed on it (don't know why is affected) i comment the entry in /usr/lib/NetworkManager/conf.d/2*-connectivity.conf
After reboot i have all up and running 100%.

1 Like

I used USB thetering to download all updates and 4.14 kernel. Still problems with Ethernet.
@b_quest
Ok, I'll post lsmod.
@bogdancovaciu
I'll try that.

Forum kindly sponsored by