No keyboard light in HP | Ryzen | NVIDIA combo

Hi

I did a fresh install on an HP Gaming Pavilion 15 with Ryzen 5 3550H and a GTX 1050, SSD only.

So far so good but I have been completely unable to turn on the keyboard backlight. Let me explain properly because I have been doing some research.

First of all, have a look at this:

$ ls /sys/class/leds/
hp::hddprotect  input4::capslock  input4::numlock  input4::scrolllock
  • hddprotect is the orange led on the side of the laptop that lits up when the working with the hard drive. It does work and has values between 0 ands 255.

  • The other three are quite self-descriptive and can have values 0 or 1, but ONLY capslock works. It worked from the beginning and everytime I activate it it gets lit in the white led as it should. However, none of the other two have ever worked (the buttons do work, I always activate bloq num on start). So, doing something like the following changes the value but there is no light:

echo 1 | sudo tee /sys/class/leds/input4::numlock/brightness

Now, there is also my power button working and lit up all the time while the laptop is on, and the led for the charger which also works. None of these two have any entry in the leds folder, and...

What about the rest of the keyboard??? No brightness control in that folder and Fn+F5 does nothing at all (it is supposed to be that key combo to turn them on and off).

I have read multiple posts from the past year, all of them about different models of laptops and neither Ubuntu, Arch or Fedora being able to make the keyboard light work. It is as if it is not detected.

I am currently in kernel 5.4, but in some posts I read they said changing the kernel does nothing. I did find something useful here (see section Keyboard Light Patch):

This guy also had issues due to the AMD+NVIDIA combo and was eventually able to solve them all, including keyboard light... But the code is for an ASUS model and I have no idea how to make it work for my laptop.

PS. Also, whenever I boot or turn off the computer I get this, which I think is unrelated and probably refers to the display backlight, but I'm adding it here just in case:

[FAILED] Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0
See 'systemctl status systemd-backlight@backlight:acpi_video0.service' for details.
[OK] Started Load/Save Screen Backlight Brightness of backlight:amdgpu_b11

Your kernel does not support your hardware, so what you're seeing is to be expected.

Therefore:

  • Log off

  • Switch to TTY2 by pressing Ctrl+Alt+F2

  • Log in there

  • Execute:

    sudo mhwd-kernel --install linux56
    sudo mhwd-kernel --install linux57
    sudo reboot
    
  • Choose these kernels one by one in the advanced options of grub.

  • try if Fn+F5 works now.

Alternatively,

  • Verify it's not turned off in the UEFI firmware section.
  • If you still have the original HP Windows, turn the keyboard backlight on there and then reboot into Manjaro and see if that helps...

I have tried with 5.7 and nothing changes. I did install both but I cannot choose 5.6 because my grub is hidden and it never shows up even after running sudo grub-editenv - unset menu_auto_hide.

Not sure what you mean by firmware section but there is no option in the BIOS regarding keyboard light.

And unfortunately the laptop came without an OS (well, it did have FreeDOS), so no Windows.

EDIT: I was able to access grub by holding shift at boot and I can confirm that neither 5.6 nor 5.7 make a difference.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by