No more Login screen and xorg got deleted after uninstalling libinput drivers

It seems you broke more stuff, but maybe this will help.
From terminal run:
sudo chmod +s /usr/lib/kcheckpass
are those errors still present?
or maybe:
sudo touch /var/log/faillog
sudo chmod 600 /var/log/faillog

1 Like

If you don't use it, don't keep it. It will not be confusing later on :slight_smile:

1 Like

Ok, just rebooted my system and released I had a problem. If I entered my password at the login screen, the system would just get suck when I clicked login. Had to go into the terminal and removing the .xsession file made it work for me. Im not sure but this first code you sent seems to not work...

Not sure why though..

I have to investigate, and compare the 3 KDE Plasma installs i have, and see the difference. If the login works without it, is fine, no worries if is missing/removed/not present.

You mentioned that this was the .xsession file,

but the comment at the beginning of the file says ~/.xinitrc. Did I miss read what you said or did you accidentally paste the wrong file?

1 Like

Oh, you are totally right. I did a mistake with the name. Just a sec to correct that.
the .xsession is like this:

#!/bin/sh

#
# ~/.xsession
#
# Executed by xdm/gdm/kdm at login
#

[[ -f ~/.extend.xsession ]] && . ~/.extend.xsession

but the file i pointed out, the .xinitrc is the one i was referring and the content of it is for, in my previous post.

Ah, alright. glad that's resolved. I checked and I already had the same .xinitrc configured the same as way as the one you posted so no editing was needed.
Might want to make an edit in your original comment so others reading the post know not to use that file.
Edit:
woops, you already did

1 Like

Ok, I tried this, and the kcheckpass errors went away. The kernal and bubblebeed errors stayed though. https://pastebin.com/tQz98n2Y . Should I be concerned?

I checked and the file already existed and had the same permisions -rw-------.
Running cat /var/log/faillog returned nothing btw.

Well, you can turn the blind eye on, but is not a solution :slight_smile:
Regarding the iTCO_wdt what you can do is from terminal:
sudo nano /etc/modprobe.d/blacklist.conf
and add this to it:
blacklist iTCO_wdt
press Ctrl+O to save and Ctrl+X to exit

Regarding the nvidia load module error, since you are on 4.19 kernel see if bumblebee and linux419-bbswitch are installed, or you can either try the 4.20 kernel, make sure the linux420-bbswitch installs too ... If you do this from MSM Kernels there should be no issue, then reboot.
You have to be sure you followed just ONE of the how too bellow, and you didn't try to mix them up:

1 Like

Yep, both bumblebee and linux419-bbswitch are installed.

Also...

Were you telling me to follow one of the tutorials, or asking me if I followed them?

I never set anything up for the graphics managers. When installing Manjaro I just chose the 'proprietary drivers' option when booting the live Manjaro usb and then set it to use bumblebee drivers.

There are laptop models that need an intervention even tho the install was done automatically and appeared successful ... Since you have an error, the only way to fix it is to compare each points explained in the bumblebee tutorial.

1 Like

Ok, so would you recommend purging bumblebee and installing bumblebee/optimus-manager? Or should I try the rest of the steps in the bumblebee post besides installing?

Also, I just noticed that the NVIDIA X server settings application was no longer installed. Do you think it got uninstalled when x server got uninstalled? If so, are there some other nvidia specific programs that i should reinstall with it?

Yes, you will have to reinstall the driver. From terminal:
sudo mhwd -i pci video-hybrid-intel-nvidia-bumblebee

Open MWHD and there should be something like this

image

After reboot, check if is working by using this way

3 Likes
$ sudo mhwd -i pci video-hybrid-intel-nvidia-bumblebee
Warning: a version of config 'video-hybrid-intel-nvidia-bumblebee' is already installed!
Use -f/--force to force installation...

do i first use -r to remove bumblebee or use -f to force install?

Better as suggested -f
If you try to remove it, there might be something else that fails, not sure ...

1 Like

@bogdancovaciu I cannot thank you enough. If this was reddit, I would actually consider buying you reddit gold.

Everytime I even touched the nvidia files on my Ubuntu install, it would break everything, to the point where my system would be left in a complete mess if I did manage to recover it.

Seeing these problems here, I was planing to just reinstall Manjaro back to a clean state, because I thought this was beyond repair. But you managed to helped me even through all this, and for that I am extremely grateful.
Thank you so much for answering my hundreds of questions and patiently walking me through it all.

1 Like

I'm always glad to be able to help and i'm happy when the assistance is successful and the problems solved.
Cheers! :slight_smile:

3 Likes

No problem, write "Spende an @bogdancovaciu " :slight_smile:

Edit: Inspired :smiley: :wink: :slight_smile:

manjaro-Konto

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by