No (or wrong) icons in KDE task switcher

It started a few weeks ago (after some update). After doing search, I found many recent complaints about problems with icons, but they were related to other DEs or parts of the screen (toolbars, notification tray, and so on). I hope I'm not the only one who experiences this weird and annoying issue.

If I open multiple apps, sometimes the icon of FIRST app in the task switcher is not displayed. It happens randomly. In other words, I didn't notice any pattern - icon is properly displayed, then disappears minute later. Most often it starts working again after I open/close some other app. It only happens with FIRST app in the list (no matter which app it is) and usually happens 2-3 times per hour or so...

Another issue (which only happens a few times a day) is icon "switching". Let's say I have 3 apps opened - Claws Mail, Konsole, and Vivaldi. If 1st app's (Claws Mail in this example) icon disappears, it gets "moved" to 2nd app in the list, so Konsole displays Claws Mail icon now. It doesn't affect further (3rd, 4th, etc.) apps. Not a big deal, but it drives me crazy for weeks...

Tried cleaning all the cache, thumbnails and other stuff using BleachBit - no effect. I know it's hard to explain, so see the screenshot - (look for 1st app in the list)

Edit - another screenshot where you can see icon "switch" - - 1st app in Dolphin File Manager, 2nd - Vivaldi Browser. As you see, the icon of 1st app was removed and applied to next app in the list.

I can't reproduce the issue, and the way you describe it happening still leads me to conclude is something local, on your install. Have you made a TEST user, log in and check if this behavior is replicable in that session?
Also, have you shared anywhere the output of:
inxi -Fxxxza --no-host
or you can share it?
Use ``` above and bellow the text when you paste it here, for proper formatting.

Didn't try to setup new test user, but will do. And here's the info:

System:    Kernel: 5.4.43-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: initrd=\amd-ucode.img initrd=\intel-ucode.img initrd=\initramfs-5.4-x86_64.img 
           root=UUID=be0e04b0-4d88-4b9b-ac79-43280760dfe3 rw cryptdevice=UUID=c5ec2029-1a6c-4c75-a4f4-c60e6b010dd4:root 
           Desktop: KDE Plasma 5.18.5 tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: TUF B450-PLUS GAMING v: Rev X.0x serial: <filter> UEFI: American Megatrends 
           v: 2008 date: 12/06/2019 
Battery:   Device-1: hidpp_battery_0 model: Logitech M585/M590 Multi-Device Mouse serial: <filter> 
           charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Topology: 6-Core model: AMD Ryzen 5 3600X bits: 64 type: MT MCP arch: Zen family: 17 (23) model-id: 71 (113) 
           stepping: N/A microcode: 8701013 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 98440 
           Speed: 4100 MHz min/max: 2200/4100 MHz boost: enabled Core speeds (MHz): 1: 4097 2: 4101 3: 4102 4: 4097 5: 4105 
           6: 4094 7: 4096 8: 4097 9: 4098 10: 4097 11: 4098 12: 4104 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GP108 [GeForce GT 1030] vendor: Gigabyte driver: nvidia v: 440.82 bus ID: 09:00.0 
           chip ID: 10de:1d01 
           Display: x11 server: X.Org 1.20.8 driver: nvidia compositor: kwin_x11 tty: N/A 
           OpenGL: renderer: GeForce GT 1030/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 direct render: Yes 
Audio:     Device-1: NVIDIA GP108 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 09:00.1 
           chip ID: 10de:0fb8 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 0b:00.4 chip ID: 1022:1487 
           Sound Server: ALSA v: k5.4.43-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: f000 
           bus ID: 04:00.0 chip ID: 10ec:8168 
           IF: enp4s0 state: down mac: <filter> 
           Device-2: Broadcom and subsidiaries BCM4360 802.11ac Wireless Network Adapter vendor: ASUSTeK driver: wl v: kernel 
           port: f000 bus ID: 08:00.0 chip ID: 14e4:43a0 
           IF: wlp8s0 state: up mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 235.01 GiB (20.1%) 
           ID-1: /dev/nvme0n1 vendor: Silicon Power model: SPCC M.2 PCIe SSD size: 238.47 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: ECFM22.6 scheme: GPT 
           ID-2: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 023 scheme: GPT 
           ID-3: /dev/sdb vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 023 scheme: GPT 
RAID:      Supported md-raid types: raid1 
           Device-1: md0 type: mdraid status: active Components: online: sdb1~c1 sda1~c0 
           Info: raid: mirror blocks: 488253440 report: 2/2 UU chunk size: N/A super blocks: 1.2 
Partition: ID-1: / raw size: 237.97 GiB size: 233.23 GiB (98.01%) used: 12.20 GiB (5.2%) fs: ext4 dev: /dev/dm-0 
           ID-2: /boot raw size: 499.0 MiB size: 498.0 MiB (99.80%) used: 56.7 MiB (11.4%) fs: vfat dev: /dev/nvme0n1p1 
Sensors:   System Temperatures: cpu: 36.1 C mobo: N/A gpu: nvidia temp: 27 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:      Processes: 346 Uptime: 2m Memory: 15.64 GiB used: 2.14 GiB (13.7%) Init: systemd v: 245 Compilers: gcc: 10.1.0 
           Shell: zsh v: 5.8 running in: konsole inxi: 3.0.37 

Did you install the latest stable update?

I use OS daily, so I update it immediately after new release is available, but no updates are available today (yet). Will check for updates later today and post the result if new Qt solves the issue.

Sadly, the issue still exists after update. Will try creating new test account.

Is the application hardcode-fixer installed?

It's not installed. Should I go ahead and install it?


In case anyone else has the same issue, it looks I managed to solve it.

Since the issue didn't exist after creating a new account, I assumed it was local problem as @bogdancovaciu suggested in the first post. First of all, tried cleaning up all the caches, temporary files and every single possible data using BleachBit - no luck...

I got icons working again by changing standard task manager into "window list" (so icons were not displayed at all), running BleachBit, rebooting, changing back task manager to standard, and rebooting again. So far, the issue is gone for 3 days...

Just a friendly warning: this seems to cause some difficult to diagnose weirdness by itself for some users.

Well, I'm not 100% sure if this step was necessary, but I thought it won't hurt to clean all the cache after switching from normal task manager to window list manager (which has no icons).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by