No sound card found - HP Elitebook

Should I simply create the file and add the line options snd-intel-dspcfg dsp_driver=1 to it?

yes - you can create the file and add the line and it will work the same

i was trying for brevity, but missed an option in command (should have been sudo tee -a )

Ok, audio worked with dsp_driver=1. Then I altered the file to dsp_driver=3 and it returned to "dummy-output". Neither audio or mic.

To be sure, I've run again the LiveUSB with Ubuntu and I confirm that both audio and mic work fine there.

just out of curiosity: is the sof-firmware package installed? if not, you could install it and it should work. maybe you need to use pulseaudio-git as well. i have the same laptop and this solved it for me...

1 Like

I didn't have any of these packages. I installed both, but it didn't make a difference. Actually, with pulseaudio-git, I wasn't able to have audio with the kernel option described by @nikgnomic anymore, so I had to uninstall it and install pulseaudio again. sof-firmware is still there, but AFAIK makes no difference in the behavior.

Still no solution for mic in Manjaro in this laptop...

yes, this sounds like the issue me and others had. this thread seems to cover the problem. Manjaro Gnome - on fresh installation internal microphone doesn't work

in short, this is what i would suggest:

  1. make sure, sof-firmware is installed
  2. revert any kernel options you have set so far.
  3. install pulseaudio-git
  4. run the commands in the last post of the thread i linked here to make sure, pulseaudio starts when you login.
  5. reboot.

this should enable the microphone and solve the issue that pulseaudio thinks your soundcard is not available when no headphones are plugged in.

1 Like

Wow, everything works fine now.

What I did following your @thht steps:

  1. Reverted kernel back to 5.6.16
  2. Removed file /etc/modprobe.d/alsa-base.conf
  3. Checked whether sof-firmware was still installed and it was
  4. Installed again pulseaudio-git
  5. Run:
systemctl --user daemon-reload
systemctl --user enable pulseaudio pulseaudio.socket
systemctl --user restart pulseaudio pulseaudio.socket
  1. Rebooted
  2. Selected "speaker" as standard device, as HDMI was selected as standard

Now I can confirm that both audio and mic work fine. I'll mark this post as solved.

Thanks!

I'm in trouble again. Since the last Manjaro stable update, my laptop has had issues with the docking station (here: [Stable Update] 2020-07-19 - Kernels, KDE, LibreOffice, Mesa, Cinnamon, Deepin, Pamac, Browsers). I've realised that, while I'm having this issue with the update kernel 5.6.19-2, things are fine if I downgrade to kernel 5.4.52-1 LTS. But then mic doesn't work anymore, though audio works. I'm wondering if it would be easier to get mic working again (but now through kernel 5.4) than the issue with the docking station. FYI, I've run again @thht's steps with kernel 5.4 and it didn't work. I've tried also @nikgnomic's workaround and nothing.

try to upgrade to the current 5.7.9 kernel version and try again, please.

if that does not work, please provide the output of inxi -Fxc0 and pulseaudio --version

I failed to mention that I had tried the 5.7.9 kernel and had the same problem with my docking station. So, audio and mic are fine (as they are on 5.6.19), but the problem with the docking station remains. That is why I downgraded it to the first version that works with the docking station, and this is the 5.4, but then I have the mic issues.

kernel v5.6 was marked End Of Life in latest update

earlier kernels do not support sof-firmware drivers for internal microphone array

kernel v5.4 probably does not recognise the new modprobe option
before SOF support was available for older kernels, some systems needed an older modprobe option to disable internal microphone array - option options snd_hda_intel.dmic_detect=0
(Discord Screen Share Audio Not Working)

I'm running Ubuntu in a LiveUSB and voila, sound is there

latest Ubuntu 20.04 LTS is using pulseaudio v13.99
this is a release candidate version with most of the fixes for SOF drivers due for pulseaudio v14.0
installing pulseaudio-git for later version of pulseaudio was a confirmed solution for a Lenovo laptop
Lenovo ThinkPad X1 Carbon (Gen 7)

This means: either 5.7 or 5.4 LTS would be better options from now on, right?

In my laptop this is working only from kernel 5.6 on. On kernel 5.4, although I have pulseaudio-git (v. 13.99), mic is not recognised.

sorry, it somehow slipped my attention that you were talking about the docking station. which one do you have? the ultraslim dock? i have that one and i have not yet managed to get any audio working via that one (neither input nor output). however, that one does not have a builtin microphone.

and at least for me, the internal mic as well as the combined headphone/mic jack of the notebook itself keeps working on the current kernel with the pulseaudio-git version when it is in the docking station....

so, what kind of docking station do you have and what exactly do you mean when you say the mic is not working?

and yes, most probably, 5.4 is not an optimal kernel for your laptop but 5.7 is.

Yeah, it seems to be that one.

Actually I'm not trying to make audio/mic work through it. I was expecting audio/mic directly from the laptop. And this works under kernels 5.6 and 5.7 after those instructions you gave me (and also connected to the docking station). The problem is that, since the latest Manjaro stable release, the laptop is not loading SDDM in the boot with these kernels if connected to the docking station (it used to with kernel 5.6). So I had the idea to downgrade the kernel to 5.4 and the laptop managed to successfully boot, but then I have no mic anymore. I was wondering what is easier to solve: the boot thing with kernels 5.6 and 5.7 or the mic with kernel 5.4.

Ok. I've just installed it again and will try to find out how to boot (and load SDDM) with it. Thanks!

support for built-in digital microphones was not added until kernel v5.5 so i do not think there is a way to get microphone working on v5.4 kernel
if the boot problem can be resolved for kernel v5.7 microphone should be no problem

Thanks! Yes, this is the thing I'm trying now here. Mic works fine with kernel v5.7, so I just need to solve the booting thing with docking station.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by